Шпаргалка (БСП). Добавление в новый документ механизма печати дополнительных печатных форм

Публикация № 1132897

Разработка - Печать

БСП печать кнопка механизм печатные формы

Постоянно приходится вспоминать, как добавить механизм печати (БСП) в новый документ. Поэтому решил написать шпаргалку.

1. В форму документа добавить процедуры:

 
// СтандартныеПодсистемы.Печать
&НаКлиенте
Процедура Подключаемый_ВыполнитьКомандуПечати(Команда)	
	УправлениеПечатьюКлиент.ВыполнитьПодключаемуюКомандуПечати(Команда, ЭтаФорма, Объект);	
КонецПроцедуры 
// Конец СтандартныеПодсистемы.Печать

// СтандартныеПодсистемы.ПодключаемыеКоманды
&НаКлиенте
Процедура Подключаемый_ВыполнитьКоманду(Команда)
	ПодключаемыеКомандыКлиент.ВыполнитьКоманду(ЭтотОбъект, Команда, Объект);
КонецПроцедуры

&НаСервере
Процедура Подключаемый_ВыполнитьКомандуНаСервере(Контекст, Результат)
	ПодключаемыеКоманды.ВыполнитьКоманду(ЭтотОбъект, Контекст, Объект, Результат);
КонецПроцедуры

&НаКлиенте
Процедура Подключаемый_ОбновитьКоманды()
	ПодключаемыеКомандыКлиентСервер.ОбновитьКоманды(ЭтотОбъект, Объект);
КонецПроцедуры
// Конец СтандартныеПодсистемы.ПодключаемыеКоманды

 

2. Добавить в события формы документа:

 
&НаКлиенте
Процедура ПриОткрытии(Отказ)
	// СтандартныеПодсистемы.ПодключаемыеКоманды
	ПодключаемыеКомандыКлиент.НачатьОбновлениеКоманд(ЭтотОбъект);
	// Конец СтандартныеПодсистемы.ПодключаемыеКоманды
КонецПроцедуры
&НаСервере
Процедура ПриСозданииНаСервере(Отказ, СтандартнаяОбработка)
	// СтандартныеПодсистемы.ПодключаемыеКоманды
	ПодключаемыеКоманды.ПриСозданииНаСервере(ЭтотОбъект);
	// Конец СтандартныеПодсистемы.ПодключаемыеКоманды
КонецПроцедуры
&НаСервере
Процедура ПриЧтенииНаСервере(ТекущийОбъект)
	// СтандартныеПодсистемы.ПодключаемыеКоманды
	ПодключаемыеКомандыКлиентСервер.ОбновитьКоманды(ЭтотОбъект, Объект);
	// Конец СтандартныеПодсистемы.ПодключаемыеКоманды
КонецПроцедуры

 

3. В модуль менеджера нового документа 

 
#Если Сервер Или ТолстыйКлиентОбычноеПриложение Или ВнешнееСоединение Тогда

#Область Печать

// Заполняет список команд печати.
// 
// Параметры:
//   КомандыПечати - ТаблицаЗначений - состав полей см. в функции УправлениеПечатью.СоздатьКоллекциюКомандПечати
//
Процедура ДобавитьКомандыПечати(КомандыПечати) Экспорт
	
КонецПроцедуры

// Сформировать печатные формы объектов
//
// ВХОДЯЩИЕ:
//   ИменаМакетов    - Строка    - Имена макетов, перечисленные через запятую
//   МассивОбъектов  - Массив    - Массив ссылок на объекты которые нужно распечатать
//   ПараметрыПечати - Структура - Структура дополнительных параметров печати
//
// ИСХОДЯЩИЕ:
//   КоллекцияПечатныхФорм - Таблица значений - Сформированные табличные документы
//   ПараметрыВывода       - Структура        - Параметры сформированных табличных документов
//
Процедура Печать(МассивОбъектов, ПараметрыПечати, КоллекцияПечатныхФорм, ОбъектыПечати, ПараметрыВывода) Экспорт
	
	ФормированиеПечатныхФорм.ЗаполнитьПараметрыОтправки(ПараметрыВывода.ПараметрыОтправки, МассивОбъектов, КоллекцияПечатныхФорм);
	
КонецПроцедуры

Функция ДоступныеДляШаблоновПечатныеФормы() Экспорт
	
	МассивДоступныхПечатныхФорм = Новый Массив;
	
	Возврат МассивДоступныхПечатныхФорм

КонецФункции

#КонецОбласти

#КонецЕсли

 

4. В общий модуль УправлениеПечатьюПереопределяемый в процедуру ПриОпределенииОбъектовСКомандамиПечати добавить строчку.

 
Процедура ПриОпределенииОбъектовСКомандамиПечати(СписокОбъектов) Экспорт
	
	СписокОбъектов.Добавить(Документы.НовыйДокумент);
	
КонецПроцедуры

 

5. В модуль дополнительной печатной формы добавить процедуры

 
#Если Сервер Или ТолстыйКлиентОбычноеПриложение Или ВнешнееСоединение Тогда
	
#Область ПрограммныйИнтерфейс

Функция СведенияОВнешнейОбработке() Экспорт
	
	СведенияОВнешнейОбработке = ДополнительныеОтчетыИОбработки.СведенияОВнешнейОбработке("2.3.1.73");
	СведенияОВнешнейОбработке.Вставить("Вид", ДополнительныеОтчетыИОбработкиКлиентСервер.ВидОбработкиПечатнаяФорма());
	СведенияОВнешнейОбработке.Вставить("Назначение", ПолучитьНазначениеОбработки());
	СведенияОВнешнейОбработке.Вставить("Наименование", "Новый документ");
	СведенияОВнешнейОбработке.Вставить("Версия", "1.0");
	СведенияОВнешнейОбработке.Вставить("Информация", "Новый документ");
	СведенияОВнешнейОбработке.Вставить("БезопасныйРежим", Ложь);
	СформироватьСписокКоманд(СведенияОВнешнейОбработке.Команды);
	
	Возврат СведенияОВнешнейОбработке;
	
КонецФункции

Процедура Печать(МассивОбъектов, КоллекцияПечатныхФорм, ОбъектыПечати, ПараметрыВывода) Экспорт
	
	ПечатнаяФорма = УправлениеПечатью.СведенияОПечатнойФорме(КоллекцияПечатныхФорм, "НовыйДокумент");
	
	Если ПечатнаяФорма <> Неопределено Тогда
		ПечатнаяФорма.ТабличныйДокумент = СформироватьПечатнуюФорму(МассивОбъектов);
		ПечатнаяФорма.СинонимМакета = НСтр("ru = 'Новый документ'");
	КонецЕсли;
	
КонецПроцедуры

#КонецОбласти

Функция СформироватьПечатнуюФорму(МассивОбъектов) Экспорт
	
	Док = МассивОбъектов[0];
	
	//Тут заполняем печатную форму
	//Макет				=  ПолучитьМакет("Макет");
	//ОбластьЗаголовок	= Макет.ПолучитьОбласть("Заголовок");
	//ТабличныйДокумент.Вывести(ОбластьЗаголовок);
	
	ТабличныйДокумент	= Новый ТабличныйДокумент;	
	Возврат ТабличныйДокумент;
	
КонецФункции

#Область СлужебныеПроцедурыИФункции

Функция ПолучитьНазначениеОбработки()
	
	Результат = Новый Массив;
	
	Результат.Добавить("Документ.НовыйДокумент");
	
	Возврат Результат;
	
КонецФункции

Функция ПолучитьСтруктуруТаблицыКоманд()
	
	Результат = Новый ТаблицаЗначений;
	
	Результат.Колонки.Добавить("Представление",			Новый ОписаниеТипов("Строка"));
	Результат.Колонки.Добавить("Идентификатор",			Новый ОписаниеТипов("Строка"));
	Результат.Колонки.Добавить("Использование",			Новый ОписаниеТипов("Строка"));
	Результат.Колонки.Добавить("ПоказыватьОповещение",	Новый ОписаниеТипов("Булево"));
	Результат.Колонки.Добавить("Модификатор",			Новый ОписаниеТипов("Строка"));
	
	Возврат Результат;
	
КонецФункции

Процедура ДобавитьКоманду(Команды, Идентификатор, Представление, Использование, ПоказыватьОповещение = Ложь, Модификатор = Неопределено)
	
	НоваяКоманда = Команды.Добавить();
	
	НоваяКоманда.Идентификатор			= Идентификатор;
	НоваяКоманда.Представление			= Представление;
	НоваяКоманда.Использование			= Использование;
	НоваяКоманда.ПоказыватьОповещение	= ПоказыватьОповещение;
	НоваяКоманда.Модификатор			= Модификатор;
	
КонецПроцедуры

Процедура СформироватьСписокКоманд(Команды)
	
	ДобавитьКоманду(Команды, "НовыйДокумент", "Новый документ", ДополнительныеОтчетыИОбработкиКлиентСервер.ТипКомандыВызовСерверногоМетода(), Истина);
	
КонецПроцедуры

#КонецОбласти

#КонецЕсли

 

6. В форму списка документа добавить процедуры:

 
&НаСервере
Процедура ПриСозданииНаСервере(Отказ, СтандартнаяОбработка)
	// СтандартныеПодсистемы.Печать
	УправлениеПечатью.ПриСозданииНаСервере(ЭтаФорма, Элементы.ПодменюПечать);
	// Конец СтандартныеПодсистемы.Печать
КонецПроцедуры

#Область ОбработчикиКомандФормы

// СтандартныеПодсистемы.Печать
&НаКлиенте
Процедура Подключаемый_ВыполнитьКомандуПечати(Команда)
	
	УправлениеПечатьюКлиент.ВыполнитьПодключаемуюКомандуПечати(Команда, ЭтаФорма, Элементы.Список);
	
КонецПроцедуры
// Конец СтандартныеПодсистемы.Печать

&НаКлиенте
Процедура Подключаемый_ВыполнитьПереопределяемуюКоманду(Команда)
	
	СобытияФормКлиент.ВыполнитьПереопределяемуюКоманду(ЭтаФорма, Команда);
	
КонецПроцедуры

#КонецОбласти

// СтандартныеПодсистемы.ПодключаемыеКоманды
&НаКлиенте
Процедура Подключаемый_ВыполнитьКоманду(Команда)
	ПодключаемыеКомандыКлиент.ВыполнитьКоманду(ЭтотОбъект, Команда, Элементы.Список);
КонецПроцедуры

&НаСервере
Процедура Подключаемый_ВыполнитьКомандуНаСервере(Контекст, Результат)
	ПодключаемыеКоманды.ВыполнитьКоманду(ЭтотОбъект, Контекст, Элементы.Список, Результат);
КонецПроцедуры

&НаКлиенте
Процедура Подключаемый_ОбновитьКоманды()
	ПодключаемыеКомандыКлиентСервер.ОбновитьКоманды(ЭтотОбъект, Элементы.Список);
КонецПроцедуры
// Конец СтандартныеПодсистемы.ПодключаемыеКоманды

Добавить в командную панель ПодменюПечать:

Тестировал на:

1С:Предприятие 8.3 (8.3.13.1644)

1С:Комплексная автоматизация 2 (2.4.6.207)

Специальные предложения

Комментарии
Избранное Подписка Сортировка: Древо
1. MSK_Step 19 10.10.19 15:15 Сейчас в теме
класс, надо такие же сделать на версионирование, дату запрета редактирования и другие полезные фишки
2711640; Светлый ум; DrAku1a; Sergafan10; +4 Ответить
2. Sergafan10 10.10.19 15:18 Сейчас в теме
(1) с версионированием каждый раз велосипед изобретать приходится))
6. John_d 2137 11.10.19 10:34 Сейчас в теме
(1) Версионирование
1. Добавить Новый объект в Подписки на события "ЗаписатьВерсиюДокумента"
2. Добавить Новый объект в Определяемые типы "ВерсионируемыеДанные"
3. В режиме предприятия настроить хранение данных:
Администрирование -> Общие настройки -> История изменений -> Настройки хранения
В списке объектов найти новый объект и поставить напротив него "При записи"
Риник; AgeevVG; fight1c; glorry; +4 Ответить
8. MSK_Step 19 11.10.19 11:50 Сейчас в теме
(6) Вы забыли про код в форме при создание на сервере
// СтандартныеПодсистемы.ВерсионированиеОбъектов
ВерсионированиеОбъектов.ПриСозданииНаСервере(ЭтотОбъект);
// Конец СтандартныеПодсистемы.ВерсионированиеОбъектов

и другие нюансы, про которые незнаете и надо внимательно читать на ИТС

Как для этого такие "Подсказки" помогают, когда ночью уже голова не соображает, то такие пошаговые выручают, так как зачем это все помнить
13. Риник 23.01.20 13:35 Сейчас в теме
3. dock 35 10.10.19 19:11 Сейчас в теме
Для идеальности не хватает только указания версии БСП....
Автору огромный плюс!
Риник; +1 Ответить
4. ColaKola 14 10.10.19 22:05 Сейчас в теме
чем вас не устроила ссылка на официальную документацию в избранном?
Casey1984; dhurricane; aegoncharov; Labotamy; Йожкин Кот; Sashares; asupsam; +7 3 Ответить
5. Labotamy 10.10.19 22:21 Сейчас в теме
ИТС не предлагать?
Casey1984; Sashares; +2 Ответить
7. MSK_Step 19 11.10.19 11:43 Сейчас в теме
(5)ахаха, вы сравнили, тут все четко разложено, там надо вникать. Я уверен на 100%, что вы у себя при разработке нового документа забиваете на все версионирования, даты запрета, рлс потому что неохота лезть на итс))
milov.aleksey; +1 1 Ответить
10. Labotamy 11.10.19 13:30 Сейчас в теме
Не увидел указания под какую версию БСП этот "склерозник"?
Дмитрий74Чел; aegoncharov; +2 Ответить
11. wolfsoft 2420 14.10.19 07:59 Сейчас в теме
Как уже писали в комментариях, вам для каждой версии БСП придётся писать отдельные шпаргалки.
14. AlX0id 13.02.20 09:50 Сейчас в теме
(11)
Если бы авторы БСП хоть чуть-чуть думали головой о последствиях изменений в оной - пришлось бы реже, чем для каждой. Но де-факто да.
12. grayskin 20.11.19 10:18 Сейчас в теме
Не забыть еще в Свойствах Формы События Процедуры прописать
Прикрепленные файлы:
Оставьте свое сообщение

См. также

Печать ценников номенклатуры с несколькими видами цен для 1С: Розница

Статья Программист Нет файла v8 Розница Розничная и сетевая торговля (FMCG) Бесплатно (free) Ценники

Простое решение для печати ценника с несколькими видами цена для 1С: Розница версий 2.2.ХХХХ-2.3.ХХХХ, механизм апробирован на версии 2.3.1.40.

23.12.2019    983    independ    0       

Подборка решений для взаимодействия со ФГИС «Меркурий» Промо

С 1 июля 2019 года все компании, участвующие в обороте товаров животного происхождения, должны перейти на электронную ветеринарную сертификацию (ЭВС) через ФГИС «Меркурий». Инфостарт предлагает подборку программ, связанных с этим изменением.

[БСП] Внешняя печатная форма: как перед печатью выводить форму настроек

Статья no Нет файла v8 КА2 Бесплатно (free) Печатные формы документов БСП (Библиотека стандартных подсистем)

Во внешней печатной форме перед печатью нужно выводить форму настроек. Для примера рассматриваю печатную форму "Акт сверки взаимных расчетов " .

19.12.2019    4481    1    John_d    7       

INFOSTART MEETUP Krasnodar. 14 февраля 2020 г. Промо

Краснодар станет первым в 2020 году местом, где пройдет региональная встреча IT-специалистов сообщества Инфостарт. Тема мероприятия - управление и технологии автоматизации учета на платформе "1С: Предприятие". Стоимость участия - 5000 рублей. Цена действительна до 26.12.2019.

Реализация команды печати "Библиотека стандартных подсистем", редакция 3.1 (3.1.1.151)

Статья Программист Нет файла v8 1cv8.cf Бесплатно (free) БСП (Библиотека стандартных подсистем)

В новом релизе "БСП" произошли изменения в процедурах общих модулей, связанных с механизмом печати, и в процедурах их вызова в формах документов и в формах списков. Рассмотрим их.

12.10.2019    2666    paulis    4       

Базовый курс по обмену данными в системе 1С:Предприятие. Онлайн-интенсив с 12 по 28 мая 2020 г. Промо

Данный онлайн-курс предусматривает изучение механизмов платформы “1С:Предприятие”, обеспечивающих обмен данными между различными прикладными 1С-решениями и взаимодействие с другими информационными системами. Курс предназначен для тех, кто уже имеет определенные навыки конфигурирования и программирования в системе “1С:Предприятие”.

5500 рублей

Голосование за доклады на INFOSTART MEETUP Kazan - до 25 февраля. Промо

Выбирайте и голосуйте за самые интересные доклады! Лучшие из лучших попадут в окончательную программу казанского митапа. Оставить свой голос можно до 25 февраля 2020 года.

Подсистема "Варианты отчетов". Используете ли Вы ее правильно?

Статья Программист Нет файла v8 1cv8.cf Бесплатно (free) Работа с интерфейсом БСП (Библиотека стандартных подсистем)

Небольшая история про использование подсистемы "Варианты отчетов" из БСП. Используете ли Вы ее правильно?

04.06.2019    25570    YPermitin    49       

Подсистема БСП «Управление доступом», основные объекты и регистры

Статья Программист Нет файла v8 v8::УФ v8::Права 1cv8.cf Бесплатно (free) БСП (Библиотека стандартных подсистем) Роли и права

Основные принципы работы подсистемы «Управление доступом» из состава БСП. Виды доступа, ограничение доступа на уровне записей. Описание основных объектов и регистров, используемых подсистемой.

23.05.2019    13561    ids79    8       

INFOSTART MEETUP Kazan. 13 марта 2020 г. Промо

Инфостарт продолжает путешествие по России. Следующая остановка - Казань. Тема мероприятия - управление и технологии автоматизации учета на платформе "1С: Предприятие". Ждем всех: докладчиков и участников! Стоимость участия - 5 500 рублей. Цена действительна до 30.01.2020

5 500

Универсальная Форма для внешней печатной формы документа

Статья Программист Стажер Нет файла v8 1cv8.cf Бесплатно (free) Печатные формы документов

Универсальная форма вызова процедуры "Печать(МассивОбъектов, КоллекцияПечатныхФорм, ОбъектыПечати, ПараметрыПечати)", чтобы каждый раз не изобретать велосипед! Реализация протестирована на 1С 8.3.12.1714 (x64).

10.05.2019    4704    Eret1k    4       

Реализация интерактивного редактирования макета Microsoft WORD из 1С для пользователя

Статья Программист Нет файла v8 1cv8.cf Windows Бесплатно (free) Печатные формы документов Практика программирования Разработка

Пользователь сам сможет редактировать макет Microsoft Word и в последствии использовать его для печати документа, справочника и т.д. Реализация протестирована на 1С 8.3.12.1714 (x64).

23.04.2019    3870    Eret1k    6       

Онлайн-курс "Подготовка к экзамену 1С:Эксперт и 1С:Профессионал по технологическим вопросам" с 7 по 24 апреля 2020 г. Промо

На курсе вы получите практические навыки решения задач производительности 1С, в том числе характерных для высоконагруженных информационных систем (более 1000 пользователей). Подготовка к экзамену – только одна из составляющих курса. 70% слушателей приходят за знаниями, которые позволят расти и зарабатывать, делать сложные задачи на крупных проектах.

16450 рублей

Добавление отчетов в типовые конфигурации 1С

Статья Программист Нет файла v8::УФ v8::СКД 1cv8.cf Бесплатно (free) Практика программирования Универсальные функции БСП (Библиотека стандартных подсистем)

Описание различных способов добавления общих и контекстных отчетов в конфигурации 1С, построенные на базе БСП. Основные моменты и нюансы.

07.03.2019    35996    ids79    45       

Возможности типовых шаблонов ограничения доступа на уровне записей (RLS)

Статья Программист Нет файла v8 v8::Права Бесплатно (free) Практика программирования БСП (Библиотека стандартных подсистем) Роли и права

Краткий обзор применения типовых шаблонов ограничения доступа на уровне записей в конфигурациях, созданных на базе БСП: #ПоЗначениям, #ПоНаборамЗначений, #ПоЗначениямРасширенный, #ПоЗначениямИНаборамРасширенный

03.02.2019    24124    ids79    9       

1C:Предприятие для программистов: Запросы и отчеты. Второй поток. Онлайн-интенсив с 17 марта по 16 апреля 2020 г. Промо

Данный онлайн-курс предусматривает углубленное изучение языка запросов и возможностей системы компоновки данных, которые понадобятся при разработке отчетов, работающих на платформе “1С:Предприятие” в рамках различных прикладных решений. Курс предназначен для тех, кто уже имеет определенные навыки конфигурирования и программирования в системе “1С:Предприятие”, а также для опытных пользователей различных прикладных решений, которые используют в своей работе отчеты разного назначения.

6500 рублей

Сдача 2-НДФЛ за 2018 год из конфигурации Зарплата и Управление Персоналом, редакция 2.5 (2.5.130.2)

Статья Бухгалтер Нет файла v8 v8::СПР ЗУП2.5 Россия БУ Windows Зарплата НДФЛ Бесплатно (free) Регламентированная отчетность

В статье я пошагово описал процесс сдачи отчётности из 1С ЗУП редакции 2.5 через программу "Налогоплательщик ЮЛ". Весь процесс я разбил на 5 шагов, подробно и с картинками описал каждый шаг.

05.01.2019    19756    busa_nn    23       

Макеты печатных форм в руках пользователей (обычные формы)

Статья Программист Нет файла v8 Россия Бесплатно (free) Универсальные печатные формы Практика программирования

Как частично избавить себя от низкопрофильного труда по правке печатных форм. Для конфигураций на основе БСП, конечно, не актуально, но для нетиповых вполне. Ну и как в помощь начинающим. У меня реализовано для печати различных "согласие на обработку персональных данных","согласие на медицинские вмешательства", различных анкет. Удобно для печатных форм, которые часто по тем или иным причинам меняются. Чтоб не дергать программиста, пусть пользователи рисуют макеты самостоятельно.

01.11.2018    5666    fromlion    3       

Готовые переносы данных из различных конфигураций 1C Промо

Рекомендуем готовые решения для переноса данных из различных конфигураций 1C. C техподдержкой от разработчиков и гарантией от Инфостарт.

Пакетная печать в строго заданном порядке

Статья Программист Нет файла v8 1cv8.cf Windows Бесплатно (free) Пакетная печать

В силу различных особенностей ПО, ОС, драйверов и т.д. порядок печати документов не всегда совпадает с порядком их отправки на печать. Данный метод позволяет всегда получать на выходе нужный порядок документов.

19.09.2018    6820    crazycat    20       

Добавление команд печати в конфигурациях на БСП 2.4.3 (в частности, в самописных документах в Бухгалтерии 3.0 после релиза 3.0.52.35)

Статья Программист Нет файла v8 v8::БУ БП3.0 Россия Бесплатно (free) Печатные формы документов Практика программирования БСП (Библиотека стандартных подсистем)

В статье https://infostart.ru/public/237013/ пользователя nick max рассматривался список действий для подключения команд печати в Бухгалтерии 3.0, работающей на БСП 2.3.6. В новом релизе Бухгалтерии 3.0.52.35 от 15.09.2017г. стала использоваться БСП 2.4.3, из-за чего произошли изменения в процедурах общих модулей, связанных с механизмом печати, и в процедурах их вызова в формах документов и в формах списков. Рассмотрим их.

18.09.2017    55673    bugtester    49       

Программы для исполнения 54-ФЗ Промо

С 01.02.2017 контрольно-кассовая техника должна отправлять электронные версии чеков оператору фискальных данных - правила установлены в 54-ФЗ ст.2 п.2. Инфостарт предлагает подборку программ, связанных с применением 54-ФЗ, ККТ и электронных чеков.

БСП. Настраиваемый комплект документов. Внешние печатные формы

Статья Программист Нет файла v8::СПР v8::УФ ЗУП3.x Бесплатно (free) Печатные формы документов

В демо-конфигурации "БСП" есть пример реализации механизма "Настраиваемый комплект документов", использующий встроенные печатные формы. Эта статья - развитие темы в сторону использования в своей обработке других внешних печатных форм.

09.06.2017    19983    WhiteOwl    12       

Фоновое формирование отчета СКД на УФ средствами БСП

Статья Программист Нет файла v8::УФ v8::СКД Бесплатно (free) Практика программирования БСП (Библиотека стандартных подсистем)

В узких кругах широко известна проблема, когда штатное фоновое формирование отчета СКД на управляемых формах перестает работать при выполнении нештатной компоновки (переопределении события ПриКомпоновкеРезультата). В этом случае клиент ожидает ответа сервера и сеанс 1С "висит", что жутко неудобно при формировании затратных по времени отчетов. Также нет возможности прервать такое выполнение. Когда мириться с этим стало тяжело, стал искать решения, но почему-то подходящего готового рецепта не нашел. Если плохо искал, значит, будет еще один в копилку.

16.05.2017    24996    herfis    9       

Подборка программ для взаимодействия с ЕГАИС Промо

ЕГАИС (Единая государственная автоматизированная информационная система) - автоматизированная система, предназначенная для государственного контроля за объёмом производства и оборота этилового спирта, алкогольной и спиртосодержащей продукции. Инфостарт рекомендует подборку проверенных решений для взаимодействия с системой.

Библиотека стандартных подсистем (Механизм БСП)

Статья Программист Нет файла v8 1cv8.cf Бесплатно (free) Практика программирования БСП (Библиотека стандартных подсистем)

Конфигурации в 1С пишутся для пользователей и по их «правилам» (клиент всегда прав), поэтому в основном все конфигурации разные, но достаточно часто в них используются одни и те же объекты, которые незначительно отличаются друг от друга. Действительно, сложно представить конфигурацию, где не фигурировали бы такие сущности как номенклатура, контрагенты, пользователи, валюта. И некоторые задачи являются типичными: возможность базового разграничения прав, работа с электронной почтой, задачи пользователям и т.д. Но...!

03.03.2017    58336    V.Stavinsky    21       

Кубик-рубик для деклараций 11 и 12 по данным 1С.Розница, ЕГАИС и других программ и источников. (Сбор/разбор деклараций на части и их анализ)

Статья Бухгалтер Нет файла v8::ОУ Розница Россия БУ УУ Windows Розничная торговля Бесплатно (free) Регламентированная отчетность Бухгалтерский учет

Рассмотрены самые сложные ситуации(даже когда все данные утеряны). Алкогольные декларации 11 и 12 по данным 1С.Розница и других программ и источников.(Сбор/разбор деклараций на части и их анализ). "Приготовление" деклараций с учетом заданных/требующихся входных/выходных параметров. Рассматриваем самые сложные(изначально кажущиеся безвыходными) ситуации. Подходит тем, кто окончательно запутался в связи с введением ЕГАИСа в розничное звено.

09.12.2016    19960    liginrambler    7       

Новый раздел на Инфостарте - Electronic Software Distribution Промо

Инфостарт напоминает: на нашем сайте можно купить не только ПО, связанное с 1С. В нашем арсенале – ESD-лицензии на ПО от ведущих вендоров: Microsoft, Kaspersky, ESET, Dr.Web, Аскон и другие.

  • Низкие цены, без скрытых платежей и наценок
  • Оперативная отгрузка
  • Возможность оплаты с личного счета (кешбек, обмен стартмани на рубли и т.п.)
  • Покупки идут в накопления для получения скидочных карт лояльности Silver (5%) и Gold (10%)

Используем механизмы обмена данными БСП для произвольного обмена

Статья Программист Нет файла v8 Бесплатно (free) Универсальные функции Внешние источники данных БСП (Библиотека стандартных подсистем)

Механизм БСП заточен на обмен XML по правилам обмена. Чтобы использовать его для любого другого обмена, коих в мире немало, требуются доработки. В статье описан вариант, как из положения выйти.

23.08.2016    30381    Патриот    28       

1C:Предприятие для программистов: Расчетные задачи (зарплата). Онлайн-интенсив с 01 по 17 июня 2020 г. Промо

Данный онлайн-курс предусматривает изучение механизмов платформы “1С:Предприятие”, которые предназначены для автоматизации периодических расчетов, а именно - для расчета зарплаты. Курс предназначен для тех, кто уже имеет определенные навыки конфигурирования и программирования в системе “1С:Предприятие”, а также для опытных пользователей прикладного решения “1С:Зарплата и управление персоналом” и прочих прикладных решений, в которых реализован функционал расчета зарплаты.

4900 рублей

Как устроена регламентированная отчетность в 1С

Статья Программист Нет файла v8 1cv8.cf Россия БУ Windows Бесплатно (free) Практика программирования Регламентированная отчетность

Регламентированная отчетность - это универсальный механизм конфигураций 1С. Принцип её работы во всех конфигурациях идентичен, различаются только источники данных для заполнения. Поэтому, раз познакомившись, Вы сможете использовать эти знания в любых конфигурациях.

30.11.2015    62484    mrXoxot    29       

Отладка конвертации данных 2.1 в конфигурациях, построенных на БСП 2.1 (БП 3.0, УТ 11 etc.)

Статья Программист Нет файла v8 1cv8.cf Windows Бесплатно (free) Практика программирования Распределенная БД (УРИБ, УРБД) Обмен через XML БСП (Библиотека стандартных подсистем)

Отладка процесса выгрузки/загрузки данных при проведении синхронизации в новых конфигурациях 1С может вызвать (у меня вызвала) некоторые затруднения. О них и пойдёт речь.

29.10.2015    35020    NittenRenegade    19