Повторяющиеся логины пользователей

Публикация № 1179080

Администрирование - Информационная безопасность - Роли и права

В этой статье хочу предложить для рассмотрения небольшую но полезную обработку, которая работает в режиме внешней обработки и выявляет задвоенные логины пользователей. Обработка предназначена для работы в клиент-серверных базах и тестировалась на платформе 8.3.14.1854.

Задача возникла в результате того, что я работаю в специфической организации,
где часто идет ротация пользователей(
например аудиторы заходят или фискалы, за раз до 50-60 пользователей). В результате довольно
частая ситуация появляются в базе пользователи с одинаковыми логинами и их надо отлавливать периодически.
Эта обработка дает возможность это делать, плюс парочка дополнительных
возможностей, просмотр всех пользователей и просмотр работающих пользователей. Обработка используется на практике. 

 

Представляю скриншоты которые показывают три закладки на форме обработки:

 

1. Отображены все пользователи

2. Отображены двойные логины

3. Отображены работающие пользователи

Программа запускается как внешняя обработка:

&НаКлиенте
Процедура ПриОткрытии(Отказ)

		ОбработкаСписка();

КонецПроцедуры

    На форме обработки имеется кнопка "Инструкция", которая запускает процедуру ИнструкцияПоЭксплуатации(Команда):

&НаКлиенте
 Процедура ИнструкцияПоЭксплуатации(Команда)
//Процедура выводит текстовый файл Инструкция по эксплуатации     
    Инструкция="          Инструкция на обработку двойной логин."+Символы.ПС+" 
    |1. На закладке ""Все пользователи"" отображаются все пользователи базы."+Символы.ПС+"
    |2. На закладке ""Двойные логины"" отображаются пользователи с повторяющимися логинами (выбираются только действующие пользователи)."+Символы.ПС+"
    |3. На закладке ""Список рабочих пользователей"" отображаются только действующие пользователи";
    
    Предупреждение(Инструкция);
    
КонецПроцедуры

    Следующая процедура заполняет три закладки, которые указаны выше на скриншотах.
Подробно работа процедуры описана в комментариях.

&НаСервере
Процедура ОбработкаСписка()
		ТаблицаСписокПользователей.Очистить();
		ТаблицаДействующихПользователей.Очистить();
		ПорядковыйНомер=0;
		
		//Создаем Массив пользователей Информационной Базы для изменения доменов *****************************
		Выборка= ПользователиИнформационнойБазы.ПолучитьПользователей();                           //Получаем массив пользователей и  из массива выбираем нужного пользователя по идентификатору
		Для Каждого ЭлементМассива Из Выборка Цикл
			ПолноеИмяПользователя=ЭлементМассива.ПолноеИмя;                                        //Из массива забираем полное имя пользователя
			ПользовательУникльныйИдентификатор=ЭлементМассива.УникальныйИдентификатор;             //Из массива забираем уникальный идентификатор пользователя
			ДоменЛогин=ЭлементМассива.ПользовательОС;                                              //Из Массива забираем домен логин пользователя
			
			Запрос = Новый Запрос;                                                                 //Определяем текущего пользователя в справочнике Пользователи 
			Запрос.Текст = 
			"ВЫБРАТЬ
			|	Пользователи.Наименование КАК Наименование,
			|	Пользователи.ПометкаУдаления КАК ПометкаУдаления
			|ИЗ
			|	Справочник.Пользователи КАК Пользователи
			|ГДЕ
			|	Пользователи.ИдентификаторПользователяИБ = &ПользовательУникльныйИдентификатор"
			;
			Запрос.УстановитьПараметр("ПользовательУникльныйИдентификатор",ПользовательУникльныйИдентификатор);
			РезультатЗапроса = Запрос.Выполнить();
			Выборка = РезультатЗапроса.Выбрать();                                
			Пока Выборка.Следующий() Цикл
				Если Выборка.ПометкаУдаления=Ложь Тогда
					ПометкаУдаленияПользователя = "Действует";                                       //Записываем результат ПометкаУдаления
				Иначе
					ПометкаУдаленияПользователя = "Удален";
				КонецЕсли;		
			КонецЦикла; 
			
			//****************************************************************************************************				  
			Если НЕ	ДоменЛогин="" Тогда		                                                         //Выделяем из ДоменЛогин Домен и логин
				ДлинаДомена=СтрДлина(ДоменЛогин);
				ДоменПользователя="";
				ЛогинПользователя="";
				Буква="";
				СчетчикБукв=3;
				Буква=Сред(ДоменЛогин,СчетчикБукв,1);
				ФлагДЛ="Д";
				Пока СчетчикБукв <= ДлинаДомена Цикл
					Если Буква="\" Тогда
						ФлагДЛ="Л";
						СчетчикБукв=СчетчикБукв+1;
						Буква=Сред(ДоменЛогин,СчетчикБукв,1);
					Иначе
						Если ФлагДЛ="Д" Тогда
							ДоменПользователя=ДоменПользователя+Буква; 
							СчетчикБукв=СчетчикБукв+1;
							Буква=Сред(ДоменЛогин,СчетчикБукв,1);  
						КонецЕсли;
						Если ФлагДЛ="Л" Тогда
							ЛогинПользователя=ЛогинПользователя+Буква; 
							СчетчикБукв=СчетчикБукв+1;
							Буква=Сред(ДоменЛогин,СчетчикБукв,1);  
						КонецЕсли;
					КонецЕсли;
				КонецЦикла;
			Иначе
				ЛогинПользователя="";
				ДоменПользователя="";
			КонецЕсли;
//***************************************************************************************************************************************************
//Заносим в таблицу всех пользователей по списку*****************************************************************************************************
			ПорядковыйНомер=ПорядковыйНомер+1;
			Строка=ТаблицаСписокПользователей.Добавить(); 
			Строка.ПорядковыйНомер=ПорядковыйНомер;
			Строка.ПолноеИмяПользователя=ПолноеИмяПользователя;                               
			Строка.ПользовательУникльныйИдентификатор =ПользовательУникльныйИдентификатор;
			Строка.ДоменЛогин=СокрЛП(ДоменЛогин);
			Строка.ДоменПользователя =СокрЛП(ДоменПользователя) ;
			Строка.ЛогинПользователя =СокрЛП(ЛогинПользователя) ;
			Строка.ПометкаУдаления=ПометкаУдаленияПользователя;
		КонецЦикла;
		ПорядковыйНомер=0;
		Запрос = Новый Запрос;
		ТСП = РеквизитФормыВЗначение("ТаблицаСписокПользователей",Тип("ТаблицаЗначений"));           //Выгружаем Табличный реквизит формы в переменную
		МВТ=Новый МенеджерВременныхТаблиц;                                                           //Создаем МенеджерВременныхТаблиц
		Запрос.МенеджерВременныхТаблиц=МВТ;
//Помещаем таблицу пользователей во временную таблицу и из нее выбираем талько рабочих пользователей, помещаем их в таблицу рабочих пользователей****	
		Запрос.Текст = 
		"ВЫБРАТЬ
		|	ТСП1.ПолноеИмяПользователя КАК ПолноеИмяПользователя,
		|	ТСП1.ПользовательУникльныйИдентификатор КАК ПользовательУникльныйИдентификатор,
		|	ТСП1.ДоменЛогин КАК ДоменЛогин,
		|	ТСП1.ДоменПользователя КАК ДоменПользователя,
		|	ТСП1.ЛогинПользователя КАК ЛогинПользователя,
		|	ТСП1.ПометкаУдаления КАК ПометкаУдаления
		|ПОМЕСТИТЬ ВТПользователи
		|ИЗ
		|	&ТСП1 КАК ТСП1
		|;
		|
		|////////////////////////////////////////////////////////////////////////////////
		|ВЫБРАТЬ
		|	ВТПользователи.ПолноеИмяПользователя КАК ПолноеИмяПользователя,
		|	ВТПользователи.ПользовательУникльныйИдентификатор КАК ПользовательУникльныйИдентификатор,
		|	ВТПользователи.ДоменЛогин КАК ДоменЛогин,
		|	ВТПользователи.ДоменПользователя КАК ДоменПользователя,
		|	ВТПользователи.ЛогинПользователя КАК ЛогинПользователя,
		|	Пользователи.Ссылка КАК ПользовательСсылка,
		|	Пользователи.ПометкаУдаления КАК ПометкаУдаления
		|ИЗ
		|	ВТПользователи КАК ВТПользователи
		|		ВНУТРЕННЕЕ СОЕДИНЕНИЕ Справочник.Пользователи КАК Пользователи
		|		ПО ВТПользователи.ПользовательУникльныйИдентификатор = Пользователи.ИдентификаторПользователяИБ
		|ГДЕ
		|	НЕ Пользователи.ПометкаУдаления = Истина
		|
		|УПОРЯДОЧИТЬ ПО
		|	ПолноеИмяПользователя"
		
		;
		Запрос.УстановитьПараметр("ТСП1",ТСП);
		РезультатЗапроса = Запрос.Выполнить();
		Выборка = РезультатЗапроса.Выбрать();                                
		Пока Выборка.Следующий() Цикл                                                                 //Выбираем результат запроса в цикле
			ПорядковыйНомер=ПорядковыйНомер+1;
			Строка=ТаблицаСписокРабочихПользователей.Добавить(); 
			Строка.ПорядковыйНомер=ПорядковыйНомер;
			Строка.ПолноеИмяПользователя=Выборка.ПолноеИмяПользователя;                               
			Строка.ПользовательУникльныйИдентификатор =Выборка.ПользовательУникльныйИдентификатор;
			Строка.ДоменЛогин=Выборка.ДоменЛогин;
			Строка.ДоменПользователя =Выборка.ДоменПользователя ;
			Строка.ЛогинПользователя =Выборка.ЛогинПользователя ;
			Строка.ПометкаУдаления =Выборка.ПометкаУдаления ;
		КонецЦикла;
		
//Помещаем таблицу рабочих пользователей во временную таблицу, выбираем пользователей со сдвоенными логинами для этого используем "КОЛИЧЕСТВО"*******
//и одно поле группировки во временную таблицу  СдвоенныеЗаписи . Соединяем временные таблицы и справочник Пользователи******************************
		ПорядковыйНомер=0;
		ЛогинКоличество1=1;
		ТСП = РеквизитФормыВЗначение("ТаблицаСписокПользователей",Тип("ТаблицаЗначений"));           //Выгружаем Табличный реквизит формы в переменную
		МВТ=Новый МенеджерВременныхТаблиц;                                                           //Создаем МенеджерВременныхТаблиц
		Запрос.МенеджерВременныхТаблиц=МВТ;
		
		Запрос.Текст = 
		"ВЫБРАТЬ
		|	ТСП1.ПолноеИмяПользователя КАК ПолноеИмяПользователя,
		|	ТСП1.ПользовательУникльныйИдентификатор КАК ПользовательУникльныйИдентификатор,
		|	ТСП1.ДоменЛогин КАК ДоменЛогин,
		|	ТСП1.ДоменПользователя КАК ДоменПользователя,
		|	ТСП1.ЛогинПользователя КАК ЛогинПользователя
		|ПОМЕСТИТЬ ВТПользователи
		|ИЗ
		|	&ТСП1 КАК ТСП1
		|;
		|
		|////////////////////////////////////////////////////////////////////////////////
		|ВЫБРАТЬ
		|	ВТПользователи.ЛогинПользователя КАК ЛогинПользователя,
		|	КОЛИЧЕСТВО(ВТПользователи.ЛогинПользователя) КАК СдвоенныеЗаписиКоличество
		|ПОМЕСТИТЬ СдвоенныеЗаписи
		|ИЗ
		|	ВТПользователи КАК ВТПользователи
		|
		|СГРУППИРОВАТЬ ПО
		|	ВТПользователи.ЛогинПользователя
		|
		|ИМЕЮЩИЕ
		|	КОЛИЧЕСТВО(ВТПользователи.ЛогинПользователя) > 1
		|;
		|
		|////////////////////////////////////////////////////////////////////////////////
		|ВЫБРАТЬ
		|	ВТПользователи.ПолноеИмяПользователя КАК ПолноеИмяПользователя,
		|	ВТПользователи.ПользовательУникльныйИдентификатор КАК ПользовательУникльныйИдентификатор,
		|	ВТПользователи.ДоменЛогин КАК ДоменЛогин,
		|	ВТПользователи.ДоменПользователя КАК ДоменПользователя,
		|	ВТПользователи.ЛогинПользователя КАК ЛогинПользователя,
		|	СдвоенныеЗаписи.СдвоенныеЗаписиКоличество КАК СдвоенныеЗаписиКоличество,
		|	Пользователи.Ссылка КАК ПользовательСсылка
		|ИЗ
		|	ВТПользователи КАК ВТПользователи
		|		ВНУТРЕННЕЕ СОЕДИНЕНИЕ СдвоенныеЗаписи КАК СдвоенныеЗаписи
		|		ПО ВТПользователи.ЛогинПользователя = СдвоенныеЗаписи.ЛогинПользователя
		|		ВНУТРЕННЕЕ СОЕДИНЕНИЕ Справочник.Пользователи КАК Пользователи
		|		ПО ВТПользователи.ПользовательУникльныйИдентификатор = Пользователи.ИдентификаторПользователяИБ
		|ГДЕ
		|	НЕ Пользователи.ПометкаУдаления = ИСТИНА
		|
		|УПОРЯДОЧИТЬ ПО
		|	СдвоенныеЗаписиКоличество,
		|	ДоменЛогин"
		
		;
		Запрос.УстановитьПараметр("ТСП1",ТСП);
		Запрос.УстановитьПараметр("ЛогинКоличество",ЛогинКоличество1);
		РезультатЗапроса = Запрос.Выполнить();
		Выборка = РезультатЗапроса.Выбрать();                                
		Пока Выборка.Следующий() Цикл                                            //Выбираем результат запроса в цикле
			ПорядковыйНомер=ПорядковыйНомер+1;
			Строка=ТаблицаДействующихПользователей.Добавить(); 
			Строка.ПорядковыйНомер=ПорядковыйНомер;
			Строка.ПолноеИмяПользователя=Выборка.ПолноеИмяПользователя;                               
			Строка.ПользовательУникльныйИдентификатор =Выборка.ПользовательУникльныйИдентификатор;
			Строка.ДоменЛогин=Выборка.ДоменЛогин;
			Строка.ДоменПользователя =Выборка.ДоменПользователя ;
			Строка.ЛогинПользователя =Выборка.ЛогинПользователя ;
			Строка.ЛогинКоличество =Выборка.СдвоенныеЗаписиКоличество ;
			Строка.ПользовательСсылка =Выборка.ПользовательСсылка ;
		КонецЦикла;   
КонецПроцедуры
	

 

Скачать файлы

.epf
Наименование Файл Версия Размер
Повторяющиеся логины пользователей.:

.epf 10,56Kb
13.01.20
0
10,56Kb Скачать

Специальные предложения

Комментарии
Избранное Подписка Сортировка: Древо развёрнутое
Свернуть все
1. DJDUH 17 14.01.20 11:44 Сейчас в теме
А консоль 1С чем не подходит? или я не понял смысл этой обработки.
2. bryantsev.yury 31 14.01.20 12:22 Сейчас в теме
(1)Смысл этой обработки следующий:
В реальных базах идет большой оборот пользователей, возникают ситуации
когда появляются пользователи с одинаковыми логинами.
для выявления таких ситуаций была создана эта обработка, плюс дополнительная возможность просмотреть всех пользователей и просмотреть
действующих пользователей.
4. chng 20.05.20 19:21 Сейчас в теме
(2) ИМХО ваша стратегия больбы с проблемой это какойто костыль в попытке устранить последствия, а бороться надо с причиной.
Попробуйте использовать в качестве логина, ФИО полностью и без сокращений! Лучше один раз убедить начальство принять такие правила, чем постоянно ожидать прерывания на устранение этих дублей...
У нас это правило, пользовательИБ=ФИЗ лицо за 6 лет при 4000 сотрудников в зупе, полные однофамильцы (причем не родственники) встретились всего несколько раз.
3. bryantsev.yury 31 14.01.20 12:34 Сейчас в теме
(1) Прошу уточнить какую консоль Вы имеете в виду.
5. bryantsev.yury 31 21.05.20 10:10 Сейчас в теме
chng Вы совершенно правы , это костыль, но пользователь так работает и по
другому работать не хочет, "Клиент всегда прав" или "Маемо, что маемо"
Оставьте свое сообщение

См. также

Анализ ролей и прав по профилю или пользователю и отбору метаданных Промо

Роли и права v8::УФ v8::Права v8::СКД 1cv8.cf Россия Абонемент ($m)

Отчет анализа ролей и прав с фильтром по профилю ИЛИ пользователю и отбору по метаданным (документы, справочники, регистры сведений и накоплений, обработок, планов обмена, констант, отчетов), ролям и правам. Тестировано на платформах: 8.3.11.2899,8.3.12.1440. Конфигурация: ERP 2.4.6.154

1 стартмани

02.08.2018    11461    78    strelec13    5    

Права доступа к объектам с гибкими отборами (расширение)

Роли и права v8 ERP2 КА2 Абонемент ($m)

Возможность без доработок конкретизировать пользователям права Просмотра и Изменения объектов базы 1С, установив ограничения с помощью отборов системы компоновки данных.

2 стартмани

сегодня в 15:45    295    0    sapervodichka    1    

Доступ к функционалу ЭДО пользователя без администраторских прав

Документооборот и делопроизводство Роли и права v8 v8::Права УНФ Абонемент ($m)

Данная обработка предназначена для запуска функционала Электронного документооборота пользователем с ограниченными правами, не имеющим доступ к разделу Компания, из которого в свою очередь запускается меню с Электронными Документами ( Архив ЭДО ,Текущие дела ЭДО , Производные документы), а также меню Администрирование / Обмен с контрагентами / Настройки электронной подписи и шифрования.

1 стартмани

26.06.2020    1020    0    its_33    0    

Альфа-Ника: Кладовщик – расширение для 1С:Бухгалтерии 3.0

Учет ТМЦ Роли и права v8::БУ v8::Права БП3.0 Россия БУ Абонемент ($m)

Целью данного расширения является создание профиля “Кладовщик”, который очень востребован в типовой конфигурации 1С: Бухгалтерия Предприятия 3.0.

10 стартмани

16.06.2020    636    0    alfanika    0    

Роли пользователей Промо

Роли и права v8 v8::Права v8::СКД 1cv8.cf Россия Абонемент ($m)

Отчет предназначен для анализа ролей пользователей.

1 стартмани

09.04.2011    18608    34    Veselchak    15    

Кто может создавать дубли?

Роли и права v8::Права ERP2 Абонемент ($m)

Ролей в ЕРП очень много, вручную не проконтролировать. Как определить у каких пользователей есть права на объект? Как определить роль, отвечающую за тот или иной объект метаданных? Какой профиль нужно назначить группе доступа? Куда отнести пользователя?

1 стартмани

13.06.2020    619    0    Redokov    0    

Система доступа к объектам на уровне открытия форм

Роли и права v8::УФ v8::Права 1cv8.cf Украина Абонемент ($m)

Простенькая система настройки доступа в режиме Предприятия к различным объектам конфигурации на уровне открытия форм.

2 стартмани

10.06.2020    656    1    xcooptex    0    

Анализ прав доступа по ролям объектов конфигурации на СКД

Роли и права v8::Права БП3.0 Россия Абонемент ($m)

Отчет сделан в виде стандартного отчета на системе компоновки данных типовой конфигурации, что делает возможность гибкой настройки и создания своего варианта отчета.

1 стартмани

09.06.2020    783    2    ryan    2    

Дата запрета изменения по организации

Роли и права v8::Права ERP2 УТ11 КА2 Россия Абонемент ($m)

Расширение поможет быстро настраивать дату запрета изменения по организациям

1 стартмани

07.06.2020    753    0    dima21m    0    

Копирование настроек пользователей

Роли и права v8 БП2.0 УТ10 УПП1 Беларусь Украина Россия Абонемент ($m)

Внешняя обработка для копирования настроек пользователей. Предназначена для типовых конфигураций, "Управление торговлей", редакция 10.3, БУХ 2.0, УПП, и их аналогов на рынке СНГ.

1 стартмани

28.05.2020    654    6    JayZ    0    

Групповое удаление доступа из ролей, выгруженных в файлы

Роли и права v8 1cv8.cf Абонемент ($m)

Обработка предназначена для группового поиска и удаления доступа из ролей.

1 стартмани

27.05.2020    606    0    unknown181538    0    

Настройка ограничений входа пользователей в базу (расширение)

Роли и права v8 v8::Права 1cv8.cf Абонемент ($m)

Настраиваем для пользователей 1С разрешенное количество открытых сеансов к текущей базе данных 1С в привязке к компьютерам. (У пользователя не будет возможности превысить допустимое количество сеансов или зайти с чужого компьютера).

2 стартмани

19.05.2020    4846    3    sapervodichka    10    

Установка пароля на изменение настройки пользователей "Дата запрета изменений" в БГУ 2

Роли и права Пароли v8::Права БГУ Государственные, бюджетные структуры Россия БУ Абонемент ($m)

В БГУ 2 (2.0.68.16) на уровне БСП у всех пользователей, имеющих роль "Администратор", есть возможность менять дату запрета изменений. Некоторым клиентам хотелось, чтобы только один пользователь мог менять дату запрета. Данное расширение позволяет определенному программно в расширении пользователю устанавливать пароль, а остальным пользователям позволяет менять даты только при вводе пароля. На красоту не претендует - не пеняйте.

1 стартмани

14.05.2020    804    2    taras20    0    

Анализ прав пользователей

Роли и права v8 v8::УФ v8::Права 1cv8.cf Россия Абонемент ($m)

Отчет по правам в разрезе пользователей, ролей и объектов метаданных.

1 стартмани

05.05.2020    1793    3    Batoo    0    

Запрет редактирования цены в документах продажи

Ценообразование, анализ цен Роли и права v8 v8::БУ v8::Права БП3.0 Россия БУ Абонемент ($m)

После установки расширения, только пользователи с полными правами или с доп. ролью смогут менять цену и сумму в документах реализации.

1 стартмани

26.04.2020    1143    0    Shalnov    2    

Создание нового пользователя путем копирования существующего, всех его ролей, групп и профилей

Роли и права v8::УФ v8::Права БП3.0 Россия Абонемент ($m)

Часто бывает так, что надо создать нового пользователя с определенными правами доступа. Перечисляются организации и роли нового пользователя. На это тратится иногда очень много времени. Часто бывает проще создать нового пользователя на основе уже существующего, а потом, если нужно подправить его права.

1 стартмани

23.04.2020    1057    3    user633783_Wladigor    0    

Поиск ролей и прав доступа в 1С 8.3

Роли и права v8::УФ v8::Права 1cv8.cf Россия Абонемент ($m)

Обработка позволяет упростить настройку ролей и прав доступа. Показывает набор прав и ролей к необходимым объектам, в том числе нетиповым.

1 стартмани

19.04.2020    1337    7    plotnikov1c    0    

Установка даты запрета изменения по расписанию

БСП (Библиотека стандартных подсистем) Роли и права v8 БП3.0 Абонемент ($m)

Внешняя обработка для установки даты запрета изменений по расписанию. Применяется для всех пользователей, кроме уже имеющихся в списке дат запрета.

1 стартмани

14.04.2020    1721    2    user1393353    0    

Ограничение доступа пользователей к внешнему отчёту на СКД

Роли и права v8 v8::Права v8::СКД 1cv8.cf Абонемент ($m)

Метод ограничения доступа пользователей к данным внешнего отчёта.

1 стартмани

04.04.2020    2035    0    user925427    14    

Установка кода доступа в 1С (обычные и управляемые формы)

Роли и права v8 v8::УФ 1cv8.cf Абонемент ($m)

Универсальная обработка по вводу кода доступа.

1 стартмани

03.04.2020    2019    4    Denr83    0    

Создание нового пользователя копированием

Роли и права v8 v8::Права УТ10 Абонемент ($m)

Создание пользователя ИБ и элемента справочника "Пользователя" копированием существующего.

1 стартмани

27.03.2020    1721    2    tamerlan922    0    

Поиск пользователей с нужной ролью

Роли и права v8 v8::УФ v8::Права 1cv8.cf Абонемент ($m)

Показывает список пользователей, у которых установлена указанная роль. Для управляемых форм.

1 стартмани

18.03.2020    1670    2    kaps22    3    

Установка групп доступа физических лиц

Роли и права v8 v8::СПР v8::Права ЗУП3.x Россия БУ Абонемент ($m)

Внешняя обработка для 1С: ЗУП 3 для установки групп доступа физическим лицам.

1 стартмани

13.03.2020    1461    3    SamMix    0    

Отчет по группам доступа, профилям и ролям

Роли и права v8 v8::Права 1cv8.cf Россия Абонемент ($m)

Отчет с 3-мя вариантами "Группы доступа", "Профили", "Роли". В отчет выводится вхождение пользователя в ту или иную роль, профиль, группу доступа.

1 стартмани

11.03.2020    1607    4    grinder    0    

Просмотр ролей пользователей

Роли и права v8 v8::УФ v8::Права 1cv8.cf Абонемент ($m)

С помощью данного отчета можно быстро проанализировать наличие тех или иных ролей у пользователей.

1 стартмани

07.03.2020    1828    4    razars    2    

Просмотр доступности объектов в ролях и группах доступа

Роли и права v8 v8::Права 1cv8.cf Россия Абонемент ($m)

Просмотр ролей, профилей, групп доступа, групп пользователей для доступа к выбранному объекту и его регистрам.

1 стартмани

06.03.2020    1634    12    JackGamer_    0    

Проверка прав по объекту метаданных у пользователя или роли и обратное

Роли и права v8 v8::УФ v8::Права 1cv8.cf Абонемент ($m)

Обработка позволяет посмотреть, какие пользователи или роли имеют доступ к объекту метаданных. Также к каким объектам имеет доступ роль или пользователь информационной базы.

1 стартмани

03.03.2020    2197    12    iCortezik    4    

Информация о пользователях информационной базы (отчет на СКД)

Администрирование данных 1С Роли и права v8 v8::Права v8::СКД 1cv8.cf Абонемент ($m)

Два простых отчета по пользователям информационной базы и информации по ним.

1 стартмани

02.03.2020    4126    16    YPermitin    8    

Ограничение доступа по контрагентам для Бухгалтерии (RLS) 3.0 (3.0.75.58) - менеджер видит только своих контрагентов

Управление взаимоотношениями с клиентами (СRM) Адаптация типовых решений Роли и права v8 БП3.0 Россия БУ Абонемент ($m)

Расширение предназначено для Бухгалтерии 8 ред. 3.0. Типовая конфигурация остается на поддержке (с замком). Решает оно следующую задачу: Менеджеры по продажам должны видеть документы и отчеты только по контрагентам, которых они ведут.

5 стартмани

27.02.2020    2042    4    teyana    4    

Решение разработчика в зависимости от опыта работы. Как ограничить отображаемый пользователю список и ничего не потерять

Роли и права v8 1cv8.cf Абонемент ($m)

Решение разработчика в зависимости от опыта работы. Ограничение отображаемого пользователю списка без применения RLS.

1 стартмани

25.02.2020    1999    0    user633166    8    

Список ролей, у которых установлено определенное право доступа к объекту

Роли и права v8::УФ v8::Права 1cv8.cf Россия Абонемент ($m)

В современных типовых конфигурациях используется огромное количество ролей для ограничения доступа к объектам конфигурации. Это приводит к тому, что приходится прокручивать список ролей на закладке "Права" в окне объекта конфигурации и ждать, когда в окошке "Права" появятся "заветные галочки". Данная обработка поможет программисту быстро сформировать список ролей, у которых установлено то или иное право доступа к объекту конфигурации.

1 стартмани

06.02.2020    2047    9    Igor030370    0    

Анализ прав доступа к метаданным конфигурации

Роли и права v8 v8::Права 1cv8.cf Россия Абонемент ($m)

Лёгкий отчёт, предназначенный для анализа прав доступа к метаданным конфигурации. Написан без использования БСП (Библиотека стандартных подсистем).

5 стартмани

31.01.2020    2194    8    v_elkin    15    

Копирование настроек и дополнительных прав пользователей

Роли и права v8 УПП1 Россия Абонемент ($m)

Модификация обработки из https://infostart.ru/public/204756/. Не копируется основной ответственный, а кроме настроек копируются и дополнительные права.

1 стартмани

28.01.2020    1845    3    FullMoon    2    

Автоматическое создание ролей (объектов метаданных)

Роли и права v8 1cv8.cf Абонемент ($m)

Обработка позволяет создать 2 роли на объекты метаданных (Чтение и Изменение).

2 стартмани

22.01.2020    2334    1    kokorishvili    9    

Анализ ролей и прав доступа

Роли и права v8 v8::УФ v8::Права 1cv8.cf Абонемент ($m)

Показывает у каких пользователей активирована Роль или Права доступа.

1 стартмани

14.01.2020    2127    6    t278    0    

Права на объект (расширение, отчет)

Роли и права v8 v8::Права 1cv8.cf Абонемент ($m)

Если пользователю не хватает прав на объект, то на практике в 90 % случаев, недостающую роль можно найти через типовой регистр сведений Права ролей. Также с помощью дополнительного отчета или небольшого расширения можно ускорить описанный процесс.

1 стартмани

07.01.2020    14784    92    sapervodichka    21    

Анализ прав и ролей пользователей (обычные и управляемые формы)

Роли и права v8 v8::УФ v8::Права 1cv8.cf Абонемент ($m)

Отчет поможет в просмотре и анализе прав по ролям и пользователям по всем (или выбранным) объектам конфигурации.

1 стартмани

16.12.2019    3124    14    Denr83    0    

Перенос пользователей ИБ через COM-соединение (обычные и управляемые формы)

Роли и права v8 v8::УФ v8::Права 1cv8.cf Россия Абонемент ($m)

Необходимо скопировать несколько или всех пользователей в новую ИБ? Обработка (обычное и управляемое приложение) сможет это сделать!

1 стартмани

29.11.2019    2926    20    Denr83    0    

Менеджер подключений к удаленным рабочим столам (RDP)

Роли и права v8 Абонемент ($m)

Менеджер подключений к удаленным рабочим столам для организации доступа сотрудникам, без передачи паролей для доступа.

2 стартмани

19.11.2019    3445    4    Shalnov    1    

Изменение запрета редактирования в дереве по группам пользователей

Роли и права v8::Права УПП1 Россия Абонемент ($m)

Обработка позволяет менять дату запрета редактирования по пользователям в раскрывающемся списке группы пользователей. Тестировалась на УПП 1.3.126.2.

1 стартмани

19.11.2019    2591    1    trest30    0    

Очередной "мягкий" отключатель активных и не очень пользователей

Роли и права v8 1cv8.cf Россия Абонемент ($m)

Тема отключения пользователей не нова, но это чуть другой взгляд на проблему.

1 стартмани

15.11.2019    2970    3    ybatiaev    11    

Анализ прав пользователей

Роли и права v8 ERP2 Россия Абонемент ($m)

Отображает права по ролям и пользователям на конкретный объект конфигурации.

1 стартмани

13.11.2019    3327    19    linder    9