Доработки в отраслевой конфигурации "1С:Альфа-Авто: Автосалон+Автосервис+Автозапчасти КОРП. Редакция 6", в простых примерах

Публикация № 1187949

Разработка - Практика программирования

расширения Альфа-Авто

В этой статье хочу поделиться своим опытом внесения доработок и изменений в конфигурацию "1С:Альфа-Авто: Автосалон+Автосервис+Автозапчасти КОРП. Редакция 6" (далее Альфа-Авто) от фирмы 1С:Рарус, как это сделать так, чтобы следующие обновления конфигурации производились быстрее и проще.

   Данная методика применялась на платформе версии 8.3.16.1063, версия конфигурации 6.0.16.03. Позже вышла информация от поставщика о рекомендуемой версии платформы 8.3.14.1779, прошу обратить на это внимание.

   Начиная с версии 8.3.6.1977 в платформе 1С появился новый механизм адаптации прикладных решений - механизм расширений, подробности тут: https://wonderland.v8.1c.ru/blog/rasshireniya/. По сегодняшний день механизм успешно развивается и открывает новые возможности для адаптации типовых решений. 

   В процессе применения расширений, именно в части доработок типовых и отраслевых решений, я определил для себя некоторые правила:

  1. Новые объекты метаданных (далее МД) и новые реквизиты типовых объектов МД рекомендую добавлять в основную конфигурацию, не нужно спешить и добавлять сразу все в расширение, ниже описание причин.
    • Новые объекты и новые реквизиты это прежде всего хранение данных, расширение в этом плане имеет ряд недостатков, его можно удалить и даже в пользовательском режиме, появляется риск потери данных, а это ценно прежде всего для заказчика и ответственность понесет разработчик.
    • В самой конфигурации "Альфа-Авто" пока есть возможность добавления в расширения новых объектов следующих типов: отчеты, обработки, подсистемы. Если попытаться выйти за эти рамки то программа будет выдавать ошибку при следующем обновлении о том что идентификатор не найден в справочнике "идентификаторов объектов расширений", потому что просто не сможет его там создать.
  2. Как можно меньше заимствовать типовых объектов, реквизитов в расширение, только в самых необходимых случаях, если что-то лишнее добавилось в процессе заимствования формы рекомендую удалять их из расширения. Все это необходимо для более быстрого обновления основной конфигурации, например до обновления реквизит объекта имел прямую ссылку на тот или иной тип, а после обновления его типизировали через определяемый тип и таких реквизитов может быть много, придется править расширение, чем больше привязка расширения к основной конфигурации тем, скорее всего, сложнее и дольше придется обновлять основную конфигурацию.
  3. Модифицируем формы в большинстве случаев кодом. 

   Примеры добавления в основной конфигурации. Для нового объекта МД пишем имя Префикс_ИмяОбъекта (например справочник Доработка_МойНовыйСправочник) синоним пишем привычное название. 

   По аналогии если добавляем новый реквизит в типовой объект или табличную часть Префикс_ИмяРеквизита (например Доработка_МойНовыйРеквизит) синоним пишем привычное название.

   Если добавляем новую табличную часть, то достаточно назвать по правилу Префикс_ИмяТабличнойЧасти , а подчиненные реквизиты можно оставить без префикса.

   Включаем наши новые объекты в свою, новую подсистему так же названную по правилу Префикс_ИмяПодсистемы, подсистема будет служебной для отбора новых объектов, соответственно в командный интерфейс конфигурации не включаем. Префикс необходим для того чтобы разработчик не тратил время на лишний анализ по новым объектам и реквизитам.

   Примеры модификации форм элементов и групп справочников, пока то что зафиксировал, проходит через процедуру ниже. В конфигурации "Альфа-Авто" есть общий модуль "УправлениеСвойствами" его нужно заимствовать в ваше расширение и внести нужные изменения после процедуры "ПриСозданииНаСервере", пример кода:

&После("ПриСозданииНаСервере")
Процедура Расш_ПриСозданииНаСервере(Форма, ДополнительныеПараметры = Неопределено)

	Попытка
		
		Если Форма.ИмяФормы = "Справочник.Автомобили.Форма.ФормаЭлемента" Тогда	
			                      
			ДопСвойства = Новый Структура;
			Владелец = Форма.Элементы.ГруппаШапка;
			УчетЯчеекСервер.СоздатьЭлементФормы(Форма, "Доработка_МойРеквизит1", "Мой реквизит 1", Владелец, 
												Тип("ПолеФормы"), "Объект.Доработка_МойРеквизит1, ВидПоляФормы.ПолеФлажка, ДопСвойства);
			
			ДопСвойства = Новый Структура;
			ДопСвойства.Вставить("ШрифтЗаголовка", Новый Шрифт(,,Истина));
			Владелец = Форма.Элементы.Страницы.ПодчиненныеЭлементы.СтраницаОсновные;
			УчетЯчеекСервер.СоздатьЭлементФормы(Форма, "Доработка_МойРеквизит2", "Мой реквизит 2", Владелец, 
												Тип("ПолеФормы"), "Объект.Доработка_МойРеквизит2", ВидПоляФормы.ПолеФлажка, ДопСвойства);
			
			Владелец = Форма.Элементы.Страницы;
			УчетЯчеекСервер.СоздатьЭлементФормы(Форма, "МояСтраница1", "Моя страница 1", Владелец, Тип("ГруппаФормы"));
			
			Владелец = Форма.Элементы.Страницы.ПодчиненныеЭлементы.МояСтраница1;
			ДопСвойства = Новый Структура;
			ДопСвойства.Вставить("ПоложениеЗаголовка", ПоложениеЗаголовкаЭлементаФормы.Нет);
			УчетЯчеекСервер.СоздатьЭлементФормы(Форма, "Доработка_МояТабличнаяЧасть1", "Моя табличная часть 1", Владелец, 
												Тип("ТаблицаФормы"), "Объект.МояТабличнаяЧасть1", ВидПоляФормы.ПолеВвода, ДопСвойства);
			
		КонецЕсли;
											
	Исключение
		
		ЗаписьЖурналаРегистрации("Ошибка создания элемента на форме в расширении", УровеньЖурналаРегистрации.Ошибка,,,ОписаниеОшибки());
		
	КонецПопытки;
	
КонецПроцедуры

Саму процедуру "СоздатьЭлементФормы" я разместил в новом модуле расширения.

#Область Создание_элементов_на_форме

Процедура СоздатьЭлементФормы(Форма, ИмяКоманды, Заголовок, Владелец, Тип, ПутьКДанным = "", ВидПоля = Неопределено, ДопСвойства = Неопределено) Экспорт 
	
	СлужебныеИмена = Новый Массив;
	СлужебныеИмена.Добавить("КлючСтроки");
	СлужебныеИмена.Добавить("ИсходныйНомерСтроки");
	ШрифтЗаголовка = Новый Шрифт(,,Ложь,Ложь,Ложь,Ложь);
	ПоложениеЗаголовка = ПоложениеЗаголовкаЭлементаФормы.Авто;
	Если ДопСвойства <> Неопределено и ДопСвойства.Свойство("ШрифтЗаголовка") Тогда
		ДопСвойства.Свойство("ШрифтЗаголовка", ШрифтЗаголовка);
	КонецЕсли;
	Если ДопСвойства <> Неопределено и ДопСвойства.Свойство("ПоложениеЗаголовка") Тогда
		ДопСвойства.Свойство("ПоложениеЗаголовка", ПоложениеЗаголовка);
	КонецЕсли;
	Если Тип = Тип("КнопкаФормы") Тогда
		НоваяКоманда = Форма.Команды.Добавить(ИмяКоманды);
		НоваяКоманда.Заголовок = Заголовок;
		НоваяКоманда.Действие = ИмяКоманды;
		
		Элемент = Форма.Элементы.Добавить(ИмяКоманды, Тип, Владелец);
		Элемент.Вид = ВидКнопкиФормы.КнопкаКоманднойПанели;
		Элемент.Заголовок = Заголовок;
		Элемент.ИмяКоманды = ИмяКоманды;
		Элемент.ШрифтЗаголовка = ШрифтЗаголовка;
		Элемент.ПоложениеЗаголовка = ПоложениеЗаголовка;
	ИначеЕсли Тип = Тип("ПолеФормы") Тогда
		Элемент = Форма.Элементы.Добавить(ИмяКоманды, Тип, Владелец);
		Элемент.Вид = ВидПоля;
		Элемент.Заголовок = Заголовок;
		Элемент.ПутьКДанным = ПутьКДанным;
		Элемент.ШрифтЗаголовка = ШрифтЗаголовка;
		Элемент.ПоложениеЗаголовка = ПоложениеЗаголовка;
		Элемент.УстановитьДействие("ПриИзменении", ИмяКоманды + "ПриИзменении");
	ИначеЕсли Тип = Тип("ГруппаФормы") Тогда
		Элемент = Форма.Элементы.Добавить(ИмяКоманды, Тип, Владелец);
		Элемент.Вид = ВидГруппыФормы.Страница;
		Элемент.Заголовок = Заголовок;
		Элемент.ШрифтЗаголовка = ШрифтЗаголовка;
	ИначеЕсли Тип = Тип("ТаблицаФормы") Тогда
		Таблица = Форма.РеквизитФормыВЗначение(ПутьКДанным).Выгрузить();
		ПрефиксКолонки = СтрЗаменить(ПутьКДанным, "Объект.", "");
		Элемент = Форма.Элементы.Добавить(ИмяКоманды, Тип, Владелец);
		Элемент.Заголовок = Заголовок;
		Элемент.ПутьКДанным = ПутьКДанным;
		Элемент.ШрифтЗаголовка = ШрифтЗаголовка;
		Элемент.ПоложениеЗаголовка = ПоложениеЗаголовка;
		Элемент.УстановитьДействие("ПриОкончанииРедактирования", ИмяКоманды + "ПриОкончанииРедактирования");
		Элемент.УстановитьДействие("ПриАктивизацииСтроки", ИмяКоманды + "ПриАктивизацииСтроки");
		Для Каждого Ст ИЗ Таблица.Колонки Цикл
			Если СлужебныеИмена.Найти(Ст.Имя) <> Неопределено Тогда
				Продолжить;
			КонецЕсли;
			ИмяКолонки = ПрефиксКолонки + Ст.Имя;
			ИмяКоманды = ИмяКолонки + "НачалоВыбора";
			ИмяКомандыПриИзменении = ИмяКолонки + "ПриИзменении";
			Колонка = Форма.Элементы.Добавить(ИмяКолонки, Тип("ПолеФормы"), Элемент);
			Колонка.Вид = ВидПоля;
			Колонка.ПутьКДанным = ПутьКДанным + "." + Ст.Имя;
			Колонка.Заголовок = ПолучитьЗаголовок(Ст.Имя);
			Колонка.УстановитьДействие("НачалоВыбора",ИмяКоманды);
			Колонка.УстановитьДействие("ПриИзменении",ИмяКомандыПриИзменении);
    		КонецЦикла;
	КонецЕсли;
	
КонецПроцедуры

Функция ПолучитьЗаголовок(Исходная)
	
	Конечная=Лев(Исходная,1);
	Для Индекс=2 по СтрДлина(Исходная) цикл
		Символ=Сред(Исходная,Индекс,1);
		Конечная=Конечная+?(ВРег(Символ)=Символ," "+НРег(Символ),Символ);
	КонецЦикла;
	
	Возврат Конечная;
	
КонецФункции	

#КонецОбласти

 

   Примеры модификации форм списка регистров сведений и справочников, форм записи регистров сведений, пока то что зафиксировал, проходит через процедуру ниже. Общий модуль "УправлениеДиалогомСервер" его нужно заимствовать в ваше расширение и внести нужные изменения после процедуры "ДобавитьРеквизитыФормы", пример кода:

&После("ДобавитьРеквизитыФормы")
Процедура Расш_ДобавитьРеквизитыФормы(Форма, Реквизиты)
	
	Попытка
		
		НовыеРеквизиты = Новый Массив;
		Если Форма.ИмяФормы = "РегистрСведений.НоменклатураПрименяемость.Форма.ФормаСписка" Тогда	
			
			УчетЯчеекСервер.СоздатьЭлементФормы(Форма, "МойРеквизит1", "Мой реквизит 1", Форма.Элементы.Список, 
												Тип("ПолеФормы"), "Список.МойРеквизит1", ВидПоляФормы.ПолеВвода);
			
		ИначеЕсли Форма.ИмяФормы = "РегистрСведений.НоменклатураПрименяемость.Форма.ФормаЗаписи" Тогда	
			
			УчетЯчеекСервер.СоздатьЭлементФормы(Форма, "МойРеквизит2", "Мой реквизит 2", Форма, 
												Тип("ПолеФормы"), "Запись.МойРеквизит2", ВидПоляФормы.ПолеВвода);
			
			
		ИначеЕсли Форма.ИмяФормы = "Справочник.Автомобили.Форма.ФормаСписка" Тогда	
			
			НовыйРеквизит = Новый РеквизитФормы("Доработка_МойРеквизит3",Новый ОписаниеТипов("СправочникСсылка.МойСправочник1"),,"Мой реквизит 3"); 
			НовыеРеквизиты.Добавить(НовыйРеквизит);
			Форма.ИзменитьРеквизиты(НовыеРеквизиты);
			Владелец = Форма.Элементы.СпискиСОтборами.ПодчиненныеЭлементы.БыстрыеОтборы;
			ДопСвойства = Новый Структура;
			ДопСвойства.Вставить("ПоложениеЗаголовка", ПоложениеЗаголовкаЭлементаФормы.Верх);
			УчетЯчеекСервер.СоздатьЭлементФормы(Форма, "Доработка_МойРеквизит3", "Мой реквизит 3", Владелец, 
												Тип("ПолеФормы"), "Доработка_МойРеквизит3", ВидПоляФормы.ПолеВвода, ДопСвойства);
			
		КонецЕсли;
		
	Исключение
		
		ЗаписьЖурналаРегистрации("Ошибка создания элемента на форме в расширении", УровеньЖурналаРегистрации.Ошибка,,,ОписаниеОшибки());
		
	КонецПопытки;
	
КонецПроцедуры

   

   Для того чтобы прописать необходимые события на созданные элементы на форме нужно будет заимствовать форму в расширении, лишние элементы удалить из расширения и в самой форме прописать событие, в моей процедуре "СоздатьЭлементФормы" имя события собирается здесь:

На форме это будет выглядеть примерно так:

 

   Выводы: расширение это удобный механизм если его использовать правильно, с помощью расширений вы можете ускорить обновление в части изменения форм, однако новые объекты метаданных, реквизиты и табличные части лучше пока хранить в основной конфигурации.

Специальные предложения

Комментарии
Избранное Подписка Сортировка: Древо
1. omut 02.02.20 20:02 Сейчас в теме
Какое отношение содержание статьи имеет к заголовку? В Альфе куча специфических моментов, на которые следует обращать внимание при доработке. Но автор рассказывает о тривиальных способах доработки с помощью расширений, не имеющих отношения к конкретной конфигурации!
promagent; leonidol; YurySigolaev; +3 Ответить
2. байт 27 02.02.20 20:07 Сейчас в теме
(1)Здравствуйте, специфика в том что добавление элементов на формы в "Альфа-Авто" идет через модули "УправлениеСвойствами" и "УправлениеДиалогомСервер", по остальному просто описал общий механизм доработок через расширения.
3. байт 27 02.02.20 20:12 Сейчас в теме
(1)+ перехватываем там типовую форму и дорабатываем программно.
4. Pixar0000 06.02.20 00:21 Сейчас в теме
не понятно к чему статья... а это "полёт" мысли
Данная методика применялась на платформе версии 8.3.16.1063, версия конфигурации 6.0.16.03. Позже вышла информация от поставщика о рекомендуемой версии платформы 8.3.14.1779, прошу обратить на это внимание.
5. байт 27 06.02.20 08:15 Сейчас в теме
(4) А что непонятного? Вроде все расписано как внести доработки в Альфу с помощью расширения с наименьшими затратами.
6. байт 27 06.02.20 08:19 Сейчас в теме
(4) имеется в виду оформление типовых форм если в объектах уже есть доработки по структуре. Показал модули, процедуры через которые это делается, привел примеры, оформил максимально просто без заморочек.
Оставьте свое сообщение

См. также

Программная работа с настройками СКД

Статья Программист Нет файла v8 v8::СКД 1cv8.cf Бесплатно (free) Практика программирования

Нюансы программной работы с настройками системы компоновки данных в отчетах и динамических списках. Обзор всех видов настроек компоновки. Что в каких случаях правильно применять. В качестве примера рассмотрена работа с отборами и группировками.

27.01.2020    5493    ids79    25       

Базовый курс по управлению ИТ-проектами. Курс проходит с 26 февраля по 22 апреля 2020 года. Промо

Отличительная черта курса - органичное сочетание трех вещей: 1.Теория проектного управления (PMI®+Agile Alliance+Российские ГОСТ+Методологии от 1С); 2. Опыт внедрения продуктов 1С (опыт франчайзи и успешных компаний + тренды Infostart Event и Agile Days); 3. Разбор реальных проблем и рекомендации экспертов по проектам слушателей. Мы будем фиксироваться на тех инструментах, которые реально оказываются полезными в практике руководителей проектов внедрения. Ведущая курса - Мария Темчина.

от 11000 рублей

[СКД] Программное создание схемы компоновки данных

Статья Программист Стажер Нет файла v8 v8::СКД 1cv8.cf Бесплатно (free) Практика программирования

Сделаем отчет на СКД полностью программно, без использования макета "схема компоновки данных".

15.01.2020    7413    John_d    21       

30 задач. Странных и не очень

Статья Программист Стажер Нет файла v8 Бесплатно (free) Практика программирования

30 задач на знание языка программирования 1С и некоторого поведения платформы. Маленьких. Странных и не очень.

02.12.2019    9316    YPermitin    72       

Сдача регламентированной отчетности из программ 1С Промо

Сдача регламентированной отчетности из программ "1С" во все контролирующие органы без выгрузок и загрузок в другие программы. Для групп компаний действуют специальные предложения.

от 1500 руб.

Программы для исполнения 488-ФЗ: Маркировка товаров Промо

1 января 2019 года вступил в силу ФЗ от 25.12.2018 № 488-ФЗ о единой информационной системе маркировки товаров с использованием контрольных (идентификационных) знаков, который позволяет проследить движение товара от производителя до конечного потребителя. Инфостарт предлагает подборку программ, связанных с применением 488-ФЗ и маркировкой товаров.

Агрегатные функции СКД, о которых мало кто знает

Статья Программист Нет файла v8 v8::СКД 1cv8.cf Бесплатно (free) Практика программирования

Пользуетесь ли Вы всеми возможными агрегатными функциями, которые предоставляет система компоновки данных? Если Вы используете только: СУММА, КОЛИЧЕСТВО, МИНИМУМ, МАКСИМУМ, СРЕДНЕЕ, то эта статья для Вас.

05.09.2019    24119    ids79    45       

Управление ИТ-проектами. Модуль 2: продвинутый онлайн-курс по классическим методам управления проектами. Вебинары проходят с 12 марта по 11 июня 2020 года. Промо

Продвинутый онлайн-курс по классическому управлению ИТ-проектами позволит слушателям освоить инструменты из PMBoK® и 1С:Технологии корпоративного внедрения и научиться их применять для проектов любого масштаба. Курс включает в себя 12 вебинаров и 12 видеолекции, разбор кейсов и рекомендации экспертов по проектам слушателей. Ведущая курса - Мария Темчина.

от 13000 рублей

Три костыля. Сказ про фокусы в коде

Статья Программист Нет файла v8 Бесплатно (free) Практика программирования

Три интересных (или странных) костыля в коде, которые могут помочь в повседневных и не очень задачах.

03.09.2019    15959    YPermitin    78       

Отслеживание выполнения фонового задания

Статья Программист Нет файла v8 1cv8.cf Бесплатно (free) Практика программирования Универсальные функции Разработка

Запуск фонового задания из модуля внешней обработки. Отслеживание выполнения задания в виде прогресса, расположенного на форме.

17.08.2019    18281    ids79    16       

INFOSTART MEETUP Kazan. 13 марта 2020 г. Промо

Инфостарт продолжает путешествие по России. Следующая остановка - Казань. Тема мероприятия - управление и технологии автоматизации учета на платформе "1С: Предприятие". Ждем всех: докладчиков и участников! Стоимость участия - 5 500 рублей. Цена действительна до 30.01.2020

5 500

Функции СКД: ВычислитьВыражение, ВычислитьВыражениеСГруппировкойМассив

Статья Программист Нет файла v8 v8::СКД 1cv8.cf Бесплатно (free) Практика программирования

Подробное описание и использование внутренних функций системы компоновки данных: Вычислить, ВычислитьВыражение, ВычислитьВыражениеСГруппировкойМассив, ВычислитьВыражениеСГруппировкойТаблицаЗначений.

08.08.2019    33348    ids79    36       

Фоновое выполнение кода в 1С - это просто

Статья Программист Нет файла v8 1cv8.cf Бесплатно (free) Практика программирования

Как легко запускать выполнение в фоне, не прибегая к долгому описанию фоновых процедур.

02.08.2019    18380    avalakh    21       

Голосование за доклады на INFOSTART MEETUP Kazan - до 25 февраля. Промо

Выбирайте и голосуйте за самые интересные доклады! Лучшие из лучших попадут в окончательную программу казанского митапа. Оставить свой голос можно до 25 февраля 2020 года.

СКД - наборы данных и связи между ними, создание собственной иерархии, вложенные отчеты

Статья Программист Нет файла v8 v8::СКД 1cv8.cf Бесплатно (free) Практика программирования

Набор данных объект. Использование в схеме компоновки нескольких наборов данных. Различные варианты связи наборов: объединение, соединение. Использование иерархии в отчетах на СКД. Создание собственной иерархии, иерархия детальных записей. Использование вложенных схем в отчетах на СКД.

26.07.2019    27226    ids79    9       

Новый раздел на Инфостарте - Electronic Software Distribution Промо

Инфостарт напоминает: на нашем сайте можно купить не только ПО, связанное с 1С. В нашем арсенале – ESD-лицензии на ПО от ведущих вендоров: Microsoft, Kaspersky, ESET, Dr.Web, Аскон и другие.

  • Низкие цены, без скрытых платежей и наценок
  • Оперативная отгрузка
  • Возможность оплаты с личного счета (кешбек, обмен стартмани на рубли и т.п.)
  • Покупки идут в накопления для получения скидочных карт лояльности Silver (5%) и Gold (10%)

СКД - использование расширений языка запросов, секция ХАРАКТЕРИСТИКИ

Статья Программист Нет файла v8 v8::СКД Бесплатно (free) Инструментарий разработчика Практика программирования

Автоматическое и не автоматическое заполнение полей компоновки данных. Использование расширений языка запросов для СКД «{…}», секция ВЫБРАТЬ, секция ГДЕ, параметры виртуальных таблиц. Автоматизированное использование дополнительных данных в запросе: секция ХАРАКТЕРИСТИКИ.

17.07.2019    19643    ids79    27       

Регистры сведений. За кулисами

Статья Программист Нет файла v8 1cv8.cf Бесплатно (free) Практика программирования Разработка

Небольшие заметки по внутреннему устройству регистров сведений.

09.07.2019    14852    YPermitin    12       

​​​​​​​CorelDRAW Graphics Suite 2019 Промо

CorelDRAW – пакет профессиональных инструментов для редактирования фотографий, разработки дизайна, создания макетов страниц и векторных иллюстраций

"Меньше копипаста!", или как Вася универсальную процедуру писал

Статья Программист Стажер Нет файла v8 v8::СКД 1cv8.cf Бесплатно (free) Практика программирования Разработка

Программист Вася разбирает подход создания универсальных методов на примере программного вывода СКД.

04.07.2019    12104    SeiOkami    49       

Создание отчетов с помощью СКД - основные понятия и элементы

Статья Программист Нет файла v8 v8::СКД Бесплатно (free) Практика программирования Математика и алгоритмы

Основные принципы работы СКД. Понятия схемы компоновки и макета компоновки. Описание основных элементов схемы компоновки: наборы данных, поля, вычисляемые поля, ресурсы, параметры.

25.06.2019    31798    ids79    17       

1C:Предприятие для программистов: Расчетные задачи (зарплата). Онлайн-интенсив с 01 по 17 июня 2020 г. Промо

Данный онлайн-курс предусматривает изучение механизмов платформы “1С:Предприятие”, которые предназначены для автоматизации периодических расчетов, а именно - для расчета зарплаты. Курс предназначен для тех, кто уже имеет определенные навыки конфигурирования и программирования в системе “1С:Предприятие”, а также для опытных пользователей прикладного решения “1С:Зарплата и управление персоналом” и прочих прикладных решений, в которых реализован функционал расчета зарплаты.

4900 рублей

Многопоточное ускорение однопользовательских нагрузок в 1С + Microsoft SQL Server 2017

Статья Программист Нет файла v8 v8::Запросы Бесплатно (free) Практика программирования Разработка

Взаимодействие с Microsoft SQL Server нередко вызывает трудности у 1С-ников, а потому интересны любые моменты, связанные с его использованием. О своем опыте работы с новым SQL Server 2017 участникам конференции Infostart-2018 рассказал директор ООО «Аналитика софт» Дмитрий Дудин.

11.06.2019    16938    dmurk    144       

Регистры накопления. Структура хранения в базе данных

Статья Программист Нет файла v8 1cv8.cf Бесплатно (free) Практика программирования Разработка

Структура хранения регистров накопления в базе данных для платформы 1С:Предприятие 8.x. Первая часть в серии публикаций.

16.05.2019    27291    YPermitin    27       

Онлайн-курс "Подготовка к экзамену 1С:Эксперт и 1С:Профессионал по технологическим вопросам" с 7 по 24 апреля 2020 г. Промо

На курсе вы получите практические навыки решения задач производительности 1С, в том числе характерных для высоконагруженных информационных систем (более 1000 пользователей). Подготовка к экзамену – только одна из составляющих курса. 70% слушателей приходят за знаниями, которые позволят расти и зарабатывать, делать сложные задачи на крупных проектах.

16450 рублей

Выполнение внешней обработки в фоновом задании

Статья Программист Нет файла v8 1cv8.cf Бесплатно (free) Практика программирования Разработка

Подробное описание подхода к созданию длительной операции на основе внешней обработки. Реализация протестирована на 1С 8.3.12.1714 (x64).

11.05.2019    17288    Eret1k    23       

Выгрузка документа по условию

Статья Программист Нет файла v8 Бесплатно (free) Практика программирования Разработка

Что делать, если документы нужно выгружать не все подряд, а по какому-то фильтру: статусу, дате, набору условий... А что если он соответствовал этим условиям, а потом перестал? А если потом опять начал? Такие ситуации заставили попотеть не одного программиста.

25.04.2019    9301    m-rv    2       

Подборка программ для взаимодействия с ЕГАИС Промо

ЕГАИС (Единая государственная автоматизированная информационная система) - автоматизированная система, предназначенная для государственного контроля за объёмом производства и оборота этилового спирта, алкогольной и спиртосодержащей продукции. Инфостарт рекомендует подборку проверенных решений для взаимодействия с системой.

Как прикрутить ГУИД к регистру сведений

Статья Программист Нет файла v8 Бесплатно (free) Практика программирования Перенос данных из 1C8 в 1C8 Разработка

... и немного теории обмена данными. В частности, разберем боль всех, кто пишет небанальные обмены данными: как набору записей регистра сведений назначить гуид и далее использовать его в обмене для идентификации этого набора.

16.04.2019    12436    m-rv    16       

О расширениях замолвите слово...

Статья Программист Стажер Нет файла v8 Бесплатно (free) Практика программирования Разработка

О чём стоит задуматься при принятии решения о создании расширения конфигурации…

07.04.2019    23433    ellavs    125       

Программы для исполнения 54-ФЗ Промо

С 01.02.2017 контрольно-кассовая техника должна отправлять электронные версии чеков оператору фискальных данных - правила установлены в 54-ФЗ ст.2 п.2. Инфостарт предлагает подборку программ, связанных с применением 54-ФЗ, ККТ и электронных чеков.

Git-репозитории для 1С-кода (опыт использования при небольших проектах)

Статья Программист Стажер Нет файла v8 Windows Бесплатно (free) Практика программирования Разработка

Инструкции по взаимодействию с Git-репозиторием, которые писались для тех наших программистов, которые вообще никогда не работали с Git (руководства в духе "Как получить код из git-репозитория?", "Как отправить код в git-репозиторий")...

28.03.2019    18579    ellavs    83       

Трюки с внешними источниками данных

Статья Программист Нет файла v8 1cv8.cf Бесплатно (free) Практика программирования Разработка

Некоторые трюки для преодоления ограничений внешних источников данных.

14.03.2019    20446    YPermitin    53