Об обновлениях

Публикация № 1194327

Разработка - Практика программирования

Рассматриваются вопросы комментирования доработок стандартных конфигураций, необходимых для облегчения работы при обновлении конфигурации.

Основа быстрого и безошибочного обновления закладывается на этапе разработки или при рефакторинге кода.

Прежде всего, всегда отмечайте отредактированные участки кода. В моей компании для этого используется метка //гг, плюс один или несколько символов, идентифицирующих программиста.

Перем ТаблицаСтоимостейБезДопРасходов;//гги
//гги ТабДокумент = ПечатьАктаОбОказанииУслуг();

//гги
Если Не Проведен Тогда
	Предупреждение("Запрещено печатать непроведенные документы");
	возврат;
КонецЕсли;
//гги

//гги
Процедура ДополнительныеДействияПриОткрытииФормы()
...
КонецПроцедуры

Здесь «//гг» - общая метка, «и» - мой буквенный идентификатор. Такие метки быстро наносить и легко искать в модулях конфигурации.

Рядом с меткой полезно указать, с какой целью сделано это изменение. Это может быть реализация некоего технического задания, исправление ошибки и так далее. Я использую метки «//тз001», «//метка002». Детальное описание, что означает техническое задание №001 или с чем было связано внесение изменений под меткой №002, я веду в отдельном файле (также можно использовать какой-нибудь модуль самой конфигурации). Если некая процедура использована в нескольких ТЗ, я отмечаю ее несколькими метками:

//гги//тз008//тз013
Функция НазначениеСпецификации_ЛКМ_Новые() Экспорт
    возврат лкпОбщегоНазначенияПолныеПрава.ПолучитьЭлементСправочника(
        "ЛКМ Новые", "НазначенияИспользованияСпецификаций", "Спецификации");
КонецФункции

Заглянув в описание, можно узнать, для чего были внесены изменения. Глобальным поиском по «//тз008» можно найти все изменения, вызванные ТЗ №008 - чтобы, например, удалить их, если данное задание уже не используется, и есть желание почистить конфигурацию от «мертвого» кода.

Отмечайте изменения в интерфейсах конфигураций на обычных формах. Я делаю это в модуле приложения:

//гги Интерфейс УправлениеПроизводством добавлено меню "Дополнительно"

При изменениях в визуальных элементах формы делайте комментарии в модуле формы:

//гги добавлены вкладки ДатаОтгрузки, ОтветственноеХранение
//на вкладке Дополнительно кнопка Логистам

Это важно потому, что отличия элементов форм не видны при сравнении/объединении. По возможности добавляйте свои элементы форм программно – тогда перенос изменений при обновлении сведется к копированию/вставке кусков кода. Это можно делать на обычных и на управляемых формах:

Обычные формы:

Индекс = ЭлементыФормы.Товары.Колонки.Индекс(ЭлементыФормы.Товары.Колонки.Артикул);
Колонка = ЭлементыФормы.Товары.Колонки.Вставить(Индекс, "Транспортная упаковка");
Колонка.Имя = "ТранспортнаяУпаковка";
Колонка.УстановитьЭлементУправления(Тип("ПолеВвода"));
Колонка.Данные = "ТранспортнаяУпаковка";
Колонка.ТолькоПросмотр = Ложь;
Колонка.Ширина = 15;
Колонка.Видимость = Истина;

Колонка.ЭлементУправления.УстановитьДействие("ПриИзменении", Новый Действие("ТоварыТранспортнаяУпаковкаПриИзменении"));

Управляемые формы:

ЭлементРодитель = Элементы.Продукция;
ЭлементПередКоторымВставить = Элементы.ПродукцияНазначение;

НовыйЭлемент = Элементы.Вставить("НаименованиеПереработчика",
     Тип("ПолеФормы"),
     ЭлементРодитель,
          ЭлементПередКоторымВставить);

НовыйЭлемент.ПутьКДанным = "Объект.Продукция.НаименованиеПереработчика";
НовыйЭлемент.Вид = ВидПоляФормы.ПолеВвода;

Но без фанатизма – на обычных формах проще выделить мышкой и скопировать-вставить десяток элементов на добавленной странице, чем создавать их все программным способом, задавая расположение и привязки - пусть даже в перспективе это придется делать 10 или 100 раз. Однажды я перенес все многочисленные изменения форм УПП в код, а завод через полгода обанкротился.

На управляемых формах вносить изменения в форму через программный код полезно почти всегда – особенно в случае использования при обновлении внешней программы типа kDiff3 (см. ниже).

Описание изменений прав можно делать в модуле объекта или в модуле приложения, отмечая их дополнительным тегом "//правагг":

В модуле менеджера объекта:

//гги//правагг ЭкономистЦеха все; МенеджерПоЗаказам, МенеджерПоПродажам чтение

В модуле приложения:

//гги//правагг убрал доступ у роли Пользователь к
     //всё Спр.ЗначенияПоказателейАнализовНоменклатуры,
     //всё Спр.НормативныеДокументыСертификацииНоменклатуры,
     //всё РС.НормативныеДокументыСертификацииНоменклатуры
     //редактирование Спр.СерииНоменклатуры
     //всё Док.СертификацияНоменклатуры

Перенос изменений в стандартных ролях – наиболее трудоемкий и неавтоматизируемый процесс. Поэтому старайтесь не изменять стандартные роли – вместо этого создавайте свои. Если вы хотите добавить права к своему справочнику менеджерам по продажам, сделайте новую роль префикс_МенеджерПоПродажам, назначьте ей права к своему справочнику, и добавьте эту роль пользователям. Другой возможный подход - добавление своих атомарных ролей, например префикс_РедактированиеСправочника_ТипыПродукции

Новые объекты и реквизиты объектов отмечайте префиксом из 2-3 символов, после которых идет символ подчеркивания. Так будет проще отличить объекты, добавленные программистом от объектов, которые удалены из конфигурации поставщика, но по той или иной причине остались в конфигурации базы данных, и вообще добавит порядка в вашу конфигурацию.

мт_ОбщегоНазначения (общий модуль)

мт_ЗначимыеПоставщики (регистр сведений)

мт_ЦенаЗакупки (реквизит документа)

Добавленные объекты располагайте внизу ветки дерева конфигурации:

После обновления они будут «уползать» вверх (например, если до обновления в конфигурации поставщика было 100 справочников, а стало 102, то после обновления справочники будут располагаться в таком порядке: с 1 по 100 строку - справочники конфигурации поставщика, потом ваши справочники, потом остальные справочники конфигурации поставщика). Не ленитесь восстановить порядок – переместите ваши объекты вниз. Недопустимо, чтобы ваши объекты были раскиданы по всему дереву конфигурации, вперемешку с объектами поставщика. Кроме очевидного беспорядка, это может привести к затруднениям при переносе изменений при обновлении. Старайтесь располагать ваши объекты в алфавитном порядке.

Не добавляйте свои отчеты и обработки в дерево конфигурации. Их место - в дополнительных отчетах и обработках или в расширении.

 

Итак, если в конфигурации у вас теперь порядок, то перенос изменений при обновлении происходит так: открываются две базы данных – с обновленной и необновленной конфигурациями. Глобальным поиском по меткам //гг (со снятым флажком «Искать слово целиком») выводятся метки в старой и новой конфигурации. Просматривайте вхождения по порядку, находите недостающие строки в новой конфигурации, переносите эти куски кода из старой. Ранее, при отображении дерева измененных объектов, запишите, какие роли и интерфейсы у вас дважды изменены (просмотр дважды измененных объектов – стандартный этап при использовании внешней программы, о чем ниже). Перенесите изменения в дважды измененных ролях, используя поиск по «//правагг». Перенесите изменения в дважды измененных интерфейсах, используя пометки в общем модуле.

Крайне полезно использовать внешнюю программу для анализа изменений в модулях при обновлении. Я использую kDiff3. Здесь я не буду описывать работу с ней; описание можно найти на сайте 1С или на других сайтах. Использование внешней программы ускоряет обновление в десятки раз, обязательно освойте ее.

Специальные предложения

Комментарии
Избранное Подписка Сортировка: Древо
1. BigB 178 12.02.20 23:11 Сейчас в теме
А не лучше ли доработки делать в виде расширений? Тогда и в конфигурации не надо включать возможность изменения и обновляться такая конфигурация будет без проблем.
costy_admin; ipoloskov; Alfn; +3 2 Ответить
2. ipoloskov 76 13.02.20 05:15 Сейчас в теме
(1) это тоже. Но у меня на поддержке еще находятся множество УПП, у других наверняка тоже.
Статью я написал по следам обновления "чужой" УПП, которую провожу в данный момент, и бардака, обнаруженного в этой конфигурации.

По поводу расширений. Я недавно вернул одну Бухгалтерию 3.0 на поддержку, перенеся все доработки в расширение. Но там я это сделал скорее для того, чтобы ускорить процесс обновления (конфигурация "на замке" обновляется в 2-3 раза быстрее, чем со снятым замком). Еще для одного клиента Бух30 я сделал новую подсистему полностью на расширении.

Какие я вижу минусы в полном перенесении правок в расширение:
Часто приходится вносить правки в модули конфигурации, причем делать правки где-нибудь в середине процедуры. Выносить процедуру в расширение чревато тем, что при обновлении она будет изменена - а видно этого не будет. На устоявшихся конфигурациях типа Бухгалтерии это, наверное, не страшно, но на развивающихся типа ERP при каждом обновлении добавится работа - искать в расширении процедуры с заголовком &Вместо, копировать новый код процедуры из основной конфигурации и заново расставлять в нем свои правки. Сравните с тремя щелчками мышью, необходимыми для обработки дважды измененного модуля с помощью kDiff3, и вы поймете, почему я не люблю директиву &Вместо в расширении.
Сейчас появилась возможность добавлять процедуры в расширение с контролем, но я этот механизм еще не пробовал.
3. MVK80 13.02.20 08:10 Сейчас в теме
(2), используйте в расширениях ИзменениеИКонтроль (это вместо &Вместо) и не надо править код основной конфигурации. Доступно с платформы 8.3.15....(последние цифры не помню). Но аккуратно, так как много багов пока в ИзменениеИКонтроль.
6. Monte Carlo 13.02.20 10:53 Сейчас в теме
(3) ERP в режиме совместимости с версией 8.3.12 до сих пор. В ней не работает ИзменениеИКонтроль.
7. MVK80 13.02.20 11:42 Сейчас в теме
(6), работает. Это платформенная фишка не привязанная к режиму совместимости. Попробуйте! Мы как раз и работаем с ERP и с ИзменениемИКонтролем.
9. Monte Carlo 13.02.20 13:35 Сейчас в теме
(7) Странно, пробовали не работает. Да это и логично. Если конфигурация работает в режиме совместимости с более старой версией платформы, то в ней не поддерживаются новые фишки.
17. MVK80 16.02.20 19:35 Сейчас в теме
(9), то есть вам проще поверить что я вру, когда явно пишу, что мы уже работаем с ИзменениемИКонтролем в ERP, нежели в то, что у вас могло не получится по тысячам причин (и вы сразу опустили руки) и теперь вы пытаетесь оправдать это какой-то логикой? Создайте пустую конфигурацию с режимом совместимости 8.3.12 на платформе выше 8.3.15. Создайте процедуру в общем модуле например с Сообщить("Основная конфигурация)" расширьте её с помощью ИзменениеИКонтроль и там замените на Сообщить("Расширение") и с помощью кнопки в обработке вызовите её.
19. Monte Carlo 18.02.20 11:00 Сейчас в теме
(17) Да, прошу прощения. Не работают клиентские методы, а серверная процедура отработала.
21. MVK80 18.02.20 11:21 Сейчас в теме
(19), да там достаточно нюансов, но какие-то пока обходим, регистрируем ошибки. Но в целом всё норм, можно работать!
По поводу клиентских методов вот ошибка: https://bugboard.v8.1c.ru/error/000062705
20. Ndochp 101 18.02.20 11:20 Сейчас в теме
(9) Вы изменение и контроль не по статье с зазеркалья делаете? а то в релизе "КонецВставить" таки переименовали в "КонецВставки" и у меня ерпа работает.
22. Monte Carlo 18.02.20 12:47 Сейчас в теме
(20) Нет, использую #КонецВставки. В клиентском методе падает с ошибкой в модуле ****.cpp. Внутренняя платформенная ошибка, после которой приложение прекращает работу.
23. Ndochp 101 18.02.20 14:47 Сейчас в теме
(22) Забавно. У меня на 8.3.15.1656 полет нормальный. Совместимость 8.3.12, как в поставке.
Но выпадение в cpp это явно не признак штатной работы механизма совместимости.
25. ipoloskov 76 19.02.20 12:57 Сейчас в теме
(3) попробовал (ERP на 8.3.16.1063)
Сразу же после запуска выскочило сообщение, что исходный код модуля изменен (или что-то в этом духе)
26. igee12 19.02.20 16:53 Сейчас в теме
(25) Проверьте, чтобы не было лишних пустых строк за пределами #Вставка .. #КонецВставки, иначе "исходный" код метода 1С считает измененным.
16. costy_admin 46 15.02.20 09:59 Сейчас в теме
(1) Поддерживаю по моему сейчас проще все переводить на расширение.
4. stepan_s 13.02.20 08:27 Сейчас в теме
понятно что при помощи расширений будет красиво. Понятно что так лучше делать на будущее с типовыми....
Но автор наверное поделился опытом как было единственно возможно до недавнего времени....
Учитывая что функционал новый - не стоит слепо и не оглядываясь сразу использовать новые возможности, особенно поделки 1С :).

Но более меня смутило такое большое количество текста, интерпретирующее рекомендации 1С по обновлениям измененных конф, но только вскольз отмечен механизм сравнения при помощи сторонних инструментов (kDiff3) при этом с ремаркой "не расскажу".
Зачем упоминать если не рассказывать? Или как в голливудских фильмах - затравка на интерес к новой части?
8. ipoloskov 76 13.02.20 13:02 Сейчас в теме
(4) хммм, наверное потому, что я узнал про kDiff3 на этом сайте. Сейчас, к сожалению, не могу найти ту статью. Но про kDiff3 написано много где еще - зачем дублировать?
Рекомендации 1С не видел. Но, судя по попадающим ко мне конфигурациям, ранее поддерживавшихся другими компаниями, их вообще мало кто видел. Комментариев изменений форм не делают. Комментариев измерений ролей не делают. Я делюсь личным опытом, который позволяет мне обновлять десяток УПП, где я уже провел рефакторинг в соответствии с вышеуказанными рекомендациями, практически в фоновом режиме - минимально отвлекаясь от разработки.
5. vano-ekt 532 13.02.20 08:54 Сейчас в теме
О обновлениях

о правописании предлогов 🤦‍♂️
ben19791010; SpartakM; YanTsys; Monte Carlo; +4 Ответить
10. YanTsys 12 13.02.20 14:10 Сейчас в теме
Не добавляйте свои отчеты и обработки в дерево конфигурации. Их место - в дополнительных отчетах и обработках или в расширении.

Почему?
11. ipoloskov 76 13.02.20 14:34 Сейчас в теме
(10)
1) Это то, что просят подправить чаще всего. Чтобы лишний раз не изменять конфигурацию.
2) Отчетов накапливается много. Их перемещение вниз дерева конфигурации становится трудоемким (третий абзац снизу).
3) Можно настроить доступ конкретным пользователям, не заводя отдельные роли (если располагать в доп. отчетах).

Для обычных форм, минусы расположения в дополнительных отчетах - их нет в меню интерфейса, что неудобно пользователю. Я обходил это так: добавлял в интерфейс пункт меню с вызовом процедуры общего модуля:
Процедура ПлановыйТабельРабочегоВремени() Экспорт //эту процедуру я вызываю из меню
	
	ОткрытьВнешнийОтчет("Плановый табель рабочего времени");
	
КонецПроцедуры

Процедура ОткрытьВнешнийОтчет(Наименование)
	
	ВнешнийОтчет = Справочники.ВнешниеОбработки.НайтиПоНаименованию(Наименование, Истина);
	
	Если ВнешнийОтчет.Пустая() Тогда
		
		СообщениеОбОшибке = "Не найден внешний отчет """+Наименование+"""";
		Предупреждение(СообщениеОбОшибке);
		ЗаписьЖурналаРегистрации(СообщениеОбОшибке, УровеньЖурналаРегистрации.Ошибка, Метаданные.Справочники.ВнешниеОбработки);
			
	Иначе
	
		ЭтоОбработка = ?(ВнешнийОтчет.ВидОбработки = Перечисления.ВидыДополнительныхВнешнихОбработок.Обработка, Истина, Ложь);
		ЭтоОтчет = ?(ВнешнийОтчет.ВидОбработки = Перечисления.ВидыДополнительныхВнешнихОбработок.Отчет, Истина, Ложь);
		
		Если НЕ (ЭтоОбработка ИЛИ ЭтоОтчет) Тогда
			Возврат;
		КонецЕсли;
		
		Попытка
			
			ИмяФайла = ПолучитьИмяВременногоФайла();
			ДвоичныеДанные = ВнешнийОтчет.ХранилищеВнешнейОбработки.Получить();
			ДвоичныеДанные.Записать(ИмяФайла);
			
			Если ЭтоОбработка Тогда
				
				Форма = ВнешниеОбработки.ПолучитьФорму(ИмяФайла);
				
			Иначе
				
				Форма = ВнешниеОтчеты.ПолучитьФорму(ИмяФайла);
				
			КонецЕсли;
			
			Если Не Форма = Неопределено Тогда
				
				Форма.Открыть();
				
			Иначе
				
				Если ЭтоОбработка Тогда
					ВнешняяОбработка = ВнешниеОбработки.Создать(ИмяФайла);
				Иначе
					ВнешнийОтчет = ВнешниеОтчеты.Создать(ИмяФайла);
					Форма = ВнешнийОтчет.ПолучитьФорму();
					Если Форма <> Неопределено Тогда
						Форма.Открыть();
					КонецЕсли;
				КонецЕсли;
				
			КонецЕсли;
			
			ЗаписьЖурналаРегистрации("Открытие внешнего отчета", УровеньЖурналаРегистрации.Информация, Метаданные.Справочники.ВнешниеОбработки, ВнешнийОтчет);
			
		Исключение
			
			Если ЭтоОбработка Тогда
				
				Предупреждение("Выбранный файл не является внешней обработкой.
							   |Либо, данная обработка не предназначена для
							   |запуска в этой конфигурации.");
			Иначе
				Предупреждение("Выбранный файл не является внешним отчетом.
							   |Либо, данный отчет не предназначена для
							   |запуска в этой конфигурации.");
			КонецЕсли;
			
			ЗаписьЖурналаРегистрации("Ошибка открытия внешнего отчета", УровеньЖурналаРегистрации.Ошибка, Метаданные.Справочники.ВнешниеОбработки, ВнешнийОтчет);
			
		КонецПопытки;
		
	КонецЕсли;
	
КонецПроцедуры
Показать

В конфигурациях на управляемых формах я располагаю отчеты в расширении. Там уже можно легко добавить их в произвольный интерфейс-подсистему. Но можно вывести в интерфейс и отчет из дополнительных отчетов и обработок. Для этого нужно добавить в расширение общую команду с кодом
&НаКлиенте
Процедура ОбработкаКоманды(ПараметрКоманды, ПараметрыВыполненияКоманды)
	
	НаименованиеОбработки = "Этикетка товарных упаковок";
	
	ОбработкаСсылка = ОбработкаСсылка(НаименованиеОбработки);
	Если ОбработкаСсылка.Пустая() Тогда
		ОбщегоНазначенияКлиентСервер.СообщитьПользователю("Не найдена внешняя обработка """ + НаименованиеОбработки + """");
		возврат;
	КонецЕсли;
	
	ПараметрыФормы = Новый Структура;
	ПараметрыФормы.Вставить("ДополнительнаяОбработкаСсылка", ОбработкаСсылка);
	
	ИмяОбработки = ДополнительныеОтчетыИОбработкиВызовСервера.ПодключитьВнешнююОбработку(ОбработкаСсылка);
	ФормаОбработки = ОткрытьФорму("ВнешняяОбработка."+ ИмяОбработки +".Форма", ПараметрыФормы);
	
КонецПроцедуры

&НаСервере
Функция ОбработкаСсылка(Наименование)
	
	возврат Справочники.ДополнительныеОтчетыИОбработки.НайтиПоНаименованию(Наименование);
	
КонецФункции
Показать

а эту команду уже добавить в подсистему-интерфейс. После этого можно будет менять отчет, не меняя расширение, и отчет располагается удобно для пользователя - в панели интерфейса.
12. YanTsys 12 13.02.20 14:53 Сейчас в теме
(11)
Отчетов накапливается много. Их перемещение вниз дерева конфигурации становится трудоемким (третий абзац снизу).


Почему вниз? Мы свои объекты располагаем в начале списка, тогда их потом не приходится искать...

Чтобы лишний раз не изменять конфигурацию.


Конечно динамическое обновление у многих вызывает фантомные боли, но у нас оно уже очень давно беспроблемно работает...

Можно настроить доступ конкретным пользователям, не заводя отдельные роли (если располагать в доп. отчетах).

Аргумент. Но будут и обратные ситуации когда мы хотим просто назначить роль человеку и не вспоминать какой комплекс отчетов и обработок ему еще нужно настроить.

Я обходил это так: добавлял в интерфейс пункт меню с вызовом процедуры общего модуля:

Я для внешних обработок просто добавляю общую команду и потом даю к ней доступ в нужной подсистеме.
13. ipoloskov 76 13.02.20 15:07 Сейчас в теме
(12)
Мы свои объекты располагаем в начале списка, тогда их потом не приходится искать...

Сравнение с конфигурацией поставщика (такое иногда приходится делать) вывалит все объекты конфигурации с пометкой "изменен порядок". Если свои объекты внизу, такого не будет.
14. kosmo0 95 14.02.20 02:32 Сейчас в теме
Личный опыт по обычным формам (УПП).
1. В измененных блоках желательно помечать начало и конец измененного блока. Так как если в модуле изменения в нескольких местах, то невозможно определить что менялось и что не менялось. Можно словами "НачалоБлока" и "КонецБлока", можно скобками "<<" и ">>".

Процедура ааа()
//мои изменения
  действие1
  действие2
  действие3
КонецПроцедуры

Процедура ааа()
//мои изменения
//НачалоБлока
  действие1
  действие2
//КонецБлока
  действие3
КонецПроцедуры
Показать


2. В комментариях обязательно ставил дату изменения. При багах проще находить исходный код и, при наличии, сразу представлять масштаб некорректных данных в БД из-за работы измененного кода.

3. В некоторых случаях полезно оставлять исходный код. Когда он относительно небольшой и расположен в "критическом" месте. Например в общем модуле - всегда есть вероятность один вызов из 10000 не будет отрабатывать как предусмотрено (то есть в этом вызове нужен только исходный код). При этом также обрамление //ИсходныйКод_НачалоБлока и //ИсходныйКод_КонецБлока. Лично я оставлял это примерно на год, потом удалял (становилось ясно что грабли отсутствуют). Просто с таким блоком намного проще отлаживать баги - что было сразу видно и не надо открывать старую конфигурацию.

4. При изменении единственной строки - комментарий в конце строки. Визуально гораздо быстрее понимать масштаб изменений при сравнении/объединении. То есть "лишние" комментарии об изменениях усложняют и увеличивают работу. Возможно при небольших изменениях в типовой конфигурации это и не критично.

5.
По возможности добавляйте свои элементы форм программно – тогда перенос изменений при обновлении сведется к копированию/вставке кусков кода. Но без фанатизма – на обычных формах проще выделить мышкой и скопировать-вставить десяток элементов на добавленной странице, чем создавать их все программным способом, задавая расположение и привязки - пусть даже в перспективе это придется делать 10 или 100 раз. Однажды я перенес все многочисленные изменения форм УПП в код, а завод через полгода обанкротился.


Лично я бы рекомендовал добавления делать программно. Если копипастить визуальные элементы ОБЫЧНОЙ формы, то при сравнении с типовой эти элементы будут показываться как различающиеся с типовыми. Причем по всем реквизитам полное совпадение, но будет показано как различающееся (по крайней мере в 8.3.8 так было).
И если типовая форма изменилась и на ней есть ваши изменения визуальных элементов, то при объединении получается такая чушь.

Если вы пришли в организацию в которой масса изменений, то не стоит сломя голову бросаться переписывать все изменения элементов форм в программный вид. Делайте это только с теми формами которые изменяются часто.

кстати, рекомендую программно создаваемые элементы формы привязывать к низу формы (панели). И если новые типовые элементы перекроют ваши, то можно будет их увидеть растянув форму вниз (а иначе переделка конфигурации - сколько времени это займет? и что скажет на это бухгалтерия в отчетный период?)
24. ipoloskov 76 19.02.20 12:56 Сейчас в теме
(14) отмечать, где в блоке начало, а где конец, имеет смысл в двух случаях:
1) блок слишком большой, и визуально на экране не видно, где он начинается и заканчивается. В этом случае необходимо выделить его в отдельную процедуру.
2) вставок много, и они идут чередой среди аутентичного кода.
Во всех остальных случаях пометки типа "начало" и "конец" только добавляют мусора на экран.
15. anton13m 14.02.20 14:12 Сейчас в теме
В некоторых случаях адаптация расширений под новую версию может существенно усложнить обновление, т.к. механизм сравнения расширений с конфигурацией поставщика или основной, вроде бы, до сих пор отсутствует, да и бывает, что внесение изменений в конфигурацию будет предпочтительней, чем выносить доработки в расширение.
ipoloskov; Ndochp; +2 Ответить
18. triviumfan 14 17.02.20 20:02 Сейчас в теме
Даже не читал. Раз название темы безграмотное, следовательно и статья тоже.
Оставьте свое сообщение

См. также

Программная работа с настройками СКД

Статья Программист Нет файла v8 v8::СКД 1cv8.cf Бесплатно (free) Практика программирования

Нюансы программной работы с настройками системы компоновки данных в отчетах и динамических списках. Обзор всех видов настроек компоновки. Что в каких случаях правильно применять. В качестве примера рассмотрена работа с отборами и группировками.

27.01.2020    5097    ids79    25       

1C:Предприятие для программистов: Запросы и отчеты. Второй поток. Онлайн-интенсив с 17 марта по 16 апреля 2020 г. Промо

Данный онлайн-курс предусматривает углубленное изучение языка запросов и возможностей системы компоновки данных, которые понадобятся при разработке отчетов, работающих на платформе “1С:Предприятие” в рамках различных прикладных решений. Курс предназначен для тех, кто уже имеет определенные навыки конфигурирования и программирования в системе “1С:Предприятие”, а также для опытных пользователей различных прикладных решений, которые используют в своей работе отчеты разного назначения.

6500 рублей

[СКД] Программное создание схемы компоновки данных

Статья Программист Стажер Нет файла v8 v8::СКД 1cv8.cf Бесплатно (free) Практика программирования

Сделаем отчет на СКД полностью программно, без использования макета "схема компоновки данных".

15.01.2020    7080    John_d    21       

Онлайн-курс "Подготовка к экзамену 1С:Эксперт и 1С:Профессионал по технологическим вопросам" с 7 по 24 апреля 2020 г. Промо

На курсе вы получите практические навыки решения задач производительности 1С, в том числе характерных для высоконагруженных информационных систем (более 1000 пользователей). Подготовка к экзамену – только одна из составляющих курса. 70% слушателей приходят за знаниями, которые позволят расти и зарабатывать, делать сложные задачи на крупных проектах.

16450 рублей

Оповещения боту из 1С за 31 минуту

Статья Программист Нет файла v8::УФ 1cv8.cf Бесплатно (free) Практика программирования Интеграция

Поделюсь опытом, как быстро сделать бота с оповещениями в Телеграмм из 1С без лишних затрат.

18.09.2019    11344    4    feva    32       

Подборка решений для взаимодействия со ФГИС «Меркурий» Промо

С 1 июля 2019 года все компании, участвующие в обороте товаров животного происхождения, должны перейти на электронную ветеринарную сертификацию (ЭВС) через ФГИС «Меркурий». Инфостарт предлагает подборку программ, связанных с этим изменением.

Агрегатные функции СКД, о которых мало кто знает

Статья Программист Нет файла v8 v8::СКД 1cv8.cf Бесплатно (free) Практика программирования

Пользуетесь ли Вы всеми возможными агрегатными функциями, которые предоставляет система компоновки данных? Если Вы используете только: СУММА, КОЛИЧЕСТВО, МИНИМУМ, МАКСИМУМ, СРЕДНЕЕ, то эта статья для Вас.

05.09.2019    23693    ids79    45       

Программы для исполнения 488-ФЗ: Маркировка товаров Промо

1 января 2019 года вступил в силу ФЗ от 25.12.2018 № 488-ФЗ о единой информационной системе маркировки товаров с использованием контрольных (идентификационных) знаков, который позволяет проследить движение товара от производителя до конечного потребителя. Инфостарт предлагает подборку программ, связанных с применением 488-ФЗ и маркировкой товаров.

Три костыля. Сказ про фокусы в коде

Статья Программист Нет файла v8 Бесплатно (free) Практика программирования

Три интересных (или странных) костыля в коде, которые могут помочь в повседневных и не очень задачах.

03.09.2019    14920    YPermitin    75       

Отслеживание выполнения фонового задания

Статья Программист Нет файла v8 1cv8.cf Бесплатно (free) Практика программирования Универсальные функции Разработка

Запуск фонового задания из модуля внешней обработки. Отслеживание выполнения задания в виде прогресса, расположенного на форме.

17.08.2019    18022    ids79    16       

Базовый курс по обмену данными в системе 1С:Предприятие. Онлайн-интенсив с 12 по 28 мая 2020 г. Промо

Данный онлайн-курс предусматривает изучение механизмов платформы “1С:Предприятие”, обеспечивающих обмен данными между различными прикладными 1С-решениями и взаимодействие с другими информационными системами. Курс предназначен для тех, кто уже имеет определенные навыки конфигурирования и программирования в системе “1С:Предприятие”.

5500 рублей

Функции СКД: ВычислитьВыражение, ВычислитьВыражениеСГруппировкойМассив

Статья Программист Нет файла v8 v8::СКД 1cv8.cf Бесплатно (free) Практика программирования

Подробное описание и использование внутренних функций системы компоновки данных: Вычислить, ВычислитьВыражение, ВычислитьВыражениеСГруппировкойМассив, ВычислитьВыражениеСГруппировкойТаблицаЗначений.

08.08.2019    32498    ids79    36       

Фоновое выполнение кода в 1С - это просто

Статья Программист Нет файла v8 1cv8.cf Бесплатно (free) Практика программирования

Как легко запускать выполнение в фоне, не прибегая к долгому описанию фоновых процедур.

02.08.2019    18107    avalakh    21       

Сдача регламентированной отчетности из программ 1С Промо

Сдача регламентированной отчетности из программ "1С" во все контролирующие органы без выгрузок и загрузок в другие программы. Для групп компаний действуют специальные предложения.

от 1500 руб.

СКД - наборы данных и связи между ними, создание собственной иерархии, вложенные отчеты

Статья Программист Нет файла v8 v8::СКД 1cv8.cf Бесплатно (free) Практика программирования

Набор данных объект. Использование в схеме компоновки нескольких наборов данных. Различные варианты связи наборов: объединение, соединение. Использование иерархии в отчетах на СКД. Создание собственной иерархии, иерархия детальных записей. Использование вложенных схем в отчетах на СКД.

26.07.2019    26628    ids79    9       

Базовый курс по управлению ИТ-проектами. Курс проходит с 26 февраля по 22 апреля 2020 года. Промо

Отличительная черта курса - органичное сочетание трех вещей: 1.Теория проектного управления (PMI®+Agile Alliance+Российские ГОСТ+Методологии от 1С); 2. Опыт внедрения продуктов 1С (опыт франчайзи и успешных компаний + тренды Infostart Event и Agile Days); 3. Разбор реальных проблем и рекомендации экспертов по проектам слушателей. Мы будем фиксироваться на тех инструментах, которые реально оказываются полезными в практике руководителей проектов внедрения. Ведущая курса - Мария Темчина.

от 11000 рублей

СКД - использование расширений языка запросов, секция ХАРАКТЕРИСТИКИ

Статья Программист Нет файла v8 v8::СКД Бесплатно (free) Инструментарий разработчика Практика программирования

Автоматическое и не автоматическое заполнение полей компоновки данных. Использование расширений языка запросов для СКД «{…}», секция ВЫБРАТЬ, секция ГДЕ, параметры виртуальных таблиц. Автоматизированное использование дополнительных данных в запросе: секция ХАРАКТЕРИСТИКИ.

17.07.2019    19306    ids79    27       

Регистры сведений. За кулисами

Статья Программист Нет файла v8 1cv8.cf Бесплатно (free) Практика программирования Разработка

Небольшие заметки по внутреннему устройству регистров сведений.

09.07.2019    14650    YPermitin    12       

INFOSTART MEETUP Kazan. 13 марта 2020 г. Промо

Инфостарт продолжает путешествие по России. Следующая остановка - Казань. Тема мероприятия - управление и технологии автоматизации учета на платформе "1С: Предприятие". Ждем всех: докладчиков и участников! Стоимость участия - 5 500 рублей. Цена действительна до 30.01.2020

5 500

"Меньше копипаста!", или как Вася универсальную процедуру писал

Статья Программист Стажер Нет файла v8 v8::СКД 1cv8.cf Бесплатно (free) Практика программирования Разработка

Программист Вася разбирает подход создания универсальных методов на примере программного вывода СКД.

04.07.2019    11996    SeiOkami    49       

Создание отчетов с помощью СКД - основные понятия и элементы

Статья Программист Нет файла v8 v8::СКД Бесплатно (free) Практика программирования Математика и алгоритмы

Основные принципы работы СКД. Понятия схемы компоновки и макета компоновки. Описание основных элементов схемы компоновки: наборы данных, поля, вычисляемые поля, ресурсы, параметры.

25.06.2019    31402    ids79    17       

Программы для исполнения 54-ФЗ Промо

С 01.02.2017 контрольно-кассовая техника должна отправлять электронные версии чеков оператору фискальных данных - правила установлены в 54-ФЗ ст.2 п.2. Инфостарт предлагает подборку программ, связанных с применением 54-ФЗ, ККТ и электронных чеков.

Многопоточное ускорение однопользовательских нагрузок в 1С + Microsoft SQL Server 2017

Статья Программист Нет файла v8 v8::Запросы Бесплатно (free) Практика программирования Разработка

Взаимодействие с Microsoft SQL Server нередко вызывает трудности у 1С-ников, а потому интересны любые моменты, связанные с его использованием. О своем опыте работы с новым SQL Server 2017 участникам конференции Infostart-2018 рассказал директор ООО «Аналитика софт» Дмитрий Дудин.

11.06.2019    16790    dmurk    144       

Регистры накопления. Структура хранения в базе данных

Статья Программист Нет файла v8 1cv8.cf Бесплатно (free) Практика программирования Разработка

Структура хранения регистров накопления в базе данных для платформы 1С:Предприятие 8.x. Первая часть в серии публикаций.

16.05.2019    26949    YPermitin    27       

Новый раздел на Инфостарте - Electronic Software Distribution Промо

Инфостарт напоминает: на нашем сайте можно купить не только ПО, связанное с 1С. В нашем арсенале – ESD-лицензии на ПО от ведущих вендоров: Microsoft, Kaspersky, ESET, Dr.Web, Аскон и другие.

  • Низкие цены, без скрытых платежей и наценок
  • Оперативная отгрузка
  • Возможность оплаты с личного счета (кешбек, обмен стартмани на рубли и т.п.)
  • Покупки идут в накопления для получения скидочных карт лояльности Silver (5%) и Gold (10%)

Выполнение внешней обработки в фоновом задании

Статья Программист Нет файла v8 1cv8.cf Бесплатно (free) Практика программирования Разработка

Подробное описание подхода к созданию длительной операции на основе внешней обработки. Реализация протестирована на 1С 8.3.12.1714 (x64).

11.05.2019    17097    Eret1k    23       

Выгрузка документа по условию

Статья Программист Нет файла v8 Бесплатно (free) Практика программирования Разработка

Что делать, если документы нужно выгружать не все подряд, а по какому-то фильтру: статусу, дате, набору условий... А что если он соответствовал этим условиям, а потом перестал? А если потом опять начал? Такие ситуации заставили попотеть не одного программиста.

25.04.2019    9225    m-rv    2       

Готовые переносы данных из различных конфигураций 1C Промо

Рекомендуем готовые решения для переноса данных из различных конфигураций 1C. C техподдержкой от разработчиков и гарантией от Инфостарт.

Как прикрутить ГУИД к регистру сведений

Статья Программист Нет файла v8 Бесплатно (free) Практика программирования Перенос данных из 1C8 в 1C8 Разработка

... и немного теории обмена данными. В частности, разберем боль всех, кто пишет небанальные обмены данными: как набору записей регистра сведений назначить гуид и далее использовать его в обмене для идентификации этого набора.

16.04.2019    12342    m-rv    16       

О расширениях замолвите слово...

Статья Программист Стажер Нет файла v8 Бесплатно (free) Практика программирования Разработка

О чём стоит задуматься при принятии решения о создании расширения конфигурации…

07.04.2019    23182    ellavs    125       

Голосование за доклады на INFOSTART MEETUP Kazan - до 25 февраля. Промо

Выбирайте и голосуйте за самые интересные доклады! Лучшие из лучших попадут в окончательную программу казанского митапа. Оставить свой голос можно до 25 февраля 2020 года.

Git-репозитории для 1С-кода (опыт использования при небольших проектах)

Статья Программист Стажер Нет файла v8 Windows Бесплатно (free) Практика программирования Разработка

Инструкции по взаимодействию с Git-репозиторием, которые писались для тех наших программистов, которые вообще никогда не работали с Git (руководства в духе "Как получить код из git-репозитория?", "Как отправить код в git-репозиторий")...

28.03.2019    18391    ellavs    83       

Трюки с внешними источниками данных

Статья Программист Нет файла v8 1cv8.cf Бесплатно (free) Практика программирования Разработка

Некоторые трюки для преодоления ограничений внешних источников данных.

14.03.2019    20239    YPermitin    53