Быстрый вход в 1С под другим пользователем

Публикация № 154075

Учет и отчетность - Бухгалтерский учет

Всего лишь кликните два раза по выбранному пользователю и 1С откроется под ним.
Для тех, у кого нет мани - выкладываю код.
Пригодилась - не забываем плюсовать.
Перем темпПользовательОС;
Перем темпПользовательИБ;


Процедура ТабличноеПолеВыбор(Элемент, ВыбраннаяСтрока, Колонка, СтандартнаяОбработка)
	Если НЕ ВыбраннаяСтрока.ЭтоГруппа Тогда
		СтандартнаяОбработка = Ложь;
		Если НЕ ЗначениеЗаполнено(ПользовательОС) Тогда
			Предупреждение("Не выбран пользователь ОС");
			Возврат;
		КонецЕсли;
		//Предварительно удалим у всех авторизацию, схожую с нашей
		ОчиститьАвторизациюОС();
		//Затем назначим нужному юзеру
		ПользовательИБ = ПользователиИнформационнойБазы.НайтиПоИмени(СокрЛП(ВыбраннаяСтрока.Код));
		Если ПользовательИБ <> Неопределено Тогда
			Если ПользовательИБ.АутентификацияОС Тогда
				//Запомним старую аутентификацию
				темпПользовательОС = ПользовательИБ.ПользовательОС;
				темпПользовательИБ = ПользовательИБ;
			КонецЕсли;
			ПользовательИБ.АутентификацияОС = Истина;
			ПользовательИБ.ПользовательОС = ПользовательОС;
			Попытка
				ПользовательИБ.Записать();
			Исключение
				Сообщить(ОписаниеОшибки());
			КонецПопытки;
		КонецЕсли;
		Если Найти(СтрокаСоединенияИнформационнойБазы(),"Srvr=") = 0 Тогда
			СтрокаЗапуска = "C:\Program Files (x86)\1cv82\common\1cestart.exe ENTERPRISE        "+СтрЗаменить(СтрЗаменить(СтрокаСоединенияИнформационнойБазы(),"File="," /F "),";","")+" /n """+ПользовательИБ.Имя+"";
		Иначе
			СтрокаЗапуска = "C:\Program Files (x86)\1cv82\common\1cestart.exe ENTERPRISE "+СтрЗаменить(СтрЗаменить(СтрЗаменить(СтрЗаменить(СтрокаСоединенияИнформационнойБазы(),"Srvr="," /S "),";Ref=""","/"),"""",""),";","")+" /n """+ПользовательИБ.Имя+"";
		КонецЕсли;
		ЗапуститьПриложение(СтрокаЗапуска);
	КонецЕсли;
КонецПроцедуры

Процедура ОчиститьАвторизациюОС()
	СписокПользователей = ПользователиИнформационнойБазы.ПолучитьПользователей();
	Для н = 0 По СписокПользователей.Количество() - 1 Цикл
		Если СписокПользователей[н].ПользовательОС = ПользовательОС Тогда
			ПользовательИБ =      ПользователиИнформационнойБазы.НайтиПоУникальномуИдентификатору(СписокПользователей[н].УникальныйИдентификатор);
			ПользовательИБ.АутентификацияОС = Ложь;
			ПользовательИБ.ПользовательОС = "";
			ПользовательИБ.Записать();
		КонецЕсли;
	КонецЦикла;
КонецПроцедуры

Процедура ПользовательОСНачалоВыбора(Элемент, СтандартнаяОбработка)
	СтандартнаяОбработка = Ложь;
	ФормаВыбораПользователяWindows = ПолучитьОбщуюФорму("ФормаВыбораПользователяWindows", ЭтаФорма);
	ФормаВыбораПользователяWindows.ВыбранныйПользовательWindows = ПользовательОС;
	Результат = ФормаВыбораПользователяWindows.ОткрытьМодально();
	Если Результат <> Неопределено Тогда
		ПользовательОС = Результат;
	КонецЕсли;
КонецПроцедуры

//Затираем следы
Процедура ПриЗакрытии()
	//Авторизацию снова очищаем
	Если ЗначениеЗаполнено(темпПользовательОС) Тогда
		//Восстановим старую аутентификацию
		темпПользовательИБ.АутентификацияОС = Истина;
		темпПользовательИБ.ПользовательОС = темпПользовательОС;
		Попытка
			темпПользовательИБ.Записать();
		Исключение
			Сообщить(ОписаниеОшибки());
		КонецПопытки;
		//Если до этого не было аутентификации, то она не нужна
	Иначе
		ОчиститьАвторизациюОС();
	КонецЕсли;
КонецПроцедуры

Скачать файлы

Наименование Файл Версия Размер
Медвежатник

.epf 7,91Kb
255
.epf 7,91Kb 255 Скачать

Специальные предложения

Комментарии
В избранное Подписаться на ответы Сортировка: Древо развёрнутое
Свернуть все
1. KonstB 177 01.10.12 09:42 Сейчас в теме
4. jig 145 01.10.12 09:58 Сейчас в теме
(1) KonstB, У меня немного по другому работает, без подмены пароля.
6. KonstB 177 01.10.12 10:40 Сейчас в теме
(4) У меня и так и так )
+ это уже все реализовано тут: Подсистема "Инструменты разработчика" v2.60 и в мобильной версии.
поэтому у Вас очередной велосипед :)
9. jig 145 01.10.12 14:25 Сейчас в теме
(6) KonstB, В данную обработку не смотрел. Каждая новая наработка - немного чей-то велосипед.
2. ivs200999 01.10.12 09:48 Сейчас в теме
Можно чуть подробнее о реализации? Сбрасывается пароль?
3. jig 145 01.10.12 09:51 Сейчас в теме
(2) ivs200999, В конфигурации подменяется авторизация, после закрытия обработки - все становится на свои места.
5. ivs200999 01.10.12 10:04 Сейчас в теме
(3) Да, я уже увидел, спасибо.
7. DimaP 56 01.10.12 14:18 Сейчас в теме
ПараметрыСеанса.ТекущийПользователь = <Выбранный из списка>


тут так?
8. jig 145 01.10.12 14:23 Сейчас в теме
(7) DimaP, Нет, тут запуск непосредственно под выбранным пользователем.
10. shadow264 2 01.10.12 14:47 Сейчас в теме
А что классная задумка=)экономит пару минут на тестах,ставлю +
11. KonstB 177 01.10.12 14:56 Сейчас в теме
Надо администрацию попросить отключить ПОИСК по сайту - все равно никто не пользуется :)
12. DimaP 56 01.10.12 21:55 Сейчас в теме
(11) Пользуется!
Но пока найдешь что нужно/скачешь - все мани кончатся ))
13. KonstB 177 02.10.12 09:16 Сейчас в теме
(12) DimaP, Поэтому многие, в последнее время, начали всякую чушь, да копи-пасты выкладывать - тем самым засоряя ресурс ((( В результате имеем проблемы с последующим поиском...
ojiojiowka; +1 Ответить
14. jig 145 02.10.12 10:30 Сейчас в теме
(13) KonstB, зачем тут мне комментарии засорять??? Можно в своих темах рассуждать о засорах ресурса. поставь уже минус - да иди с миром.
15. KonstB 177 02.10.12 12:10 Сейчас в теме
(14) Ничего не могу поделать - раз уж затрагивается наболевшая тема...
Я ради этого и сделал публикацию - по своей сути "фуфел" (ничего особенного) - что бы позасорять комментарии, но у Вас активности больше ))) Хотел этот вопрос на форуме поднять, но все как то руки не доходят (
16. OrsoBear 03.10.12 11:43 Сейчас в теме
Предлагаю подобные вещи помимо отчета еще и примерами кода снабжать.
Действительно, чтобы глянуть, что сделал автор, приходится скачивать обработку,
тратятся средства.
17. jig 145 03.10.12 12:32 Сейчас в теме
Без проблем могу выложить, только хотябы плюсы ставьте.
18. kanalex 27 29.11.12 10:10 Сейчас в теме
{Форма.Форма.Форма(32)}: Значение не является значением объектного типа (Имя)
СтрокаЗапуска = "C:\Program Files (x86)\1cv82\common\1cestart.exe ENTERPRISE "+СтрЗаменить(СтрЗаменить(СтрЗаменить(СтрЗаменить(СтрокаСоединенияИнформационнойБазы(),"Srvr="," /S "),";Ref=""","/"),"""",""),";","")+" /n """+ПользовательИБ.Имя+"";

{Форма.Форма.Форма(52)}: Ошибка при вызове метода контекста (ПолучитьОбщуюФорму)
ФормаВыбораПользователяWindows = ПолучитьОбщуюФорму("ФормаВыбораПользователяWindows", ЭтаФорма);
по причине:
Недопустимое значение параметра (параметр номер '1')
19. jig 145 29.11.12 11:44 Сейчас в теме
(18) kanalex, Здравствуйте. Данная обработка писалась на стандартной УТ 10.3, там присутствует общая форма выбора пользователя. Если так ругается, то заполните поле - имя пользователя вручную, \\имяДомена\имяЮзера.
20. echo77 1188 19.06.13 09:06 Сейчас в теме
Оформите публикацию нормально - код можно оформить и покрасивее.
Вот, почитайте статью : http://infostart.ru/public/66592/
21. jig 145 19.06.13 13:12 Сейчас в теме
(20) echo77, Благодарю за подсказку.
22. nixel 1013 26.06.13 18:05 Сейчас в теме
Восстановления паролей у пользователей, очищенных процедурой ОчиститьАвторизациюОС() не предусмотрено? =)
Действительно, а зачем им...
23. jig 145 27.06.13 13:30 Сейчас в теме
(22) nixel, внимательней читаем код:
Процедура ПриЗакрытии()
//Авторизацию снова очищаем
Если ЗначениеЗаполнено(темпПользовательОС) Тогда
//Восстановим старую аутентификацию
темпПользовательИБ.АутентификацияОС = Истина;
темпПользовательИБ.ПользовательОС = темпПользовательОС;
Попытка
темпПользовательИБ.Записать();
Исключение
Сообщить(ОписаниеОшибки());
КонецПопытки;
//Если до этого не было аутентификации, то она не нужна
Иначе
ОчиститьАвторизациюОС();
КонецЕсли;
КонецПроцедуры
24. nixel 1013 27.06.13 15:09 Сейчас в теме
(23) это только для одного сохраненного во временной переменной пользователя. а процедурка очищает всех, что найдет.

Процедура ОчиститьАвторизациюОС()
    СписокПользователей = ПользователиИнформационнойБазы.ПолучитьПользователей();
    Для н = 0 По СписокПользователей.Количество() - 1 Цикл
        Если СписокПользователей[н].ПользовательОС = ПользовательОС Тогда
            ПользовательИБ =      ПользователиИнформационнойБазы.НайтиПоУникальномуИдентификатору(СписокПользователей[н].УникальныйИдентификатор);
            ПользовательИБ.АутентификацияОС = Ложь;
            ПользовательИБ.ПользовательОС = "";
            ПользовательИБ.Записать();
        КонецЕсли;
    КонецЦикла;
КонецПроцедуры
Показать
25. nixel 1013 27.06.13 15:12 Сейчас в теме
(23) все, нашел. тотально скретинил, извиняюсь =)
26. Borunmeert 28.06.13 10:07 Сейчас в теме
не работает в УПП 1.3. ничего не происходит при нажатии!
27. jig 145 02.07.13 20:36 Сейчас в теме
(26) goodwin11, Проверьте правильность написания "пользователя windows".
28. a.podobin 27.05.14 10:21 Сейчас в теме
Итак, тестирование показало следующие недочеты:
1. если серверная БД, то ключ пути к БД должен быть через обратный слэш --> /S db-srv\CENTER
скорее всего у некоторых скачавших и не запускается, просто ничего не происходит. обратите внимание на п.2 если решили протестировать на других юзверах!
2. в случае если необходимо запустить БД под несколькими пользователями, при закрытии восстановление настроек выполняется только для последнего.

Для "взял и пользуйся" - далеко.
Для "допила" - нормально.

Без понимания 2-го пункта в живой базе можно натворить беды.
29. jig 145 29.05.14 14:32 Сейчас в теме
(28) a.podobin, Спасибо за комментарий, но по второму пункту не согласен! Вот код:
Процедура ОчиститьАвторизациюОС()
СписокПользователей = ПользователиИнформационнойБазы.ПолучитьПользователей();
Для н = 0 По СписокПользователей.Количество() - 1 Цикл
Если СписокПользователей[н].ПользовательОС = ПользовательОС Тогда
ПользовательИБ = ПользователиИнформационнойБазы.НайтиПоУникальномуИдентификатору(СписокПользователей[н].УникальныйИдентификатор);
ПользовательИБ.АутентификацияОС = Ложь;
ПользовательИБ.ПользовательОС = "";
ПользовательИБ.Записать();
КонецЕсли;
КонецЦикла;
КонецПроцедуры
т.е. очистка будет авторизации будет у всех пользователей, у которых прошла подмена.
30. Светлый ум 268 19.11.15 13:55 Сейчас в теме
В портативных инструментах разработчика - эта штука тоже есть.
33. Светлый ум 268 08.11.16 09:54 Сейчас в теме
(30) Светлый ум, приспичела версия для 8.1 и та что в "инструментах разработчика" - не подошла:
- а ваша шуршит-работает)
+1
34. Светлый ум 268 08.11.16 10:07 Сейчас в теме
(33) Модуль и форму руками перетаскивал.
31. veyron21 128 20.01.16 10:22 Сейчас в теме
А мне кажется, что обработка весьма полезная.
Чтобы не тратить много времени на знакомство с подсистемой инструментов разработчика, можно скачать эту поделку и пользоваться себе наздоровье. Автор молодец, даже исходник выложил.
32. echo77 1188 24.01.16 11:24 Сейчас в теме
ИМХО, это не будет работать в клиент-серверном варианте, если сервер 1С работает вне домена, а вы пытаетесь запустится под другим пользователем не с сервера 1С
Оставьте свое сообщение

См. также

Проверка данных после неполного ("нового") переноса из ЗУП 2.5 в ЗУП 3.1 Промо

Зарплата Бухгалтерский учет Перенос данных из 1C8 в 1C8 Зарплата v8 v8::СПР ЗУП3.x Россия БУ Абонемент ($m)

Описаны данные, которые необходимо проверить после неполного ("нового") переноса из ЗУП 2.5 в ЗУП 3.1. Описано, на что необходимо обратить внимание, где найти перенесенные данные, что НЕ переносится, где найти настройки.

1 стартмани

17.01.2018    33548    149    utrumar    3    

Регистры налогового учета на управляемых формах (ностальгия по Бухгалтерии 2.0)

Налоговые Бухгалтерский учет Анализ учета v8 v8::БУ v8::УФ БП3.0 Россия НУ Налог на прибыль Абонемент ($m)

Все организации, работающие на общей системе налогообложения, должны вести налоговый учет по налогу на прибыль в аналитических регистрах налогового учета, формы которых разрабатываются налогоплательщиком самостоятельно и должны быть включены в приложения к учетной политике по налоговому учету. Многие бухгалтеры тяготеют к внешнему виду отчетов Бухгалтерии 2.0. Для них эти отчеты.

1 стартмани

17.08.2020    2443    1    AlexandrSmith    0    

Реестр платежей для Бухгалтерии предприятия, редакция 3.0 БИТ.ФИНАНС 3.1

Печатные формы документов Бухгалтерский учет v8 v8::БУ БП3.0 Россия БУ Абонемент ($m)

Внешняя печатная форма "Реестр платежей" для документа "Реестр платежей" (Бухгалтерия 3.0 БИТ.ФИНАНС 3.1 3.1.46.2).

1 стартмани

01.08.2020    2461    0    mkola    0    

Кассовая книга по подразделениям, БП 3.0

Кассовые операции Бухгалтерский учет v8 v8::БУ БП3.0 Россия БУ Абонемент ($m)

Внешний отчет "Кассовая книга по подразделениям" предназначен для печати отдельных кассовых книг для разных подразделений в обычной (не КОРП) Бухгалтерии 3.0.

1 стартмани

24.06.2020    3522    31    baldorc    8    

Инструкции по работе в 1С ЗУП Промо

Пользователю системы Бухгалтерский учет Зарплата Управление персоналом (HRM) Зарплата Управление персоналом (HRM) v8 ЗУП2.5 БУ УУ Абонемент ($m)

Инструкции Кадровика и Расчетчика. Ничего лишнего. Скрины из реальной базы. Обработка открытия (обычное приложение) + файлы в формате MS WORD *.doc (открывается во ВСЕХ версиях программы WORD!). 50+ страниц!

1 стартмани

25.12.2013    57475    541    vladim-kul    35    

Движения денежных средств для 1С:Бухгалтерия 3.0. Актуально для анализа денежных потоков

Бухгалтерский учет Финансовые v8 v8::БУ v8::СКД БП3.0 Россия БУ Абонемент ($m)

Данный внешний отчет предназначен для Бухгалтерии 3.0. Кажется, что он будет очень востребован руководителями компаний, финансистами.

1 стартмани

12.04.2020    2746    8    alfanika    0    

Материальный отчет для Бухгалтерии 3.0

Бухгалтерский учет Учет ТМЦ v8::БУ БП3.0 Россия БУ Абонемент ($m)

Материальный отчет предназначен для получения отчета по материальным счетам в Бухгалтерия 3.0. Может быть использован как бухгалтерами, так и программистами для доработки. Сделан по стандартной Унифицированной форме МХ-20.

1 стартмани

05.03.2020    2364    9    mkola    1    

Свод имущества по МОЛ (ЦМО) с инвентарными номерами. БГУ 1, БГУ 2

Учет ОС и НМА Бухгалтерский учет v8 v8::БУ v8::СКД БГУ Государственные, бюджетные структуры Россия БУ Госбюджет Абонемент ($m)

Отчет Свод имущества по ЦМО (центру материальной ответственности) для БГУ 1 и БГУ 2. Какое имущество и на каких счетах числится за МОЛ, + инв номера ОС. Показатели: баланс, счет учета, нефинансовый актив (ОС, номенклатура, БСО или денежные документы), инв. номер ОС, количество и сумма.

1 стартмани

02.03.2020    3825    13    aleksF16    0    

Методические материал очного тренинга по теме «Планирование производства в программе «1С:ERP Управление предприятием 2.0» (1С:ERP) Промо

Бухгалтерский учет Производство готовой продукции (работ, услуг) Производство готовой продукции (работ, услуг) v8 ERP2 УУ Абонемент ($m)

В методичке представлен пошаговый пример реализации планирования производства в новой ERP-системе фирмы 1С - "1C:ERP Управление предприятием 2.0".

1 стартмани

13.05.2014    56321    531    1СERP    7    

Технические проверки данных регистров бухгалтерии (отчет на СКД)

Администрирование данных 1С Бухгалтерский учет Механизмы бухгалтерского учета v8::БУ 1cv8.cf БУ Абонемент ($m)

Отчет для технических проверок данных бухгалтерских регистров.

5 стартмани

25.02.2020    7192    26    YPermitin    2    

Справка-расчет переоценки валютных средств (с оборотами)

Справки Печатные формы документов Бухгалтерский учет v8::БУ БП3.0 Россия БУ Абонемент ($m)

Внешний отчет на базе штатной справки-расчета переоценки валютных средств к регламентной операции переоценки валютных средств на конец месяца. В отличие от штатной справки отчет независимый (не привязан к регламентной операции (документу) по переоценке валютных средств), выполняется за произвольный период и включает обороты переоценки порожденные различными документами.

1 стартмани

15.02.2020    3819    19    Shang    3    

Свернутый акт сверки для 1С:Бухгалтерии 3.0

Дебиторская и кредиторская задолженность Комиссионная торговля Оптовая торговля Бухгалтерский учет v8 v8::БУ БП3.0 Оптовая торговля, дистрибуция, логистика Россия БУ Абонемент ($m)

Удобно для торговых предприятий, которые часто сталкиваются с возвратами, и для тех, кого не устраивают записи сторно в акте сверки.

2 стартмани

06.02.2020    3208    1    r.resh39    0    

Учет расчетов с филиалами и представительствами в 1С (проблемы и решения) Промо

Дебиторская и кредиторская задолженность Управленческий учет (прочее) Бухгалтерский учет Дебиторская и кредиторская задолженность v8 Россия БУ Абонемент ($m)

Часто, работая с различными базами клиентов, наблюдаешь факты ошибок бухгалтерии по настройке учета расчетов с контрагентами, которые имеют филиалы и представительства. И если клиент сам имеет филиальную структуру, то система ошибок иногда достигает превышения уровня существенности, что приводит к отрицательному аудиторскому заключению. При этом, от неверного подхода к данному учету нарушается не только бухгалтерский, управленческий, но и налоговый учет в части НДС, налога на прибыль, а у упрощенцев – налог по УСН.

1 стартмани

17.02.2012    106745    75    Виктор1905    13    

Инфографика для БГУ ред.2

Бухгалтерские Бухгалтерский учет v8 v8::БУ БГУ Государственные, бюджетные структуры Россия БУ Госбюджет Абонемент ($m)

Простой отчет, позволяющий вывести ключевые показатели учета в Бухгалтерии государственного учреждения (редакция 2).

1 стартмани

02.02.2020    3355    3    dunpil    2    

Бухгалтерская отчетность, бухгалтерский баланс в редакции от 19.04.2019 № 61н c выгрузкой в формате версии 5.08, утвержденной приказом от 13.11.2019 № ММВ-7-1/570@. Для конфигурации КА 1.1

Регламентированная отчетность Бухгалтерский учет Бухгалтерия Механизмы бухгалтерского учета v8 КА1 Россия БУ Абонемент ($m)

Внешняя обработка для сдачи бухгалтерского баланса в редакции от 19.04.2019 № 61н c выгрузкой в формате версии 5.08, утвержденной приказом от 13.11.2019 № ММВ-7-1/570@. Для конфигурации КА 1.1 с отчетности за 2019 год.

5 стартмани

24.01.2020    8463    39    dnikolaev    10    

Универсальный конструктор отчетов по бухгалтерским оборотам и остаткам

Оборотно-сальдовая ведомость, Анализ счета Бухгалтерский учет v8 v8::БУ КА1 БП2.0 УПП1 БУ Абонемент ($m)

Универсальный конструктор отчетов на основе оборотов и остатков регистров бухгалтерии. Имеется возможность настройки бланка отчета. Гибкое оформление позволяет в том числе готовить финансовую отчетность на иностранных языках для иностранного руководства. Может работать в любой типовой конфигурации, поддерживающей бухгалтерские проводки, и не требует ее изменения или доработки. Поддерживает любое количество настроенных вариантов отчетов. Все варианты хранятся внутри базы и не потеряются при копировании базы в другое место (например, на ноутбук). Поддерживает работу с любым регистром бухгалтерии. В одном отчете можно использовать источники из разных регистров. В качестве показателей могут выступать любые ресурсы регистров бухгалтерии (не только "Сумма").

3 стартмани

04.01.2020    3974    4    1cspecialist    1    

Счет-фактура полученный (за поставщика) для БП 2.0 / БП 3.0

Печатные формы документов Бухгалтерский учет Оптовая торговля v8 v8::БУ БП2.0 БП3.0 БУ Абонемент ($m)

Счет-фактура полученный (за поставщика) для БП 2.0 / БП 3.0 для документа счет-фактура полученный.

1 стартмани

26.12.2019    3960    6    prime9    1    

Личная карточка (унифицированная форма Т-2) (ЗУП 3.1)

Управление персоналом (HRM) Бухгалтерский учет v8 v8::СПР ЗУП3.x Россия БУ Абонемент ($m)

Внешний отчет позволяет печатать Унифицированную форму Т-2 (ЗУП 3.1).

1 стартмани

26.11.2019    5041    21    KrasinAA    5    

Акт сверки в разрезе договоров, для конфигурации Бухгалтерия для Казахстана ред. 3

Печатные формы документов Бухгалтерский учет Дебиторская и кредиторская задолженность v8 v8::БУ БП3.0 Казахстан БУ Абонемент ($m)

Внешняя печатная форма к документу "Акт сверки взаиморасчетов" в разрезе договоров, для конфигурации Бухгалтерия для Казахстана ред. 3.

1 стартмани

26.11.2019    5583    10    Bakytzhan_777    7    

Настроить ЗУП? Да легко! Промо

Зарплата Управленческий учет (прочее) Бухгалтерский учет Зарплата v8 КА1 ЗУП2.5 ЗКБУ УПП1 Россия БУ НДФЛ Абонемент ($m)

Специалисты, внедряющие зарплатные решения, а также бухгалтера по зарплате не дадут соврать, что процесс настройки зарплатной программы - творческий. Еще бы, информации, которую нужно держать в голове не то что много, ее слишком много. Нужно обладать познаниями как в нюансах законодательства, так и представлять себе особенности работы программы. Возможно, именно поэтому зарплата считается одним из самых сложных участков учета, и многие молодые внедренцы боятся ее как огня. При этом зарплатчики всегда востребованы, так как если без автоматизации, например, торговли еще можно обойтись, то без автоматизации учета зарплаты никак.

1 стартмани

16.01.2013    43214    763    tomvlad    59    

Отчет по контрактам: исполнение, последняя дата поставки, а также привязка к остаткам на счете 304.01

Бухгалтерский учет v8::БУ БГУ Государственные, бюджетные структуры Россия БУ Госбюджет Абонемент ($m)

Обработка выводит контракты, полностью исполненные по поставкам (все операции по ОС, услугам , материалам и пр.) и при этом существуют остатки на счете 304.01 по обеспечениям контрактов. Т.е. создана для избежания ситуаций по просрочке возвратов обеспечения.

1 стартмани

20.11.2019    3255    4    JohnOEM    0    

Регистр - расчет финансового результата в разрезе номенклатурных групп для БП 3.0

Бухгалтерский учет Учет доходов и расходов Финансовые v8 v8::БУ БП3.0 Россия БУ Абонемент ($m)

Расчет финансового результата в разрезе номенклатурных групп для Бухгалтерии 3.0.

2 стартмани

11.11.2019    5615    14    alex649    0    

Отчет по основным средствам для БП 3.0

Бухгалтерский учет Учет ОС и НМА v8::БУ БП3.0 Россия БУ Абонемент ($m)

Отчет позволяет вывести подробную информацию по ОС на выбранную дату.

1 стартмани

07.11.2019    6513    22    anton448    5    

Операционное планирование движения денежных средств или как построить систему контроля расходования денежных средств Промо

Финансовый учет и бюджетирование (FRP) Учет доходов и расходов Управленческий учет (прочее) Бухгалтерский учет Анализ учета Финансовые Управленческие Финансовый учет и бюджетирование (FRP) Учет доходов и расходов v8 КА1 УПП1 Госбюджет УУ Абонемент ($m)

Данная статья посвящена операционному планированию движения денежных средств и будут раскрыты следующие аспекты этой деятельности: 1. роль операционного планирования ДС в жизни компании; 2. подсистема операционного планирования ДС в типовой конфигурации «1С:Управление производственным предприятием ред. 1.3 (релиз 1.3.32.1)» (далее по тексту УПП); 3. особенности и ошибки типовой подсистемы УПП; 4. практический опыт внедрения подсистемы операционного планирования ДС; 5. возможные варианты доработок, исправления ошибок типовой подсистемы УПП;

1 стартмани

24.12.2012    78879    189    Vladimir_Konyrev    36    

Статистика: Форма 57-Т за октябрь 2019. ЗУП.3.1

Зарплата Бухгалтерский учет Статистические Статистики v8 v8::СПР ЗУП3.x Россия БУ Абонемент ($m)

Формирование статистического отчета 57-Т за октябрь 2019 года по форме 2017 года. Так как 1С еще не разработала отчет 57-Т за октябрь 2019 года, разработано расширение, которое сформирует отчет 57-Т за октябрь 2019 года по форме 2017 года. Проблема типового отчета 57-Т по формату 2017 года в том, что выбирая любой период - отчет всегда формируется за октябрь 2017 года. Данное расширение исправляет эту проблему: отчет можно сформировать за выбранный вами период, в том числе и за октябрь 2019 года.

1 стартмани

06.11.2019    11764    106    user_2010    38    

Табель учета рабочего времени Т-13 с неявками в рабочих днях и часах для ЗУП 3.1 и КА 2

Зарплата Учет рабочего времени Бухгалтерский учет v8 v8::СПР ЗУП3.x Россия БУ Абонемент ($m)

Внешний отчёт "Табель учета рабочего времени Т-13" с неявками в календарных и рабочих днях и часах.

1 стартмани

05.11.2019    4835    8    елена777    0    

Бухгалтерская справка для документа "Регламентная операция" для Бухгалтерии 3.0

Справки Печатные формы документов Бухгалтерский учет v8::БУ БП3.0 Россия БУ Абонемент ($m)

Столкнулись с необходимостью печати Бухгалтерской справки для документа "Регламентная операция". В функционале программы такая справка имеется только для операций, введенных вручную.

1 стартмани

18.10.2019    3731    7    teplova    0    

Управленческий учет — третий лишний?! Промо

Управленческий учет (прочее) Бухгалтерский учет v8 КА1 УПП1 Россия УУ Абонемент ($m)

Из комментариев к моим предыдущим статьям, особенно «БП, КА, УПП: Три правды», выяснилось, что управленческий учет (УУ) некоторыми пользователями воспринимаются, как «нехорошие излишества», а пропаганда и обсуждение УУ причисляется к «миссионерской деятельности». С фанатичностью, достойной борцов за коммунизм, оппоненты пишут: «Не подскажете, какую еще правду, кроме бухгалтерской, можно поискать в УПП? Т.е. вообще в учетных системах? Любая учетная система направлена не на фиксацию фактов (хотя это важная составляющая), а на оптимизацию функционирования объекта учета. Бухгалтерский учет отличается тем, что в качестве критериев оптимальности использует денежные показатели (прибыль, доход, рентабельность и т.п.). Это и есть бухгалтерская правда. Назовите мне еще что-нибудь - без помавания и камлания мифическими понятиями потребностей "менеджеров". Какие еще такие "результаты работы разных служб" существуют?» (орфография автора сохранена). Попробуем ответить на этот вопрос.

2 стартмани

19.08.2012    49480    3    PAVI    302    

Отчеты к аккредитации высших учебных заведений

Справки Управление персоналом (HRM) Бухгалтерский учет v8 v8::СПР ЗКГУ3.0 Государственные, бюджетные структуры БУ Госбюджет Абонемент ($m)

Отчеты к аккредитации высших учебных заведений Справки о кадровом обеспечении ООП высшего образования, Справка о квалификации руководящих и научно-педагогических работников ВУЗа

1 стартмани

17.10.2019    4647    0    mib7    0    

Свод проводок по начислениям и удержаниям в таблицах для документа "Отражение заработной платы в регламентированном учете" (УПП 1.3)

Зарплата Бухгалтерский учет Печатные формы документов v8 УПП1 Россия БУ Абонемент ($m)

Внешняя печатная форма для документа "Отражение заработной платы в регламентированном учете".

1 стартмани

25.09.2019    3934    2    vlgogolev    0    

Расчетный листок для ЗУП 3.1, ЗИК 3.1 с расшифровкой показателей начислений, сдельный заработок

Зарплата Бухгалтерские Бухгалтерский учет v8 v8::СПР ЗКБУ ЗКГУ3.0 ЗУП3.x БУ Госбюджет Абонемент ($m)

В данном расчетном листке реализована возможность вывода подробной информации по показателям для расчета. Например стандартный вывод показателей не показывает процент северной надбавки, вывод в отдельной колонке. Также в случае с сдельным начислением реализован вывод подробной информации об выполненных видах работ, их расценке и объёму.

2 стартмани

18.09.2019    6515    28    pogroleg    30    

Технологический анализ.Часть 2 Промо

Бухгалтерский учет Анализ учета v8 БГУ Россия БУ Абонемент ($m)

В первой части мы с вами рассмотрели первый раздел типового технологического анализа. В этой части мы рассмотрим второй раздел.

1 стартмани

01.06.2012    14278    117    Brunetochka    0    

Электронное учебное пособие по практической работе в программах 1С:Розница 8, 1С:Управление торговлей 8 и 1С:Управление нашей фирмой 8

Кассовые операции Оптовая торговля Розничная торговля Ценообразование, анализ цен Пользователю системы Бухгалтерский учет Кассовые операции Оптовая торговля Розничная торговля Ценообразование, анализ цен v8 Розница УНФ УТ11 Россия УУ Абонемент ($m)

Электронное учебное пособие предназначено для получения практических навыков по работе в программах «1С:Розница 8», «1С:Управление торговлей 8» и «1С:Управление нашей фирмой 8». Пособие содержит 4 главы, каждая из которых, посвящена отдельной торговой программе на платформе «1С:Предприятие 8».

3 стартмани

30.07.2019    7900    25    delta    0    

Как работать в ERP. Демонстрационный пример для мебельных предприятий. Для ЕРП / КА2

Пользователю системы Производство готовой продукции (работ, услуг) Бухгалтерский учет Производство готовой продукции (работ, услуг) v8 ERP2 КА2 Беларусь Россия Казахстан БУ УУ Абонемент ($m)

Методическое руководство, для демонстрации отраслевых возможностей 1С:Управление предприятием и 1С Комплексная автоматизация ред.2. Адаптировано для мебельных предприятий, упрошенный вариант производства.

5 стартмани

01.07.2019    7826    14    Константин С.    2    

Инструкция по переработке давальческого сырья в 1С: ERP. Упрощенное производство

Бухгалтерский учет Производство готовой продукции (работ, услуг) Пользователю системы Производство готовой продукции (работ, услуг) v8 v8::ОУ ERP2 Россия БУ УУ Абонемент ($m)

Пользовательская инструкция по работе с блоком "Переработка давальческого сырья" в упрощенной схеме производства (без планирования этапов производства).

5 стартмани

24.06.2019    11242    22    BagiraN    10    

Распределение НДС Промо

Бухгалтерский учет v8 БП2.0 Россия БУ НДС Абонемент ($m)

Памятка по распределению НДС для бухгалтеров материального отдела работающие с 1С Бухгалтерия 2.0

1 стартмани

22.04.2012    15789    139    abyrvalcom    1    

Синхронизация 1С:Зарплата и кадры государственного учреждения, редакция 3, и БГУ 1.0

Бухгалтерский учет Зарплата Зарплата v8 БГУ ЗКГУ3.0 Россия БУ Абонемент ($m)

Инструкция для бухгалтера, что необходимо донастроить в программах, для заполнения КПС при синхронизации между "Зарплата и кадры государственного учреждения, редакция 3" с БГУ 1.0.

1 стартмани

07.03.2019    5693    15    сибирь    3    

Ведение учета по нескольким единицам измерения для одного объекта учета в программах 1С без изменения конфигурации

Оптовая торговля Розничная торговля Учет ТМЦ Управленческие Бухгалтерский учет Оптовая торговля Розничная торговля Учет ТМЦ v8 v8::УФ 1cv8.cf УУ Абонемент ($m)

Решение, позволяющее организовать учет по двум и более единицам измерения, для одного объекта учета в программах 1С без изменения конфигурации (т.е. без доработок).

1 стартмани

07.09.2017    11792    3    vittol    4    

Готовое решение Финансовый учет в БП+ИТАН+ДО

Финансовый учет и бюджетирование (FRP) Бухгалтерский учет Финансовый учет и бюджетирование (FRP) v8 БП3.0 Россия Госбюджет УУ Абонемент ($m)

ПРИМЕР ПО ФУНКЦИОНАЛУ УПРАВЛЕНИЕ ДЕНЕЖНЫМИ СРЕДСТВАМИ К ПРОЕКТУ БЕСШОВНОЙ ИНТЕГРАЦИИ БП+ИТАН С ДО

3 стартмани

24.07.2017    9546    3    advard    0    

Руководство пользователя по документам товарных операций в 1С: Комплексная автоматизация 1.1 (УПП 1.3)

Бухгалтерский учет Оптовая торговля Пользователю системы Оптовая торговля v8 КА1 Россия БУ Абонемент ($m)

Руководство пользователя по документам товарных операций в 1С Комплексная автоматизация 1.1 (УПП 1.3) в формате pdf. Создано по системе справочной информации конфигурации 1С:Комплексная автоматизация, редакция 1.1 (1.1.83.2) с иллюстрациями (57 листов А4)

2 стартмани

27.03.2017    21492    24    a_lexus_2004    1    

Термическая обработка деталей. Термообработка. Отражение в УПП

Бухгалтерский учет Производство готовой продукции (работ, услуг) Производство готовой продукции (работ, услуг) v8 УПП1 Машиностроение и приборостроение Металлургическая промышленность Россия БУ УУ Абонемент ($m)

На промышленном заводе используется термообработка металлоизделий в процессе производства - закалка, отпуск. Есть оказание услуг по термообработке на сторону. Используется конфигурация УПП-1.3, РАУЗ. Встал вопрос, как отражать это в программе. Хочу поделиться соображениями по теме и способом отражения, принятым у нас.

1 стартмани

03.03.2017    10464    3    rasdva    1    

Учет основных средств стоимостью не более 40 000 рублей (количественный учет на МЦ.4)

Бухгалтерский учет Учет ОС и НМА Учет ОС и НМА v8 БП2.0 Россия БУ Абонемент ($m)

Описание учета товарно-материальных ценностей стоимостью до 40 000 руб по инвентарным номерам.

1 стартмани

01.07.2016    9884    6    уля    1    

Инструкция по УПП для создания графиков отпусков

Бухгалтерский учет Управление персоналом (HRM) Учет рабочего времени Управление персоналом (HRM) Учет рабочего времени v8 УПП1 УУ Абонемент ($m)

Инструкция для пользователей УПП, для работы с документами и справочниками: - Остатки отпусков - Ввод графиков отпусков - Ввод фактических отпусков

1 стартмани

04.02.2016    8263    9    burnand2    1    

Откуда берутся данные 6-НДФЛ в ЗУП 2.5

Бухгалтерский учет Зарплата Зарплата v8 ЗУП2.5 Россия БУ НДФЛ Абонемент ($m)

Как заполняются данные 6-НДФЛ? Файл с картинками и описанием дополнений учета НДФЛ в ЗУП 2_5_99 по сравнению с прежними версиями.

1 стартмани

03.02.2016    180975    156    milov.aleksey    126    

Методическое пособие для микрофинансовых организаций "Учет займов с использованием системы 1С: Бухгалтерия 8 редакция 3.0"

Управленческий учет (прочее) Бухгалтерский учет Займы, кредит, лизинг Займы, кредит, лизинг v8 БП2.0 Финансовые услуги, инвестиции Россия БУ Абонемент ($m)

Подробное иллюстрированное практическое руководство по учету привлеченных и выданных займов в микрофинансовых организациях в программе 1С:Бухгалтерия 8.

5 стартмани

06.01.2016    17098    9    irinik51    1    

Схема учета НДС в УПП 1.3 (документы и регистры)

Бухгалтерский учет Оптовая торговля Оптовая торговля v8 УПП1 Россия БУ НУ НДС Абонемент ($m)

Небольшая схема-шпаргалка по учету НДС в УПП 1.3. В схеме расписаны документы и регистры, с помощью которых осуществляется учет.

1 стартмани

22.10.2015    8180    25    max.hohlov    1    

Перевыставление транспортных услуг

Бухгалтерский учет Производство готовой продукции (работ, услуг) Производство готовой продукции (работ, услуг) v8 УПП1 БУ НУ Абонемент ($m)

В данной статье рассмотрен вариант реализации в 1С:УПП 1.3 операций по перевыставлению транспортных услуг перевозчиков, работающих по упрощенной системе налогообложения, с помощью подписки на событие. В теоретической части данной статьи использовались выдержки из статьи Владимира Малышко «Транзитная торговля», опубликованной в ежемесячном журнале «Практический бухгалтерский учет» №6,7 2013 г.

1 стартмани

20.08.2015    60076    12    el-le    4