Загрузка товаров из внешних файлов в произвольный документ (УТ11, КА2, ERP; Розница 2)

Публикация № 1224859 15.04.20

Пользовательские инструменты - Обработка документов

обработка загрузка excel таблица табличный внешний файл

Речь пойдет о том, как типовой механизм "Загрузки из внешнего файла" прикрутить к, по сути, любому документу, где есть табличная часть Товары. Пример приведен на Перемещении товаров, и с каждым документом может быть своя специфика, но общий механизм совпадет. В приложенном готовом варианте расширения механизм подключен еще к двум документам - Списаниям и Оприходованиям.

На Инфостарте (да и в интернете) предлагают различные способы загрузки из внешних файлов. Это действительно часто помогает пользователям (если, конечно, файл имеет какую-то повторяющуюся структуру).

И - иногда люди хотят видеть именно загрузку из Excel-файла, а иногда .. привыкают к тому механизму, который уже реализовала 1с (но, почему-то, далеко не во всех документах).

Так случилось и в этот раз - пользователи обратились с пожеланием, чтобы в "Перемещении товаров" был такой же механизм, как и в поступлении ("Заполнить - Загрузить из внешнего файла").

 

Итак.

Механизм задействует две ключевые вещи:

1. Запуск обработки с формы документа - "Обработка.ЗагрузкаДанныхИзВнешнихФайлов";

2. Заполнение документа по данным обработки через событие формы "Обработка выбора".

**Обновлено 25.04.2020

Протестировано на 1С:Комплексная автоматизация 2 (2.4.11.65)

Код подходит для документов Оприходование Излишков Товаров и Списание Недостач Товаров, кроме вот этой строки

//специфика перемещения ++
   СтрокаТЧТовары.КодСтроки=0;//код строки заказа
//специфика перемещения --

**Обновлено 23.12.2020

1. Протестировано на УТ 11.4.13

2. Убрано несколько зависимостей (не должно проверяться значение основного языка конфигурации, удалено обращение к картинке, которую удалили из актуальных релизов конфигурации)

**Обновлено 09.01.2022

1. Для Розницы тоже подходит (но листинг несколько отличается). Добавлено отдельное расширение под Розницу.
2. Протестировано на Розница 8, редакция 2.3 (2.3.10.36)

 

**Обновлено 28 .07.2022

Протестировано на 1С:Комплексная автоматизация 2 (2.5.8.232)

 

**Обновлено 24 .08.2022

Внесена небольшая правка в Перемещение (Версии для КА,УТ,ERP)

Реализация

1. Забираем в расширение форму документа "Перемещение товаров".

2. Создаем новую команду - "ЗагрузитьИзВнешнегоФайла", и создаем такой обработчик

&НаКлиенте
Процедура ЗагрузитьИзВнешнегоФайла(Команда)
	
    ОтборТовар = Новый Массив(1);
    ОтборТовар[0] = ПредопределенноеЗначение("Перечисление.ТипыНоменклатуры.Товар");
    
    ПараметрыФормы = Новый Структура();
    ПараметрыФормы.Вставить("ЗагружатьКоличество", Истина);
    ПараметрыФормы.Вставить("ЗагружатьЦены", Ложь);
    ПараметрыФормы.Вставить("ЗагружатьСуммы", Ложь);
    ПараметрыФормы.Вставить("ЦенаВключаетНДС", ложь);
    //ПараметрыФормы.Вставить("Партнер", Объект.Партнер);
    //ПараметрыФормы.Вставить("СопоставлятьПоНоменклатуреПоставщиков", Истина);
    ПараметрыФормы.Вставить("ЗагружатьГТД", Ложь);
    
    ПараметрыФормы.Вставить("ЗагружатьЗапасы",           Ложь);
    ПараметрыФормы.Вставить("ЗагружатьСкидки",           Ложь);
    ПараметрыФормы.Вставить("ЗагружатьУпаковочныеЛисты", Ложь);
    
    ПараметрыФормы.Вставить("ПересчитыватьСуммы", Истина);
    ПараметрыФормы.Вставить("ЦенаВключаетНДС",    Истина);
    ПараметрыФормы.Вставить("Организация",        Неопределено);
    ПараметрыФормы.Вставить("НалогообложениеНДС",
        ПредопределенноеЗначение("Перечисление.ТипыНалогообложенияНДС.ПродажаОблагаетсяНДС"));
    
    ПараметрыФормы.Вставить("ОтборПоТипуНоменклатуры", Новый ФиксированныйМассив(ОтборТовар));
    ПараметрыФормы.Вставить("ИмяТЧ", "Товары");
    ПараметрыФормы.Вставить("ЗагружатьСкидки", Ложь);
    ПараметрыФормы.Вставить("Заголовок", НСтр("ru = 'Загрузка товаров из внешних файлов'"));
    ПараметрыФормы.Вставить("ПараметрыОтбора", Новый Структура);
    ПараметрыФормы.Вставить("ДатаЗаполнения",     '00010101');
    
    
    Оповещение = Новый ОписаниеОповещения("ЗагрузитьИзВнешнегоФайлаЗавершение", ЭтотОбъект, "Товары");
    РаботаСТабличнымиЧастямиКлиент.ПоказатьФормуЗагрузкиНоменклатуры(ПараметрыФормы, Оповещение);

	
КонецПроцедуры

3. Создаем оповещение, на которое мы сослались в предпоследней строке

4. Из него вызовем функцию "ПолучитьЗагруженныеТоварыИзХранилища", которую тут же и опишем. Сделано по аналогии с функцией в "Приобретении товаров и услуг", но выброшена часть кода.

&НаКлиенте
Процедура ЗагрузитьИзВнешнегоФайлаЗавершение(АдресЗагруженныхДанных, ДополнительныеПараметры) Экспорт

    Если ЗначениеЗаполнено(АдресЗагруженныхДанных) Тогда
        ПолучитьЗагруженныеТоварыИзХранилища(АдресЗагруженныхДанных, ДополнительныеПараметры);
    КонецЕсли;

КонецПроцедуры


&НаСервере
Процедура ПолучитьЗагруженныеТоварыИзХранилища(АдресТоваровВХранилище, ИмяТЧ)

	ТоварыИзХранилища = ПолучитьИзВременногоХранилища(АдресТоваровВХранилище);
    
    КэшированныеЗначения = ОбработкаТабличнойЧастиКлиентСервер.ПолучитьСтруктуруКэшируемыеЗначения();
    
    СтруктураДействий = Новый Структура;
    //СтруктураДействий.Вставить("ЗаполнитьНоменклатуруПоставщикаПоНоменклатуре", Объект.Партнер);
        
    Для Каждого СтрокаТоваров Из ТоварыИзХранилища Цикл
        СтрокаТЧТовары = Объект[ИмяТЧ].Добавить();
        ЗаполнитьЗначенияСвойств(СтрокаТЧТовары, СтрокаТоваров);
        Если ИмяТЧ = "Товары" Тогда
            ОбработкаТабличнойЧастиСервер.ОбработатьСтрокуТЧ(СтрокаТЧТовары, СтруктураДействий, КэшированныеЗначения);
        КонецЕсли;
                //специфика перемещения ++
                СтрокаТЧТовары.КодСтроки=0;//код строки заказа
                //специфика перемещения --
    КонецЦикла;


КонецПроцедуры

Если есть желание поскорее окунуться в работу (и доработку механизма для своих задач), во вложении - готовое расширение.

Скачать файлы

Наименование Файл Версия Размер
Загрузка из внешнего файла (Перемещение,Списание, Оприходование) - УТ 11.4,ERP 2.4, KA 2.4

.cfe 59,86Kb
56
.cfe УТ 11.4,ERP 2.4, KA 2.4 59,86Kb 56 Скачать
Загрузка товаров из внешних файлов в произвольный документ (УТ11.5, КА2.5, ERP2.5):

.cfe 83,88Kb
2
.cfe УТ11.5, КА2.5, ERP2.5 83,88Kb 2 Скачать
Загрузка из внешнего файла (Оприходование) - ( Розница 2):

.cfe 24,57Kb
2
.cfe v 09 01 2022 24,57Kb 2 Скачать

Специальные предложения

Комментарии
В избранное Подписаться на ответы Сортировка: Древо развёрнутое
Свернуть все
1. klaus38 01.06.20 09:17 Сейчас в теме
Вот спасибо. Я изначально такие сложные конструкции сваял, а вот как надо было.
2. ooliyah 03.06.20 01:34 Сейчас в теме
Здравствуйте! В УТ 11.4.6.230 и Рознице 2.2. при подключении расширения выдает ошибку (на скриншоте). Подскажите пожалуйста, в чем может быть проблема.
Прикрепленные файлы:
3. erutan 89 03.06.20 15:36 Сейчас в теме
(2)Здравствуйте!
Попробуйте, пожалуйста, снять вот эту галку (см скриншот)

Если так и не поможет, напишите, пожалуйста, личное сообщение

ps можно еще вот этот объект удалить
Прикрепленные файлы:
4. user1281106 30.11.20 12:17 Сейчас в теме
Здравствуйте. Скачал расширение, но не могу установить. выскакивает ошибка
Прикрепленные файлы:
5. erutan 89 30.11.20 17:59 Сейчас в теме
(4) Здравствуйте! Попробуйте, пожалуйста, снять проверку с этого свойства (скриншот выше).
Умеете с конфигуратором работать?

Если вдруг совсем нет, могу попробовать подключиться по энидеск, в личку только напишите, и время надо будет согласовать.
6. Горыныч_Злой 21.12.20 09:17 Сейчас в теме
Добрый день, по наследству от предыдущего коллеги досталась и ваша работа. :)

Сейчас после обновления до 11.4.13 не стыковка не только по языку, но и потерялась картинка (что-то с «…Вид цены»)
7. erutan 89 22.12.20 10:06 Сейчас в теме
(6) здравствуйте!
Жду от Вас уточнения в личных сообщениях
8. user626746_sportleader_z 18.01.21 14:39 Сейчас в теме
Добрый день! Возможно ли использовать эту доработку в 1С:Предприятие 8.3 (8.3.16.1063). Конфигурация Розница 8. Магазин одежды и обуви, редакция 2.3 (2.3.6.17) ?
9. erutan 89 18.01.21 20:01 Сейчас в теме
(8) на 100% не скажу, но\

>>Так случилось и в этот раз - пользователи обратились с пожеланием, чтобы в "Перемещении товаров" был такой же механизм, как и в >>поступлении ("Заполнить - Загрузить из внешнего файла").

если в Поступлении есть такая команда ("Заполнить - Загрузить из внешнего файла").

то должно сработать
10. simuljakr 198 10.04.21 18:15 Сейчас в теме
Отлично! Спасибо! Зделал по-аналогии загрузку комплектующих в справочник "варианты комплектаций" - все работает!
11. 12345sponche 28.12.21 12:27 Сейчас в теме
Спасибо за статью, по аналогии добавил возможность загрузки из файла в документ "Перемещение" 1с УТ.
Только я еще в командную панель добавил кнопку "Загрузить из файла" и на эту кнопку привязал команду "ЗагрузитьИзВнешнегоФайла"
12. 12345sponche 28.12.21 12:47 Сейчас в теме
13. sponchebob 8 28.12.21 12:51 Сейчас в теме
Спасибо! Получается в любой документ, в котором есть табличная часть товаров, можно интегрировать данный функционал?
14. erutan 89 28.12.21 16:41 Сейчас в теме
(13) Здравствуйте! По сути, да (но может немного меняться код - если появится какой-то обязательный реквизит, и тд)
sponchebob; +1 Ответить
15. sponchebob 8 28.12.21 19:48 Сейчас в теме
(14) Статья реально полезная, надо 1с интегрировать возможность загрузки из файла в каждый документ!
16. user1237931 14.04.22 17:53 Сейчас в теме
В УТ 11.5 убрали из конфигурации обработку ЗагрузкаДанныхИзВнешнихФайлов
Теперь ее заменяет обработка ЗагрузкаТоваровИзВнешнихФайлов которая должна вызываться из процедуры общего модуля РаботаСТабличнымиЧастямиКлиент.ПоказатьФормуЗагрузкиНоменклатуры и описанный выше метод уже не работает...
17. erutan 89 18.04.22 18:02 Сейчас в теме
(16) спасибо!
Пока не обновлялись на эту ветку. Постараюсь на майских праздниках посмотреть , что можно сделать ..
19. euch 14.06.22 17:39 Сейчас в теме
(16) У меня заработало после правок и копипасты кода из других документов:

&НаКлиенте
Процедура ЗагрузитьИзВнешнегоФайла(Команда)
	
	ОтборТовар = Новый Массив(1);
	ОтборТовар[0] = ПредопределенноеЗначение("Перечисление.ТипыНоменклатуры.Товар");
	
	ПараметрыФормы = Новый Структура();
	ПараметрыФормы.Вставить("ЗагружатьКоличество", Истина);
	ПараметрыФормы.Вставить("ЗагружатьЦены", Ложь);
	ПараметрыФормы.Вставить("ЗагружатьСуммы", Ложь);
	ПараметрыФормы.Вставить("ЦенаВключаетНДС", ложь);
	//ПараметрыФормы.Вставить("НалогообложениеНДС", Объект.НалогообложениеНДС);
	//ПараметрыФормы.Вставить("Партнер", Объект.Партнер);
	//ПараметрыФормы.Вставить("СопоставлятьПоНоменклатуреПоставщиков", Истина);
	ПараметрыФормы.Вставить("ЗагружатьГТД", Ложь);
	
	ПараметрыФормы.Вставить("ЗагружатьЗапасы",           Ложь);
	ПараметрыФормы.Вставить("ЗагружатьСкидки",           Ложь);
	ПараметрыФормы.Вставить("ЗагружатьУпаковочныеЛисты", Ложь);
	
	ПараметрыФормы.Вставить("ПересчитыватьСуммы", Истина);
	ПараметрыФормы.Вставить("ЦенаВключаетНДС",    Истина);
	ПараметрыФормы.Вставить("Организация",        Неопределено);
	ПараметрыФормы.Вставить("НалогообложениеНДС",
		ПредопределенноеЗначение("Перечисление.ТипыНалогообложенияНДС.ПродажаОблагаетсяНДС"));
	
	ПараметрыФормы.Вставить("ОтборПоТипуНоменклатуры", Новый ФиксированныйМассив(ОтборТовар));
	ПараметрыФормы.Вставить("ИмяТЧ", "Товары");
	ПараметрыФормы.Вставить("ЗагружатьСкидки", Ложь);
	ПараметрыФормы.Вставить("Заголовок", НСтр("ru = 'Загрузка товаров из внешних файлов'"));
    ПараметрыФормы.Вставить("ПараметрыОтбора", Новый Структура);
    ПараметрыФормы.Вставить("ДатаЗаполнения",     '00010101');
	
	
	Оповещение = Новый ОписаниеОповещения("ЗагрузитьИзВнешнегоФайлаЗавершение", ЭтотОбъект, "Товары");
    РаботаСТабличнымиЧастямиКлиент.ПоказатьФормуЗагрузкиНоменклатуры(ПараметрыФормы, Оповещение);
	
КонецПроцедуры

&НаКлиенте
Процедура ЗагрузитьИзВнешнегоФайлаЗавершение(АдресЗагруженныхДанных, ДополнительныеПараметры) Экспорт

	Если ЗначениеЗаполнено(АдресЗагруженныхДанных) Тогда
		ПолучитьЗагруженныеТоварыИзХранилища(АдресЗагруженныхДанных, ДополнительныеПараметры);
	КонецЕсли;

КонецПроцедуры

&НаКлиенте
Процедура Расш_Загр_ОбработкаВыбораПеред(ВыбранноеЗначение, ИсточникВыбора)
	Если ИсточникВыбора.ИмяФормы = "Обработка.ЗагрузкаТоваровИзВнешнихФайлов.Форма.Форма" Тогда
		
		ПолучитьЗагруженныеТоварыИзХранилища(ВыбранноеЗначение, ИсточникВыбора);
		
	КонецЕсли;
КонецПроцедуры

&НаСервере
Процедура ПолучитьЗагруженныеТоварыИзХранилища(АдресТоваровВХранилище, ИмяТЧ)
//Процедура ПолучитьЗагруженныеТоварыИзХранилища(РезультатВыбора, ИмяТЧ)
	
	//ТоварыИзХранилища = ПолучитьИзВременногоХранилища(РезультатВыбора.АдресТоваровВХранилище);
	ТоварыИзХранилища = ПолучитьИзВременногоХранилища(АдресТоваровВХранилище);
	//ИмяТЧ = РезультатВыбора.ИмяТЧ;
	
	КэшированныеЗначения = ОбработкаТабличнойЧастиКлиентСервер.ПолучитьСтруктуруКэшируемыеЗначения();
	
	СтруктураДействий = Новый Структура;
	//СтруктураДействий.Вставить("ЗаполнитьНоменклатуруПоставщикаПоНоменклатуре", Объект.Партнер);
	
	Если ИмяТЧ = "Товары" Тогда
		//НаправленияДеятельностиКлиентСервер.СтруктураДействийВставитьПриДобавленииСтроки(ЭтаФорма, СтруктураДействий);
	КонецЕсли;
	
	Для Каждого СтрокаТоваров Из ТоварыИзХранилища Цикл
		СтрокаТЧТовары = Объект[ИмяТЧ].Добавить();
		ЗаполнитьЗначенияСвойств(СтрокаТЧТовары, СтрокаТоваров);
		Если ИмяТЧ = "Товары" Тогда
			ОбработкаТабличнойЧастиСервер.ОбработатьСтрокуТЧ(СтрокаТЧТовары, СтруктураДействий, КэшированныеЗначения);
		КонецЕсли;
                //специфика перемещения ++
                СтрокаТЧТовары.КодСтроки=0;//код строки заказа
                //специфика перемещения --
	КонецЦикла;
	
	Если ИмяТЧ = "Товары" Тогда
		//ЗаполнитьСтатусыУказанияСерийСервер();
	КонецЕсли;

КонецПроцедуры
Показать
user1237931; erutan; +2 Ответить
18. Adilgeriy 23 28.04.22 01:44 Сейчас в теме
может подскажете почему не отображается колонка номенклатура партнера в типовой загрузке
23. erutan 89 28.07.22 11:38 Сейчас в теме
(18) возможно, надо поэкспериментировать со св-м "ПараметрыФормы.Вставить("СопоставлятьПоНоменклатуреПоставщиков", Истина);"
В данном примере оно вообще закомментировано
20. user1811910 08.07.22 20:12 Сейчас в теме
можно ли каким-то образом не заполнять данные для поиска номенклатуры (штрихкод, код, Артикул, Номенклатура), а поиск выполнялся только по характеристики?
21. erutan 89 11.07.22 10:09 Сейчас в теме
(20) боюсь, что не подскажу. Все никак не доберусь до функционала сам, чтобы проверить.
22. erutan 89 28.07.22 11:37 Сейчас в теме
(20)
характеристики

Вообще, с точки зрения 1с, Характеристика - это всегда нечто, подчиненное номенклатуре. Так что без допила вряд ли получится.
Одни и те же хар-ки могут быть у разных номенклатур (например, "размер 42" у разной обуви)
24. Горыныч_Злой 08.08.22 13:14 Сейчас в теме
(22)
Вообще, с точки зрения 1с, Характеристика - это всегда нечто, подчиненное номенклатуре. Так что без допила вряд ли получится.
Одни и те же хар-ки могут быть у разных номенклатур (например, "размер 42" у разной обуви)


А если взять что Характеристика уникальна? раельно заделать загрузку по Характеристикам (Характеристика + колл.) ?
25. Горыныч_Злой 24.08.22 15:41 Сейчас в теме
Доработки ожидаются ?
В 11.4 работало, в 11.5.7.402 в документе перемещение кнопа появилась но не работает ;(

По характеристикам да :( без переделки в самой конфе не обойтись :(
26. erutan 89 24.08.22 20:42 Сейчас в теме
(25) Здравствуйте. Проверю сегодня.
27. erutan 89 24.08.22 20:48 Сейчас в теме
(25) Стоп. А вы версию под ERP 2.5 / УТ 11.5 пробовали? Я отдельно выложил
28. Горыныч_Злой 24.08.22 23:22 Сейчас в теме
29. erutan 89 25.08.22 07:30 Сейчас в теме
(28)проверьте, пожалуйста, личные сообщения. Сейчас должно все работать (ну и в шапке обновил версию)
30. Горыныч_Злой 25.08.22 09:31 Сейчас в теме
(29) Да, всё, теперь красота.. Спасибо
Задумка, работа нужная,..
почему 1С_ки не думают о тех кто работает на их продукте... мля...
Оставьте свое сообщение

См. также

Аванс с проверкой невыходов (Расширение для ЗУП 3.1 и ЗКГУ 3.1) Промо

Обработка документов Зарплата Платформа 1С v8.3 Сложные периодические расчеты 1С:Зарплата и кадры государственного учреждения 3 1С:Зарплата и Управление Персоналом 3.x Россия Бухгалтерский учет Абонемент ($m)

Проверка перед выплатой аванса в документе "Ведомость в банк" и "Ведомость в кассу" по отсутствующим сотрудникам. Тестировал на платформе 1С:Предприятие 8.3 (8.3.15.1489), конфигурации Зарплата и управление персоналом, редакция 3.1 (3.1.10.78) и Зарплата и кадры государственного учреждения, редакция 3.1 (3.1.10.78)

2 стартмани

26.07.2019    10811    50    APTEM_SLV    43    

"1С:Розница 8. Ювелирный магазин" - кол. УИН в списках ДМДК, альтернативная печать DataMatrix, заполнение партий для ДМДК по артикулам/штрихкодам

Розничная торговля WEB-интеграция Платформа 1С v8.3 1С:Розница Ювелирная промышленность и торговля Россия Абонемент ($m)

В связи с обязанностью организаций отражать остатки (а чуть позже, и выбытие в рознице) - многим придется или обновлять/дорабатывать свою систему, или переходить на систему со встроенной поддержкой ГИИС ДМДК. Мы решили использовать ПП 1С:Розница 8. Ювелирный магазин. О самом процессе упомяну лишь вскользь, т.к. существуют инструкции и по настройке туннеля stunnel, и вебинары по пользованию программой. Но на этапе заведения остатков ряд вещей мы посчитали неудобными, потому доработали их, так или иначе, об этом и расскажу.

1 стартмани

25.01.2022    3747    1    erutan    10    

Перепроведение документов с контролем проводок

Обработка документов Платформа 1С v8.3 Бухгалтерский учет Конфигурации 1cv8 Бухгалтерский учет Абонемент ($m)

Немного переделанная стандартная обработка «Проведение документов», контролирует проводки документов и если они изменились — сообщает об этом.

1 стартмани

05.06.2021    7492    9    AnryMc    0    

Обнуление остатков и движений регистров накопления (УФ) Промо

Чистка данных Обработка документов Склад и ТМЦ Платформа 1С v8.3 Управляемые формы Конфигурации 1cv8 Россия Управленческий учет Абонемент ($m)

Универсальная обработка обнуления регистров накопления (остатки и обороты) для любой* конфигурации под управляемые формы.

4 стартмани

01.12.2017    14781    79    aleksch21    7    

Связанные документы или Структура подчиненности (КА 2.4, ERP 2, УТ 11)

Обработка документов Платформа 1С v8.3 1С:ERP Управление предприятием 2 1С:Управление торговлей 11 1С:Комплексная автоматизация 2.х Управленческий учет Абонемент ($m)

В форму структуры подчиненности документов добавлены кнопки проведения, отмены проведения и пометки на удаление. Также красным подсвечены поступления денег и синим списания.

1 стартмани

13.07.2020    18160    26    silver_jr    1    

"Учет штрафов ГИБДД" с возможной загрузкой из открытых источников в интернет Расширение конфигурации 1С: Предприятие 8.3

Обработка документов WEB-интеграция Платформа 1С v8.3 Управляемые формы Конфигурации 1cv8 Россия Бухгалтерский учет Управленческий учет Абонемент ($m)

Расширение конфигурации Бухгалтерия предприятия, редакция 3.0 (при минимальных изменениях любой типовой конфигурации), позволяющее вести историю данных по штрафам ГИБДД для справочника транспортных средств компании. Бонусом поставляется внешняя обработка, способная загружать эти данные из открытых источников в интернет.

4 стартмани

30.12.2019    26594    38    capitan    26    

Пакетное пробитие чеков на Онлайн-кассе при оплатах от физических лиц на расчетный счет

Банковские операции Кассовые операции Обработка документов Платформа 1С v8.3 Бухгалтерский учет 1С:Бухгалтерия 3.0 Россия Бухгалтерский учет Абонемент ($m)

Автоматизация процесса пробития чеков онлайн при поступлениях на расчетный счет от физических лиц. Помогает сократить трудозатраты таким организациям, как МФЦ, Управляющие компании и т.д. Подходит для 1С:Бухгалтерия 3.0 любой версии (базовая, ПРОФ, КОРП). Не изменяет конфигурацию. Конфигурация остается на поддержке (типовая).

2 стартмани

24.09.2019    29446    17    r.resh39    15    

Подсистема "Корректировка движений документов" Промо

Обработка документов Платформа 1С v8.3 Управляемые формы Конфигурации 1cv8 Абонемент ($m)

Универсальная подсистема, позволяющая просматривать и корректировать движения документа по учетным регистрам конфигурации прямо из его формы. Подсистема актуальна для тех конфигураций, в которых подобный функционал не предусмотрен (например, типовая конфигурация "Управление торговлей 11").

3 стартмани

10.03.2016    27435    45    Bassgood    31    

Списание (корректировка) задолженности контрагентов УНФ 1.6

Взаиморасчеты Обработка документов Закрытие периода Платформа 1С v8.3 1С:Управление нашей фирмой Украина Бухгалтерский учет Абонемент ($m)

Обнуление задолженности контрагентов в конфигурации "Управление небольшой (нашей) фирмой" версии 1.6 с помощью документа "Корректировка регистров".

1 стартмани

24.07.2019    38777    28    DMon    1    

Регистрация документов с измененной суммой

Обработка документов Платформа 1С v8.3 Конфигурации 1cv8 Абонемент ($m)

Обработка берет информацию из истории изменения документов. Удобна для администраторов, когда документы с измененной суммой по какой-то причине не регистрируются в плане обменов. Можно регистрировать не все документы, а только те, которые были изменены.

1 стартмани

20.04.2019    31863    9    ryan    0    

Валовая прибыль для УПП 1.3, КА 1.1 в режиме РАУЗ (работа типового отчета без доработок конфигурации)

Обработка документов Платформа 1С v8.3 1С:Комплексная автоматизация 1.х 1С:Управление производственным предприятием Управленческий учет Абонемент ($m)

Простое и мгновенное решение для использования типового отчета "Валовая прибыль" в конфигурациях "Управление производственным предприятием 1.3", "Комплексная автоматизация 1.1" (а также отраслевых решений на их базе) при включенном режиме РАУЗ (расширенная аналитика учета затрат). Не требует настройки или изменения конфигурации, либо может быть, для дополнительного удобства, интегрировано в нее с минимальными доработками.

2 стартмани

21.01.2019    33757    41    stvorl    12    

Загрузка данных из Excel (из табличного документа) в часто используемые объекты: в справочники, документы, их табличные части, в планы видов расчетов, регистры расчета, регистры сведений Промо

Обработка документов Загрузка и выгрузка в Excel Обработка справочников Платформа 1С v8.3 Конфигурации 1cv8 Абонемент ($m)

Это перепиленная вдоль и поперек версия всем известной обработки "Загрузка из табличного документа" с диска ИТС. Добавлена возможность грузить в документы, виды расчетов, регистры расчета.

9 стартмани

25.06.2014    16640    33    Дмитрий74Чел    9    

Помощник корректировки остатков ЕГАИС в небольшом магазине. Розница 2.2

Розничная торговля Обработка документов Платформа 1С v8.3 1С:Розница Розничная и сетевая торговля (FMCG) Рестораны, кафе и фаст-фуд Россия Управленческий учет Абонемент ($m)

Данная обработка упрощает корректировку остатков алкогольной продукции небольшого магазина, где предполагается передача всей продукции в торговый зал сразу после приемки.

5 стартмани

08.09.2018    51041    85    asdfgcom    47    

Перенумерация документов для Бухгалтерии предприятия 3.0 Промо

Обработка документов Платформа 1С v8.3 1С:Бухгалтерия 2.0 Россия Абонемент ($m)

Автоматическая перенумерация документов.

1 стартмани

11.11.2013    42338    1190    Poyarkov696    50    

Корректировка остатков ЕГАИС, возврат из регистра 2, загрузка ТТН из файлов, другое для УТ10.3

Розничная торговля Обработка документов Платформа 1С v8.3 Оперативный учет 1С:Управление торговлей 10 Россия Бухгалтерский учет Абонемент ($m)

Набор обработок для автоматизации работы с ЕГАИС: Обработка корректировки остатков ЕГАИС для УТ 10.3, аналогичная имеющимся в УТ 11, Рознице 2.2. Автоматически формирует документы "Передача в торговый зал", "Акт постановки на баланс в торговом зале", "Акт списания в торговом зале". Обработка возврата из регистра 2 с подбором справок Б. Обработка формирования ТТН из файлов xml.

1 стартмани

24.01.2018    52457    20    biz-intel    6    

Пометка на удаление неиспользуемых элементов справочников и документов Промо

Чистка данных Обработка документов Обработка справочников Платформа 1С v8.3 Управляемые формы Конфигурации 1cv8 Абонемент ($m)

В ходе работы в программе в ней зачастую накапливается "мусор". Данная разработка может помочь убрать его... (обычные или управляемые формы)

1 стартмани

02.02.2010    47060    740    AnryMc    53    

Копирование меню в Трактир Management

Обработка документов Производство готовой продукции (работ, услуг) Платформа 1С v8.3 Конфигурации 1cv8 Рестораны, кафе и фаст-фуд Россия Управленческий учет Абонемент ($m)

Механизм копирования меню в Трактир Management. Данная обработка расширяет функционал типового решения Трактир Management, позволяя быстро вводить в эксплуатацию новую точку путём создания нового меню на основании имеющегося.

1 стартмани

28.11.2017    41687    3    integrator1983    0    

Помощник по закрытию месяца для УТ 11.3

Обработка документов Закрытие периода Платформа 1С v8.3 Оперативный учет 1С:Управление торговлей 11 Россия Управленческий учет Абонемент ($m)

Помощник по закрытию месяца для УТ 11.3. Имеет две функции: обнуление товаров "К оформлению" в интеркампани и обнуление отрицательных остатков в регистре "Себестоимость товаров".

5 стартмани

10.11.2017    37193    16    Zalipaka    1    

Упрощение работы с актами сверки в УТ/КА/УПП - вывод номеров счетов в документе и печатной форме

Обработка документов Печатные формы Взаиморасчеты Платформа 1С v8.3 1С:Комплексная автоматизация 1.х 1С:Управление торговлей 10 1С:Управление производственным предприятием Бухгалтерский учет Управленческий учет Абонемент ($m)

Обычно акт сверки с клиентами содержат информацию о документах реализации товаров (накладных) и выполненных платежах. Но платежи делаются на основании счетов, номера которых отсутствуют в актах, что затрудняет собственно сверку. Данная обработка находит соответствующие расходным накладным счета/заказы, показывает их в форме документа и выводит в печатную форму акта.

2 стартмани

12.05.2017    44604    5    denmax    7    

[Расширение] Загрузка данных из Excel в табличную часть документа с созданием не найденной номенклатуры

Обработка документов Оптовая торговля Склад и ТМЦ Загрузка и выгрузка в Excel Оперативный учет 1С:Управление торговлей 11 Россия Управленческий учет Абонемент ($m)

Расширение типовой обработки 1С "Загрузка данных из внешних файлов" (Управление торговлей ред. 11.4). Позволяет загружать данные из внешнего файла в табличную часть документа и создавать не найденную номенклатуру. Доработано: создание не сопоставленной номенклатуры по настройкам. Добавлена загрузка в документы Перемещение, Списание, Оприходование. Расширение тестировалась на демо версии Управление торговлей 11.4.9.70, 11.4.11.55, 11.4.12.61, 11.4.13.103, 11.5.7.390, 11.5.8.264

3 стартмани

09.12.2016    38133    231    shtinalex    43    

Что нам стоит Push построить

Внешние источники данных Платформа 1С v8.3 Мобильная платформа Абонемент ($m)

Попробовал некоторое время назад, push сообщения, реализованные в платформе. Понравилось, но есть несколько минусов, на примере одной программы сообщений (не буду показывать пальцем), спустя некоторое время, сообщения переставали приходить онлайн, а на компьютере приходили моментально, при этом сами смартфоны звались флагманами. Читал позднее статью, где описывалось, что проблема на стороне смартфонов, что-то вроде технологий энергосбережения, но точно не помню. Также немалый минус доступно только для смартфонов.

1 стартмани

08.09.2016    35677    18    PloAl    8    

Редактор движений документа. Сохранение в XML, обмен между базами, замена регистратора.

Обработка документов Универсальные обработки Файловые протоколы обмена (TXT, XML, DBF), FTP Платформа 1С v8.3 Абонемент ($m)

Редактор набора записей движений документа. Позволяет сохранить набор записей в XML, в настройки пользователя, прочитать сохраненный XML в другой идентичной базе, заменить регистратор. Можно изменять порядок записей, менять активность, как массово, так и по одной и др. Тонкий клиент, управляемые формы.

1 стартмани

07.09.2016    57430    176    Aphanas    5    

 Интеграция 1С и C#. Обращение к 1С через COM. Создание номенклатуры и выполнение запроса к 1С из C# на примере интеграции с Союз-PLM (система информационной поддержки жизненного цикла изделий). Обработка «Загрузка заказа на сборку». (ERP)

Загрузка и выгрузка в Excel Внешние источники данных Платформа 1С v8.3 1С:ERP Управление предприятием 2 Абонемент ($m)

Союз-PLM представляет собой полнофункциональный программный комплекс для решения  широкого спектра задач управления инженерной технической информацией наукоемких изделий и сложных инженерных объектов в области машиностроения, приборостроения, архитектуры, строительства. На практике, это управление конструкторской документацией, интегрированное с САПР, бизнес-процессы, файловый архив. Все это работает в SQL и шевелится с помощью скриптов на C#. Скрипты свободно  отлаживаются в MS Visual Studio. Подробнее смотрите на их сайте: http://www.programsoyuz.ru/products/system-soyuz-plm.html  Редактирование, конструирование и использование бизнес-процессов на порядок лучше систем на базе 1С из тех, что я изучил.

1 стартмани

25.07.2016    60196    8    milkers    2    

Загрузка Счета покупателя из PDF

Обработка документов Файловые протоколы обмена (TXT, XML, DBF), FTP Оптовая торговля Платформа 1С v8.3 Бухгалтерский учет 1С:Бухгалтерия 3.0 Абонемент ($m)

Обработка позволяет загрузить счет покупателя из pdf-файла в документ Счет на оплату покупателю (Бухгалтерия 3.0)

2 стартмани

23.05.2016    32877    34    John_d    5    

Обработка "Все одной кнопкой" (групповое создание и печать документов) для УПП ред. 1.3

Обработка документов Пакетная печать Кассовые операции Оптовая торговля Производство готовой продукции (работ, услуг) Платформа 1С v8.3 1С:Управление производственным предприятием Бухгалтерский учет Управленческий учет Абонемент ($m)

Данная обработка предназначена для группового создания, редактирования и печати основных документов («Реализация товаров и услуг», «Счет-Фактура выданный», «Счет на оплату клиентом», «Доверенность» на получение продукции, "Приходного кассового ордера") на основании документа «Заказ клиента». Основная цель обработки – оптимизация работы менеджеров при формировании пакета документов клиентам.

3 стартмани

09.04.2016    36816    36    SEOAngels    1    

Управление доставкой розничным покупателям

Обработка документов Розничная торговля Платформа 1С v8.3 1С:Управление торговлей 10 Розничная и сетевая торговля (FMCG) Россия Управленческий учет Абонемент ($m)

Дополнение для УТ 11.1, оформление доставки для розничного покупателя на основании кассового чека в связке с мягким чеком покупателя.

5 стартмани

10.03.2016    40478    8    Denis_Viktorovich    5    

Ночное восстановление последовательности документов (фоновым заданием) для БП 3.0

Обработка документов Платформа 1С v8.3 Бухгалтерский учет 1С:Бухгалтерия 3.0 Россия Абонемент ($m)

Внешняя обработка служит для восстановления последовательности документов в БП 3.0 за месяц, по расписанию, фоновым заданием на сервере 1С. Подключается как дополнительная обработка в режиме пользователя.

10 стартмани

25.02.2016    48803    101    SmArtist    8    

Перечисление НДФЛ в бюджет РФ (13%, 30%)

Обработка документов Зарплата Платформа 1С v8.3 Сложные периодические расчеты 1С:Зарплата и Управление Персоналом 2.5 Бухгалтерский учет Налоговый учет НДФЛ Абонемент ($m)

Внешняя обработка (табличных частей), предназначенная для корректного заполнения документа "Перечисление НДФЛ в бюджет РФ". Конфигурация: Зарплата и Управление Персоналом, редакция 2.5

1 стартмани

27.01.2016    48133    241    1kashak    23    

Начисление процентов по кредитам и займам для 1С:Бухгалтерии 3.0

Обработка документов Займы, кредит, лизинг Платформа 1С v8.3 1С:Бухгалтерия 2.0 Россия Бухгалтерский учет Абонемент ($m)

Универсальная обработка по начислению процентов по кредитам и займам для 1С:Бухгалтерии 3.0 без изменения конфигурации

1 стартмани

22.01.2016    80417    182    algora    27    

Пакетная замена номенклатуры с учетом характеристик

Обработка документов Оптовая торговля Склад и ТМЦ Платформа 1С v8.3 1С:Комплексная автоматизация 1.х 1С:Управление торговлей 10 1С:Управление производственным предприятием Управленческий учет Абонемент ($m)

Обработка "Пакетная замена номенклатуры" в Заказе покупателя, Реализации и Поступлении товаров с использованием отбора по значениям характеристик

1 стартмани

22.01.2016    36128    5    trendy    2    

Формирование актов сверки взаиморасчётов и групповая печать

Обработка документов Пакетная печать Взаиморасчеты Платформа 1С v8.3 1С:Бухгалтерия 2.0 Бухгалтерский учет Абонемент ($m)

Обработка позволяет сформировать новые акты сверки и распечатать за период разом на принтере

3 стартмани

15.01.2016    46914    41    gortol    4    

Перечисление НДФЛ в бюджет: заполнение НДФЛ по расчетной ведомости для ЗУП 2.5

Обработка документов Зарплата Платформа 1С v8.3 1С:Зарплата и Управление Персоналом 2.5 Россия Бухгалтерский учет НДФЛ Абонемент ($m)

Внешняя обработка для заполнению сумм НДФЛ для перечисления в бюджет по данным расчетной ведомости для 1С ЗУП 2.5

2 стартмани

30.12.2015    35281    71    pavel_pozdeev    4    

Оформление ветеринарных документов на продукты питания и грядущие глобальные изменения в 1С (часть 1)

Внешние источники данных Оптовая торговля Розничная торговля Платформа 1С v8.3 Сельское хозяйство и рыболовство Оптовая торговля, дистрибуция, логистика Пищевая промышленность Управленческий учет Абонемент ($m)

С 01 января 2016 года возможно оформление ветеринарно-сопроводительных документов в электронном виде. Что это означает для предприятий, производящих и торгующих подконтрольной продукцией?

3 стартмани

27.12.2015    68878    7    axxell    28    

Акт сверки с номерами счетов-фактур, начальными остатками по договорам и заполнением по головному контрагенту [Расширение]

Обработка документов Взаиморасчеты Платформа 1С v8.3 1С:Бухгалтерия 3.0 Россия Бухгалтерский учет Абонемент ($m)

Акт сверки взаиморасчетов (БП 3.0): - Вывод начальных и конечных остатков по договорам в печатную форму; - Вывод валютной суммы для договоров в условных единицах; - Заполнение данных счетов-фактур или УПД; - Заполнение данных по головному контрагенту и всем обособленным подразделениям; - Заполнение представителя организации из ответственных лиц; - Факсимильная подпись и печать. Не требует снятия с поддержки и подходит для базовых конфигураций

1 стартмани

15.12.2015    71937    97    mrXoxot    40    

Самый простой клиент ЕГАИС УТМ для розницы. $m

Внешние источники данных Рабочее место Розничная торговля Платформа 1С v8.3 Конфигурации 1cv8 Россия Управленческий учет Абонемент ($m)

Данная обработка позволяет обеспечить приходную часть магазина розничной торговли алкоголем(ЕГАИС розница), или прочего предприятия. Эти действия становятся обязательными для розничного звена в городских поселениях с 01.01.2016 и будут достаточными до 01.07.2016. Предлагаю Вашему вниманию простое и доступное решение, которое позволяет отсрочить проблему интеграции ЕГАИС в розничное звено до указанной даты. (открытый код). Реализовано на открытой модели http://infostart.ru/public/402052/.

2 стартмани

14.12.2015    45648    8    Terrain25    47