[ШАБЛОН] Внешняя печатная форма с отладкой

Публикация № 1729824 20.09.22

Бухгалтерский учет - Печатные формы

Печать ПФ ВнешняяПФ Обработка Шаблон Печатная форма Внешняя печатная отладка

Шаблон внешней печатной формы с отладкой. Поможет быстро создавать печатные формы, необходимо лишь изменять ключевые параметры, макет и заполнение Табличного документа.

Внешняя печатная форма прикрепляется к базе как дополнительная обработка через "Дополнительные отчеты и обработки". Для отладки все выведено на форму. 

Все тесты производились на платформе 8.3.20.1914, однако код отработает на любой из 8.2, 8.3. База КА 2.4.

 

Текст модуля объекта

Функция СведенияОВнешнейОбработке() Экспорт
	
	оМетаданные = Метаданные();
	
	ПараметрыРегистрации = ДополнительныеОтчетыИОбработки.СведенияОВнешнейОбработке();
	ПараметрыРегистрации.Вид = ДополнительныеОтчетыИОбработкиКлиентСервер.ВидОбработкиПечатнаяФорма();
	ПараметрыРегистрации.Наименование = оМетаданные.Синоним;
    ПараметрыРегистрации.Версия = оМетаданные.Комментарий;
    ПараметрыРегистрации.БезопасныйРежим = Ложь;
    ПараметрыРегистрации.Информация = оМетаданные.Синоним; 
		
	Назначение = Новый Массив;
	Назначение.Добавить("Документ.ЗаказКлиента");
	ПараметрыРегистрации.Вставить("Назначение", Назначение); 
	
	НоваяКоманда = ПараметрыРегистрации.Команды.Добавить();
	НоваяКоманда.Представление = оМетаданные.Синоним;
	НоваяКоманда.Идентификатор = оМетаданные.Имя;
	НоваяКоманда.Использование = ДополнительныеОтчетыИОбработкиКлиентСервер.ТипКомандыВызовСерверногоМетода();

    Возврат ПараметрыРегистрации;
		
КонецФункции

Процедура Печать(МассивОбъектов, КоллекцияПечатныхФорм, ОбъектыПечати, ПараметрыВывода) Экспорт
	
	Если УправлениеПечатью.НужноПечататьМакет(КоллекцияПечатныхФорм, "ВнешняяПечатнаяФормаСОтладкой") Тогда
		
		УправлениеПечатью.ВывестиТабличныйДокументВКоллекцию(
				КоллекцияПечатныхФорм,
				"ВнешняяПФ",
				НСтр("ru='Внешняя ПФ'"),
				СформироватьПечатнуюФорму(МассивОбъектов, ОбъектыПечати, Неопределено));
		
		ФормированиеПечатныхФорм.ЗаполнитьПараметрыОтправки(ПараметрыВывода.ПараметрыОтправки, МассивОбъектов, КоллекцияПечатныхФорм);  
	КонецЕсли;
	
КонецПроцедуры    

Функция СформироватьПечатнуюФорму(МассивОбъектов, ОбъектыПечати, ПараметрыПечати) Экспорт
	
	ТабличныйДокумент = Новый ТабличныйДокумент;
	ТабличныйДокумент.ОтображатьСетку = Ложь;  
	ТабличныйДокумент.ОтображатьЗаголовки = Ложь;
	ТабличныйДокумент.АвтоМасштаб = Истина;
	ТабличныйДокумент.ИмяПараметровПечати = "ПАРАМЕТРЫ_ПЕЧАТИ_ВНЕШНЯЯ_ПФ";      
	
	Макет = ПолучитьМакет("Макет");
	
	ЭтоПервыйДокумент = Истина;
	
	УстановитьПривилегированныйРежим(Истина); 
		
	Для Каждого ЗаказКлиента Из МассивОбъектов Цикл     
				
		Если ЭтоПервыйДокумент Тогда   
			ЭтоПервыйДокумент = Ложь;
		Иначе
			ТабличныйДокумент.ВывестиГоризонтальныйРазделительСтраниц();
		КонецЕсли; 
		
		// ШАПКА
		ОбластьМакета = Макет.ПолучитьОбласть("Шапка");		
		ТабличныйДокумент.Вывести(ОбластьМакета); 
				
		// Заполнение табличного документа   
		Итого = 0; 
		Валюта = ЗаказКлиента.Валюта;
		
		// ПОДВАЛ
		ОбластьПодвал = Макет.ПолучитьОбласть("Подвал");
		
		ОбластьПодвал.Параметры.Итого = Итого;        		
		ОбластьПодвал.Параметры.ИтоговаяСтоимостьЧисло = "" + Итого + " " + Валюта;
		ОбластьПодвал.Параметры.ИтоговаяСтоимостьТекст = "(" + ЧислоПрописью(Итого, "Л=ru_RU; ДП=Истина", "рубль,рубля,рублей,м,копейка,копейки,копеек,ж,2") + ")";

		// Получение данных ответсвенных лиц из ДО по связанному документу.
		ПодписантОрганизация = "";
		ПодписантКонтрагент = "";
		ДолжностьПодписантОрганизация = "";
		ДолжностьПодписантКонтрагент = "";
		
		Результат = ИнтеграцияС1СДокументооборотВызовСервера.ДанныеОбъектаДОПоВнешнемуОбъекту(ЗаказКлиента);
		
		Если Результат <> Неопределено Тогда // найден
			Прокси = ИнтеграцияС1СДокументооборотПовтИсп.ПолучитьПрокси();   
			ОбъектXDTO = ИнтеграцияС1СДокументооборот.ПолучитьОбъект(Прокси, Результат.type, Результат.ID);
			Если ОбъектXDTO.objects.Количество() > 0 И ОбъектXDTO.objects[0].partyRows.rows.Количество() > 0 
				И ОбъектXDTO.objects[0].partyRows.rows[0].signedBy <> Неопределено Тогда
				ПодписантОрганизация = ОбъектXDTO.objects[0].partyRows.rows[0].signedBy.name;
			КонецЕсли;
			Если ОбъектXDTO.objects.Количество() > 0 И ОбъектXDTO.objects[0].partyRows.rows.Количество() > 1 
				И ОбъектXDTO.objects[0].partyRows.rows[1].signedBy <> Неопределено Тогда
				ПодписантКонтрагент = ОбъектXDTO.objects[0].partyRows.rows[1].signedBy.name;
				ФИОПодписант = СтрРазделить(ПодписантКонтрагент, " ", Истина);
				Если ФИОПодписант.Количество() = 3 Тогда
					ПодписантКонтрагент = ФИОПодписант[0] + " " + Лев(ФИОПодписант[1], 1) + ". " + Лев(ФИОПодписант[2], 1) + ".";
				КонецЕсли;
				ПодписантXDTO = ИнтеграцияС1СДокументооборот.ПолучитьОбъект(Прокси, ОбъектXDTO.objects[0].partyRows.rows[1].signedBy.objectID.type, ОбъектXDTO.objects[0].partyRows.rows[1].signedBy.objectID.ID);
				Если ПодписантXDTO.objects.Количество() > 0 Тогда
					ДолжностьПодписантКонтрагент = ПодписантXDTO.objects[0].position;
				КонецЕсли;
			КонецЕсли;
		КонецЕсли;   
		
		Если ЗначениеЗаполнено(ПодписантОрганизация) Тогда
			
			Запрос = Новый Запрос;
			Запрос.Текст = 
				"ВЫБРАТЬ
				|	ОтветственныеЛицаОрганизаций.ФизическоеЛицо КАК ФизическоеЛицо,
				|	ОтветственныеЛицаОрганизаций.Должность КАК Должность
				|ИЗ
				|	Справочник.ОтветственныеЛицаОрганизаций КАК ОтветственныеЛицаОрганизаций
				|ГДЕ
				|	ОтветственныеЛицаОрганизаций.ОтветственноеЛицо = ЗНАЧЕНИЕ(Перечисление.ОтветственныеЛицаОрганизаций.Руководитель)
				|	И ОтветственныеЛицаОрганизаций.Владелец = &Владелец
				|	И ОтветственныеЛицаОрганизаций.ДатаНачала <= &Дата
				|	И (ОтветственныеЛицаОрганизаций.ДатаОкончания >= &Дата
				|			ИЛИ ОтветственныеЛицаОрганизаций.ДатаОкончания = ДАТАВРЕМЯ(1, 1, 1))
				|	И ОтветственныеЛицаОрганизаций.ФизическоеЛицо.Наименование = &Наименование";  
			
			Запрос.УстановитьПараметр("Владелец", ЗаказКлиента.Организация);
			Запрос.УстановитьПараметр("Дата", ЗаказКлиента.Дата);
			Запрос.УстановитьПараметр("Наименование", ПодписантОрганизация); 
			
			Выборка = Запрос.Выполнить().Выбрать(); 
			Если Выборка.Следующий() Тогда
				ПодписантОрганизация = ФизическиеЛицаУТ.ФамилияИнициалыФизЛица(Выборка.ФизическоеЛицо, ЗаказКлиента.Дата);
				ДолжностьПодписантОрганизация = Выборка.Должность;
			КонецЕсли; 
			
		Иначе                                                        			
			ОтвЛ = ОтветственныеЛицаБП.ОтветственныеЛица(ЗаказКлиента.Организация, ЗаказКлиента.Дата);
			ПодписантОрганизация = ОтвЛ.РуководительПредставление;
			ДолжностьПодписантОрганизация = ОтвЛ.РуководительДолжностьПредставление;   		
		КонецЕсли;
		
		ОбластьПодвал.Параметры.Организация = ЗаказКлиента.Организация.НаименованиеСокращенное;
		ОбластьПодвал.Параметры.Контрагент = ЗаказКлиента.Контрагент.НаименованиеПолное;
		ОбластьПодвал.Параметры.ДолжностьПодписантОрганизация = ?(ЗначениеЗаполнено(ДолжностьПодписантОрганизация), ДолжностьПодписантОрганизация, "Представитель");
		ОбластьПодвал.Параметры.ДолжностьПодписантКонтрагент = ?(ЗначениеЗаполнено(ДолжностьПодписантКонтрагент), ДолжностьПодписантКонтрагент, "Представитель");
		ОбластьПодвал.Параметры.ПодписантОрганизация = ПодписантОрганизация;
		ОбластьПодвал.Параметры.ПодписантКонтрагент = ПодписантКонтрагент; 
		
		// Окрасим незаполненные поля
		Если НЕ ЗначениеЗаполнено(ДолжностьПодписантКонтрагент) Тогда
			ОбластьПодвал.Область(6,3,6,4).ЦветФона = ЦветаСтиля.ПолеСОшибкойФон;
		КонецЕсли;  
		
		ТабличныйДокумент.Вывести(ОбластьПодвал);
		
	КонецЦикла;
	
	УстановитьПривилегированныйРежим(Ложь);
	

	Возврат ТабличныйДокумент;

КонецФункции    

 

Текст формы

 

&НаСервере
Функция ВыполнитьПечатьНаСервере()
	
	ОбработкаОбъект = РеквизитФормыВЗначение("Объект");
	МассивОбъектов = Новый Массив;
	МассивОбъектов.Добавить(Объект.ивЗаказ);  	
	
	ОбъектыПечати = Новый СписокЗначений;
	ОбъектыПечати.Добавить(Объект.ивЗаказ);
	
	ТабличныйДокумент = ОбработкаОбъект.СформироватьПечатнуюФорму(МассивОбъектов, ОбъектыПечати, Неопределено);
	
	Возврат ТабличныйДокумент;	
	
КонецФункции

&НаКлиенте
Процедура ВыполнитьПечать(Команда)
	
	ВыполнитьПечатьНаСервере().Показать(); 
	
КонецПроцедуры

Данный шаблон внешней печатной формы был добавлен для ускорения поиска нужного кода и разработки.

Статья будет дорабатываться, будет добавлен полезный функционал, используемый в ПФ. 

Другие статьи:

[Шаблон] загрузки данных из Excel

Поиск пользователей в базах через COM-Объект

Скачать файлы

Наименование Файл Версия Размер
[ШАБЛОН] Внешняя печатная форма с отладкой.:

.epf 10,86Kb
2
.epf 0.0.1 10,86Kb 2 Скачать

Специальные предложения

Оставьте свое сообщение

См. также

[ШАБЛОН] Выгрузка / Загрузка данных из Excel

Загрузка и выгрузка в Excel Платформа 1С v8.3 Конфигурации 1cv8 Абонемент ($m)

Шаблон обработки по выгрузке / загрузке данных из Excel. Обработка может быть полезна как матерым программистам, так и новичкам. Первые не будут писать код заново, а вторые получают шаблон, с которым можно начинать разбираться с выгрузкой и загрузкой из Excel. Основная задача данного шаблона - сократить время на поиск и написание кода по выгрузке / загрузке данных.

1 стартмани

19.09.2022    664    1    Neiron_1C    0    

Параметризация печатных форм под контрагентов (подключаемое расширение)

Печатные формы Адаптация типовых решений Платформа 1С v8.3 Конфигурации 1cv8 Абонемент ($m)

Расширение добавляет возможности параметризации печати для контрагентов. Подробнее описано здесь https://infostart.ru/1c/articles/1510459/

10 стартмани

05.08.2022    4201    4    sapervodichka    4    

Печать любой печатной формы, зарегистрированной с помощью БСП, для любой конфигурации

Обработка документов Печатные формы БСП (Библиотека стандартных подсистем) Платформа 1С v8.3 Конфигурации 1cv8 Россия Абонемент ($m)

Добрый день. Не так давно мне была поставлена задача сделать обработку, позволяющую для выбранного объекта конфигурации показывать список печатных форм этого объекта и выводить выбранную форму на печать. Пришлось немного поразбираться с БСП, но в итоге получилось. Работает для любой конфигурации. Одно условие только - печатная форма должна быть зарегистрирована с помощью БСП.

1 стартмани

27.07.2022    1054    1    Alex33614    0    

Конструктор печатных форм для ЗУП 3.1 по шаблонам MSOffice и OpenOffice Промо

Печатные формы Документооборот и делопроизводство Платформа 1С v8.3 Сложные периодические расчеты 1С:Зарплата и Управление Персоналом 3.x Абонемент ($m)

Данная обработка позволяет быстро создавать печатные формы документов на основании документов из программы 1С ЗУП8 версии 3.1. Печатные формы можно заполнять на основании следующих документов: "Прием на работу", "Прием на работу списком", "Кадровый перевод", "Кадровый перевод списком", "Перемещение в другое подразделение", "Договор ГПХ" Обработка протестирована на платформе 1С:Предприятие 8.3 (8.3.12.1714) релиз ЗУП 3.1.9.187 Тонкий клиент (файловый или клиент-сервер) Установленный Microsoft office (2003 и выше) или OpenOffice/LibreOffice 09/04/2019 Исправил ошибку, возникающую, если наименование вида расчета содержит скобки.

10 стартмани

02.11.2017    34908    309    zabaluev    62    

Пример внешней печатной формы, с выводом в документ docx

Печатные формы Инструментарий разработчика Платформа 1С v8.3 Конфигурации 1cv8 Абонемент ($m)

На основе обработки _ДемоПечатьСписанийТоваровOpenOfficeXML.epf (взята из БСП 3.1.7.110) сделал пример формирования печатной формы. Печатная форма выводится в документ с расширением docx. Шаблон документа в макете обработки.

1 стартмани

19.07.2022    1010    8    План счетов    6    

Шаблон внешней печатной формы Word

Печатные формы Инструментарий разработчика Платформа 1С v8.3 Конфигурации 1cv8 Абонемент ($m)

Шаблон внешней печатной формы в формате Word для минимизации времени разработки. Для любой конфигурации, без использования БСП.

1 стартмани

18.07.2022    861    10    irvin12345    0    

Универсальный шаблон печатных форм для справочника Сотрудники

Печатные формы Платформа 1С v8.3 1С:ERP Управление предприятием 2 1С:Комплексная автоматизация 2.х 1С:Зарплата и Управление Персоналом 3.x Кадровые агентства, подбор персонала Россия Абонемент ($m)

Шаблон печатной формы, вызываемой из команды Печать справочника Сотрудники. Используется в качестве заготовки для кадровых документов: договоров, соглашений, уведомлений, предписаний, служебных записок и пр.

1 стартмани

08.06.2022    1035    6    ivan8211    0    

Отправка пакета документов по электронной почте (в формате PDF/XLS/HTML/MXL/ODS) Промо

Печатные формы Пакетная печать Email рассылки Оптовая торговля Платформа 1С v8.3 1С:Бухгалтерия 2.0 1С:Комплексная автоматизация 1.х 1С:Управление производственным предприятием 1С:Управление торговлей 10 Россия Бухгалтерский учет Абонемент ($m)

С помощью обработки можно нажатием одной кнопки отправить пакет документов контрагенту по электронной почте. Теперь не надо заходить в каждый документ, формировать нужную печатную форму, сохранять на диск, а потом собирать в одном письме. Все это за вас сделает программа самостоятельно. Все, что требуется от пользователя - просто выбрать документ в программе! Доступны варианты обработки для обычного и управляемого приложения!

2 стартмани

22.04.2015    64966    54    trendy    25    

Обезжиривание шрифта в печатной форме (экономим тонер)

Печатные формы Адаптация типовых решений Платформа 1С v8.3 1С:Бухгалтерия 3.0 Абонемент ($m)

Код, который убирает полужирное начертание у шрифтов в печатной форме. Тестировалось на конфигурации Бухгалтерия Предприятия 3.0.111.16. Но должно работать на любых конфигурациях с БСП.

1 стартмани

24.05.2022    1314    1    q_i    4    

Присоединение внешней печатной формы в виде файла к объекту-основанию

Печатные формы Адаптация типовых решений Платформа 1С v8.3 Конфигурации 1cv8 Абонемент ($m)

В данной публикации речь пойдёт о том, как можно присоединить сформированную внешнюю печатную форму в виде файла к тому объекту (справочнику, документу и т.п.), на основании которого она была сформирована.

1 стартмани

20.05.2022    1796    1    delta    0    

Шаблон для быстрого создания подключаемой печатной формы договоров для конфигурации Бухгалтерия 3.0. Упакован в комплект поставки для 1cfresh (пройдена проверка)

Печатные формы Платформа 1С v8.3 1С:Бухгалтерия 3.0 Абонемент ($m)

Готовый шаблон подключаемой печатной формы для максимально быстрого создания печатной формы договоров для конфигурации Бухгалтерия 3.0. Будет полезно для программистов 1С и опытных пользователей(системных администраторов и бухгалтеров), обладающих минимальными навыками програмирования 1С. С помощью материалов из данной публикации можно максимально быстро создать и подключить к вашей базе Бухгалтерия 3.0 индивидуальную печатную форму договора, сосредоточившись на самом важном для Вас - заполнении текста самого договора. Предложенное решение предоставляет более широкие возможности по созданию печатной формы договора, чем использованием стандартного механизма встроенных шаблонов печатных форм БСП, поскольку позволяет использовать язык программирования 1С для подготовки текста Вашего документа.

2 стартмани

02.02.2022    2144    5    igor7777    6    

Мастер печатных форм v 3.3 (+English version) Промо

Печатные формы Платформа 1С v8.3 Управляемые формы Система компоновки данных Конфигурации 1cv8 Абонемент ($m)

Создание печатных форм "с нуля" за несколько минут. Моментальная отладка. Не требует знания встроенного языка 1С. Работает в толстом, тонком и вэб-клиентах.

1 стартмани

07.03.2014    103639    1252    kser87    239    

Печать документа из структуры подчиненности

Печатные формы Платформа 1С v8.3 1С:Розница 1С:Управление торговлей 11 Россия Управленческий учет Абонемент ($m)

В структуру подчиненности документа добавляет кнопки "Печать", "Провести", "Распровести", "Пометить на удаление". В теории работает в любой конфигурации на управляемых формах. Расширение.

1 стартмани

07.01.2022    2344    2    dgonson    0    

Смена МОЛ в учете инвентаря на счете МЦ.04

Склад и ТМЦ Печатные формы Платформа 1С v8.3 Бухгалтерский учет 1С:Бухгалтерия 3.0 Бухгалтерский учет Абонемент ($m)

Обработка для смены материально ответственных лиц и подразделений в учете инвентаря (хозяйственных принадлежностей) в 1С:Бухгалтерии 8.

1 стартмани

14.12.2021    2863    56    Rackhanot    12    

ТОРГ-12 из документа Заказ покупателя. Розница 2.3

Печатные формы Оптовая торговля Платформа 1С v8.3 1С:Розница Россия Абонемент ($m)

Расширение, использующее стандартный макет ТОРГ-12 для печати из документа "Заказ покупателя".

1 стартмани

14.12.2021    1798    2    altaro    0    

Отправка электронной почты с помощью локального почтового клиента из 1С, развернутой под удаленным рабочим столом Промо

Печатные формы Универсальные функции Email рассылки Платформа 1С v8.3 1С:Комплексная автоматизация 1.х 1С:Бухгалтерия 2.0 1С:Управление торговлей 10 1С:Управление производственным предприятием Абонемент ($m)

Решение для интерактивной (нажал-отредактировал) отправки электронных писем и печатных форм через почтовый клиент (Thunderbird, Outlook) находящийся на локальном компьютере, из конфигурации 1С, развернутой под удаленным рабочим столом (RDP, remote-app). Подходит также для локального развертывания 1С. Представлен пример быстрой интеграции с конфигурациями "Управление торговлей 10.3", "Управление производственным предприятием 1.3", "Комплексная автоматизация 1.1", "Бухгалтерия предприятия 2.0".

1 стартмани

21.09.2018    36209    24    stvorl    1    

Исправление данных количества отработанных дней в печатной форме "Карточка учета исполнительного документа с оплатами"

Зарплата Печатные формы Платформа 1С v8.3 Сложные периодические расчеты 1С:Зарплата и Управление Персоналом 3.x Бухгалтерский учет Абонемент ($m)

Печатная форма «Карточка учета исполнительного документа с оплатами» документа Исполнительный лист Колонка «Отработано дней» в случае увольнения сотрудника в середине месяца заполняется как за полный месяц.

2 стартмани

26.11.2021    2929    1    RizhkovSergio    0    

Печать этикеток и ценников по изменившимся ценам за период для УТ 11

Печатные формы Платформа 1С v8.3 Оперативный учет 1С:Управление торговлей 11 Россия Управленческий учет Абонемент ($m)

С помощью этого расширения вы сможете отобрать и напечатать ценники только на те товары, цены которых изменились за указанный период, или в выбранных документах установки цен.

6 стартмани

09.09.2021    3112    4    tiniji    0    

Печать кода маркировки при приемке товаров для УТ11.4 и для Розницы 2.3

Пакетная печать Печатные формы Склад и ТМЦ Платформа 1С v8.3 1С:Розница 1С:Управление торговлей 11 Россия Управленческий учет Абонемент ($m)

Расширение позволяет напечатать марки из формы проверки маркируемой продукции в документе "Приобретение товаров и услуг" или "Приемка товаров ИС МП" в УТ 11 И из документа "Поступление товаров" в Рознице.

2 стартмани

01.09.2021    3417    15    tiniji    4    

Упрощение работы с актами сверки в УТ/КА/УПП - вывод номеров счетов в документе и печатной форме Промо

Обработка документов Печатные формы Взаиморасчеты Платформа 1С v8.3 1С:Комплексная автоматизация 1.х 1С:Управление торговлей 10 1С:Управление производственным предприятием Бухгалтерский учет Управленческий учет Абонемент ($m)

Обычно акт сверки с клиентами содержат информацию о документах реализации товаров (накладных) и выполненных платежах. Но платежи делаются на основании счетов, номера которых отсутствуют в актах, что затрудняет собственно сверку. Данная обработка находит соответствующие расходным накладным счета/заказы, показывает их в форме документа и выводит в печатную форму акта.

2 стартмани

12.05.2017    44643    5    denmax    7    

Алгоритм вывода подписантов из дополнительных сведений во внешнюю печатную форму акта ОС-1

Обработка документов Печатные формы Учет ОС и НМА Платформа 1С v8.3 1С:ERP Управление предприятием 2 1С:Комплексная автоматизация 2.х Россия Бухгалтерский учет Абонемент ($m)

В стандартной печатной форме "Акта ОС-1" нет возможности вывести подписантов, т.к. в документе "Принятие к учету ОС" нет полей для заполнения председателя и членов комиссии.

1 стартмани

16.08.2021    5574    4    SergAl    30    

"Палитра быстрой печати" ценников/этикеток товаров и создания документов поступлений для Розницы

Розничная торговля Обработка документов Печатные формы Платформа 1С v8.3 1С:Розница Розничная и сетевая торговля (FMCG) Россия Управленческий учет Абонемент ($m)

Предлагается расширение для конфигурации 1С:Розница, позволяющее быстро печатать ценники/этикетки товаров и создавать документы поступления через "Палитру быстрой печати" с возможностью работы из меню РМК.

10 стартмани

05.08.2021    3630    1    aximo    0    

Драйвер весов с печатью этикеток Масса-К

Весы Печатные формы Платформа 1С v8.3 1С:Управление торговлей 10 1С:Розница Розничная и сетевая торговля (FMCG) Абонемент ($m)

Обработка обслуживания весов с печатью этикеток Масса-К для УТ 10.3 и Розницы 1.0. Выгрузка осуществляется штатными средствами конфигураций.

5 стартмани

21.07.2021    3626    3    Bujum    1    

[x1c.ru] MXL Stamps - Печати и подписи в макетах печатных форм в несколько кликов Промо

Печатные формы Универсальные обработки Платформа 1С v8.3 Конфигурации 1cv8 Абонемент ($m)

Обработка позволяет быстро создавать поля текста из ячеек печатных форм и добавлять "под них" подписи и печати. Работает в конфигурациях на управляемых формах.

1 стартмани

22.08.2015    43305    18    GusevNA    6    

Групповая печать ПКО и РКО за период (БП 3.0)

Пакетная печать Печатные формы Кассовые операции Платформа 1С v8.3 Бухгалтерский учет Управляемые формы 1С:Бухгалтерия 3.0 Бухгалтерский учет Абонемент ($m)

Групповая печать кассовых ордеров (ПКО и РКО) за любой период. Для Бухгалтерии предприятия 3.0.

1 стартмани

13.07.2021    4753    12    Ant10    0    

Печать этикеток и ценников из УТ 10.3 на обычные и термопринтеры Argox и Godex

Периферийные устройства Печатные формы Платформа 1С v8.3 1С:Управление торговлей 10 Абонемент ($m)

Удобная и быстрая печать ценников и этикеток из 1С:Управление торговлей (УТ) 10.3 на обычных принтерах и на термопринтерах Argox OS-203 DT, OS-2130D и Godex BZB2/EZ2/EZ4, Citizen CLP-521/621.

2 стартмани

12.07.2021    5445    17    w0r0n    10    

Печать непроведенных документов для конфигураций УТ, КА, ERP

Оптовая торговля Печатные формы Платформа 1С v8.3 1С:ERP Управление предприятием 2 1С:Управление торговлей 11 1С:Комплексная автоматизация 2.х Россия Управленческий учет Абонемент ($m)

Некоторым пользователям бывает очень необходимо (причины не известны :) ), напечатать непроведенный документ. Данное расширение позволяет формировать печатные формы без проведения документа.

3 стартмани

01.07.2021    3720    25    prime9    5    

Печать и подпись на счете. Авто отправка по электронной почте для Бухгалтерии и УТ Промо

Печатные формы Оптовая торговля Email рассылки Платформа 1С v8.3 1С:Бухгалтерия 2.0 1С:Управление торговлей 10 Россия Абонемент ($m)

Подключаемая внешняя обработка позволяет формировать и отправлять счет с цветными печатью и подписями на электронную почту клиента

1 стартмани

10.04.2012    56892    1451    PiterPen    92    

Сохранение печатной формы в файл для нескольких документов с заданным именем файла

Печатные формы Загрузка и выгрузка в Excel Платформа 1С v8.3 Бухгалтерский учет 1С:Бухгалтерия 3.0 Бухгалтерский учет Абонемент ($m)

С завидной регулярностью бухгалтерия обращается с задачей сделать им групповую обработку в разных базах по сохранению печатной формы различных документов в формате PDF и/или XLS.

1 стартмани

22.05.2021    4439    18    SerGeoSik    3    

Внешняя компонента печати этикеток для 4 моделей принтеров Промо

Розничная торговля Разработка внешних компонент Периферийные устройства Печатные формы Платформа 1С v8.3 Россия Абонемент ($m)

COM-сервер (внешняя компонента) позволяет печатать этикетки на 4-е модели принтеров (+совместимые с ними по языку управления) 1) Godex EZ-2, Godex BZB-2 2) Godex EZ-2P, Godex DT-2 3) Zebra LP 2824 4) Argox OS-203DT

1 стартмани

15.08.2012    45850    109    ImageWriter    5    

Реализация штрих-кода ЕАН13+5 (со сроком годности)

Розничная торговля Печатные формы Платформа 1С v8.3 Конфигурации 1cv8 Розничная и сетевая торговля (FMCG) Управленческий учет Абонемент ($m)

Реализует Штрих-Код ЕАН 13+5. Сети, типа Ленты, требуют на липках товара указывать срок годности товара, чтобы кассирша, пикая сканером покупку, не смогла продать просроченный товар. Пример реализует это.

4 стартмани

20.04.2021    3882    2    apostolis    0    

Возвращаем "нормальную" печать линейных штрихкодов в Рознице

Розничная торговля Печатные формы Платформа 1С v8.3 1С:Розница Абонемент ($m)

Расширение возвращает использование старой компоненты для печати линейных штрихкодов, что улучшает их читаемость сканерами и устраняет "смазывание" при печати на некоторых принтерах.

3 стартмани

01.04.2021    4127    4    denmax    4    

Вывод кода и артикула в печатную форму документа "Заказ поставщику". 1С: УТ 11.4

Печатные формы Оптовая торговля Платформа 1С v8.3 Оперативный учет 1С:Управление торговлей 11 Управленческий учет Абонемент ($m)

В типовом УТ 11 в печатные формы документов (в частности, "Заказ поставщику"), можно выводить в дополнительной колонке только код или артикул номенклатуры. Но иногда возникает необходимость выводить код и артикул одновременно. Данное расширение позволяет добавить этот функционал, не затрагивая код конфигурации.

1 стартмани

01.04.2021    6473    11    Stæg    11    

Генератор Штрих-кода EAN 13 на основе шрифта EanGnivc.ttf Промо

Универсальные функции Розничная торговля Склад и ТМЦ Печатные формы Платформа 1С v8.3 Конфигурации 1cv8 Абонемент ($m)

Печать Штрих-кодов на основе Шрифта. Дает преимущества: 1) Быстрая печать - особенно заметно на принтерах штрих-кодов. 2) Идеально пропечатанный штрих-код - в отличие от печати картинок, дающих различные искажения (гребенка и т.д....). Единственный минус - регистрация шрифта))

2 стартмани

06.11.2012    58019    258    sanfoto    25    

Адаптация макета акта сверки из Бухгалтерии 3 Корп для сверки взаиморасчетов в Комплексной автоматизации 2.4

Печатные формы Взаиморасчеты Платформа 1С v8.3 1С:Комплексная автоматизация 2.х Россия Бухгалтерский учет Управленческий учет Абонемент ($m)

Поступила задача привести внешний вид печатной формы Сверки взаиморасчетов в комплексной автоматизации 2.4 под вид акта сверки из Бухгалтерии 3. Поиски решений задачи на просторах интернета не дали своих плодов.

1 стартмани

23.03.2021    4118    5    Rabin    0    

Печать этикетки с штрихкодом и кодом маркировки для 1С:Розница 2.3

Розничная торговля Печатные формы Платформа 1С v8.3 1С:Розница Абонемент ($m)

Обработка позволяет распечатать этикетки из документа Заказ на эмиссию кодов маркировки СУЗ. Выводится наименование, артикул товара, характеристика, также некоторые значения дополнительных характеристик (Цвет, Состав). Выводится ШК товара и маркировочный ШК. Размер 45*30мм.

1 стартмани

23.03.2021    3652    11    XuMbI4    0    

Печать ценников и этикеток с двумя видами цен посредством типового механизма в Рознице 2.3

Печатные формы Платформа 1С v8.3 1С:Розница Управленческий учет Абонемент ($m)

Элементарный, легкий, типовой и дешевый способ получить этикетку с 2мя видами цен. Тестировался и разрабатывался в релизе Розница 2.3.5.32.

1 стартмани

15.02.2021    6569    89    Dmitry888    14    

Печать и подпись на счете. Отправляем на электронную почту для УТ 11. Бета-версия Промо

Печатные формы СRM Email рассылки Платформа 1С v8.3 1С:Управление торговлей 10 Россия Бухгалтерский учет Управленческий учет Абонемент ($m)

Программа для отправки счета, со вставленными печатью и подписями должностных лиц на почту клиента для УТ 11

1 стартмани

07.03.2013    33198    128    PiterPen    20    

Печать этикеток с кодом DataMatrix для честного знака

Розничная торговля Печатные формы Платформа 1С v8.3 1С:Управление торговлей 11 Россия Управленческий учет Абонемент ($m)

Печать кода маркировки DataMatrix для этикетки из текста для честного знака. Зачастую поставщики/импортеры продукции присылают коды маркировки в файле, и требуется их повторная распечатка.

1 стартмани

11.02.2021    6234    34    anvile    15    

Формирование файла выгрузки весовых товаров в весы CAS CL-5000 с печатью этикеток

Весы Печатные формы Платформа 1С v8.3 1С:Управление нашей фирмой Розничная и сетевая торговля (FMCG) Россия Управленческий учет Абонемент ($m)

Данная обработка позволяет автоматически формировать файл выгрузки весовых товаров в весы с печатью этикеток CAS CL-5000 из УНФ 1.6.

5 стартмани

09.02.2021    4420    2    aximo    2    

Универсальная печатная форма для справочника и документа по своему шаблону, сделанному в ms word: Кадровые, Торговые, Делопроизводственные, Бухгалтерские, Управляющие

Печатные формы Платформа 1С v8.3 Конфигурации 1cv8 1С:Розница 1С:Управление нашей фирмой 1С:ERP Управление предприятием 2 1С:Бухгалтерия 3.0 1С:Управление торговлей 11 1С:Комплексная автоматизация 2.х 1С:Зарплата и Управление Персоналом 3.x Россия Абонемент ($m)

Создавайте дополнительные печатные формы для печати из 1С по своему усмотрению без помощи программиста. Например можно прямо из справочника Физические лица или Сотрудники - напечатать не стандартный документ, например карточку Физического лица по своим полям, прикрепить к нему свой специфичный договор или какую-нибудь расписку. Трудовой договор прямо из списка сотрудников и ещё много свободных бланков. Из контрагента - специально оформленный по вашему требованию договор в который подставятся нужные данные из базы 1С.

5 стартмани

02.02.2021    8876    117    strelvan    11    

Сохранение и передача документов по E-mail. Счет, Акт, ТОРГ-12, Счет-Фактура 1137, Акт сверки. XLS, PDF, MXL, HTM Бухгалтерия 2.0 (КОРП) Промо

Печатные формы Email рассылки Платформа 1С v8.3 1С:Бухгалтерия 2.0 Россия Абонемент ($m)

Обработка позволяет выбирать документы за период (Счет, Реализация товаров и услуг, Счет Фактура), добавлять печати, подписи, логотип (только в счет), сохранять документы в различных форматах (XLS, PDF, MXL, HTM) и отправлять по электронной почте. Существует отбор по контрагентам.

1 стартмани

03.09.2012    24986    261    gsmirnov    13    

Печать этикеток для УТ 10.3 (x64)

Печатные формы Платформа 1С v8.3 1С:Управление торговлей 10 Россия Абонемент ($m)

Внешняя обработка для печати этикеток для конфигурации УТ 10.3 на 64 битном клиенте (Windows 7, Windows 10).

1 стартмани

04.12.2020    6350    20    MaximKor    2    

1С+OZON - маркировка (печать этикеток)

Розничная торговля Печатные формы Платформа 1С v8.3 1С:CRM ПРОФ, КОРП Россия Абонемент ($m)

Обработка получает PDF-файл с маркировкой (этикеткой озон) для указанного направления - POST /v2/posting/fbs/package-label

4 стартмани

04.12.2020    7802    25    aleksey.kubovtsov    18    

Печать ценников со штрихкодом и двумя ценами (Розница 2.2-2.3)

Розничная торговля Ценообразование, анализ цен Печатные формы Платформа 1С v8.3 1С:Розница Россия Бухгалтерский учет Управленческий учет Абонемент ($m)

Внешняя обработка позволяет печатать ценники со штрихкодом и двумя ценами (Розница 2.2-2.3).

2 стартмани

27.11.2020    3990    16    Spektr    0    

Счет на оплату покупателю + отправка по электронной почте Промо

Печатные формы Email рассылки Оптовая торговля Производство готовой продукции (работ, услуг) Платформа 1С v8.3 Бухгалтерский учет 1С:Бухгалтерия 2.0 Россия Бухгалтерский учет Абонемент ($m)

Внешняя печатная форма для документа "Счет на оплату покупателю". Отправляет по электронной почте сформированный файл печатной формы в формате *.xls.

1 стартмани

13.11.2012    31863    131    siranush    9    

Формирование и отправка актов сверок. УНФ 1.6

Печатные формы Взаиморасчеты Email рассылки Платформа 1С v8.3 1С:Управление нашей фирмой Россия Бухгалтерский учет Управленческий учет Абонемент ($m)

Обработка предназначена для автоматического формирования и рассылки актов сверки в УНФ 1.6.

1 стартмани

20.11.2020    6235    32    mic4    14    

Внешние печатная форма и отчет для 1С DRIVE

Печатные формы Платформа 1С v8.3 Конфигурации 1cv8 Абонемент ($m)

Внешняя печатная форма и внешний отчет, подключаемые в дополнительные отчеты для 1С DRIVE.

1 стартмани

02.11.2020    4675    2    hamsar    0    

Печать этикеток со штрихкодом из справочника Номенклатура и документа Поступление (акты, накладные) (БП 3.0)

Печатные формы Платформа 1С v8.3 Бухгалтерский учет 1С:Бухгалтерия 3.0 Россия Бухгалтерский учет Управленческий учет Абонемент ($m)

Внешняя печатная форма позволяет печатать этикетки со штрихкодом из справочника Номенклатура и документа Поступление (акты, накладные) (БП 3.0).

2 стартмани

27.10.2020    4581    14    Spektr    0