Битрикс24. Работаем с оффлайн событиями

Публикация № 829149 11.05.18

Интеграция и обмен данными - Внешние источники данных

Появление оффлайн событий упростило синхронизацию Битрикс24 -> 1С. Теперь, например, можно загрузить только измененные между сеансами обмена сделки. А не тащить все незавершенные. В статье описание, как это можно сделать.

И так: регистрируем приложение в своем Битрикс24. Как это сделал описал в //tf21.ru/public/574117/. Помимо прав на CRM дайте еще права на пользователей. В примере по ИД пользователя вытаскивается ФИО. А без прав будет ошибка.

 

Запустим обработку и внесем все регистрационные данные

Сохраните чтобы потом не вводить заново.

Первое, что можно попробовать, это получить список доступных событий. Жмите Получить список событий. Получим что-то вроде этого.

В примере используется событие ONCRMDEALUPDATE. 

Для того, чтобы события начали регистрироваться жмем Начать регистрацию событий.

Теперь перейдем в наш Битрикс24 и изменим уже заранее добавленные сделки. Например изменим статус.

 

Вернемся в обработку и прочитаем события

 

Можно завершить регистрацию и убедится, что после этого события не регистрируются, обработка ничего не вернет.

 

Теперь код. Процедуры ОтправитьRESTЗапрос  и другие используются из модуля описанного в предыдущей статье.

 

Получить список событий

Процедура ПолучитьСписокСобытий() Экспорт
	
	СписокСобытий = "";
	
	Ответ = ОтправитьRESTЗапрос("events", "");
	М = Неопределено;
	Если Ответ.Свойство("result", М) Тогда
		
		Для Каждого С Из М Цикл
			
			СписокСобытий = СписокСобытий + С + Символы.ПС;
			
		КонецЦикла;
		
	КонецЕсли;	
	Сообщить(СписокСобытий);

КонецПроцедуры

Начать регистрацию событий

Процедура НачатьРегистрациюИзменений() Экспорт
	
	Ответ = ОтправитьRESTЗапрос("event.bind", "event=ONCRMDEALUPDATE&event_type=offline");
	Если Ответ.Свойство("result") Тогда
		Сообщить("Ок");
	Иначе
		Сообщить("Ошибка!");
	КонецЕсли;


КонецПроцедуры

 

Обработка изменений сделок

Процедура ПрочитатьСобытия() Экспорт
	
	Ответ = ОтправитьRESTЗапрос("event.offline.get", "filter[EVENT_NAME]=ONCRMDEALUPDATE");
	Р = Неопределено;
	Если Ответ.Свойство("result", Р) Тогда
		
		Для Каждого С Из Р.Events Цикл
			
			Если С.EVENT_NAME = "ONCRMDEALUPDATE" Тогда
				
				// вытащу сделку
				
				Сделка = ОтправитьRESTЗапрос("crm.deal.get", "id=" + С.EVENT_DATA.FIELDS.ID);
				ИмяСделки = "";
				Если Сделка.Свойство("result") Тогда
					ИмяСделки = Сделка.result.TITLE;
				КонецЕсли;
				
				// кто менял
				Пользователь = ОтправитьRESTЗапрос("user.get", "filter[id]=" + С.EVENT_ADDITIONAL.user_id);
				ИмяПользователя = "";
				Если Пользователь.Свойство("result") Тогда
					ИмяПользователя = Пользователь.result[0].LAST_NAME + " " + Пользователь.result[0].NAME;
				КонецЕсли;
				
				
				Сообщить("В " + С.TIMESTAMP_X + " сделку " + ИмяСделки + " изменил пользователь " + ИмяПользователя);
			КонецЕсли;
			
			
		КонецЦикла;
		
	КонецЕсли;		

	
КонецПроцедуры

 

Вся документация по REST API Битрикс24 здесь

Обработка тестировалась на платформе 8.3.10.2580

 

Скачать файлы

Наименование Файл Версия Размер
Битрикс24. Работаем с оффлайн событиями. Пример обработки.

.epf 11,25Kb
50
.epf 11,25Kb 50 Скачать

Специальные предложения

Комментарии
В избранное Подписаться на ответы Сортировка: Древо развёрнутое
Свернуть все
1. script 126 11.05.18 22:32 Сейчас в теме
Спасибо огромное - продолжение будет?
2. user662672_explorer2000 217 14.05.18 08:23 Сейчас в теме
Добрый день! Продолжение о чем?
3. пользователь 15.05.18 11:56
Сообщение было скрыто модератором.
...
4. user662672_explorer2000 217 15.05.18 12:29 Сейчас в теме
Согласен, упустил этот момент, проверю. В текущем варианте скорей всего следующие 50 отработает при последующем запуске
5. пользователь 15.05.18 13:49
Сообщение было скрыто модератором.
...
16. novatrade 31.05.18 12:51 Сейчас в теме
(5)Это к Битриксу. Я думаю для регламентного обмена выше крыши.
19. amd1986 06.06.18 19:05 Сейчас в теме
30. berl 66 05.11.18 18:09 Сейчас в теме
(19) Для обхода ограничения в 50 записей используется параметр в запросе "&start=НачальнаяПозиция" где НачальнаяПозиция - номер первого элемента из партии в 50 шт.
При получении ответа в параметре .total находится общее количество элементов, и далее цикл
31. amd1986 08.11.18 17:00 Сейчас в теме
(30) я про другое имел в виду.
6. user662672_explorer2000 217 18.05.18 14:17 Сейчас в теме
Добрый день!

Метод crm.deal.get не списочный, к тому же доп. параметр clear у меня не передается и по умолчанию он равен 1. Т.е. после прочтения событий они удаляются. Для обработки всех событий (если их больше 50) можно доработать например следующим образом

Процедура ПрочитатьСобытия() Экспорт
	
	
	Пока Истина Цикл
	
		Ответ = ОтправитьRESTЗапрос("event.offline.get", "filter[EVENT_NAME]=ONCRMDEALUPDATE");
		
		Р = Неопределено;
		Если Ответ.Свойство("result", Р) Тогда
			
			Если Р.Events.Количество() = 0 Тогда
				Возврат;
			КонецЕсли;
			
			Для Каждого С Из Р.Events Цикл
				
				Если С.EVENT_NAME = "ONCRMDEALUPDATE" Тогда
					
					// вытащу сделку
					
					Сделка = ОтправитьRESTЗапрос("crm.deal.get", "id=" + С.EVENT_DATA.FIELDS.ID);
					ИмяСделки = "";
					Если Сделка.Свойство("result") Тогда
						ИмяСделки = Сделка.result.TITLE;
					КонецЕсли;
					
					// кто менял
					Пользователь = ОтправитьRESTЗапрос("user.get", "filter[id]=" + С.EVENT_ADDITIONAL.user_id);
					ИмяПользователя = "";
					Если Пользователь.Свойство("result") Тогда
						ИмяПользователя = Пользователь.result[0].LAST_NAME + " " + Пользователь.result[0].NAME;
					КонецЕсли;
					
					
					Сообщить("В " + С.TIMESTAMP_X + " сделку " + ИмяСделки + " изменил пользователь " + ИмяПользователя);
				КонецЕсли;
				
				
			КонецЦикла;
			
		КонецЕсли;		
	
	КонецЦикла;

	
КонецПроцедуры
Показать
7. novatrade 22.05.18 11:42 Сейчас в теме
А зачем проверка типа:
Если С.EVENT_NAME = "ONCRMDEALUPDATE" Тогда

Ведь Вы уже сделали выборку по данному событию?
8. user662672_explorer2000 217 22.05.18 12:34 Сейчас в теме
Верно, это лишнее. Может только для того, чтобы показать, что и имя события возвращается.
9. novatrade 22.05.18 15:03 Сейчас в теме
интересно было бы, если выборку делать по нескольким событиям, связанных с сделками. А потом разбор. В фильтре поставить "ONCRMDEAL%"
10. user662672_explorer2000 217 23.05.18 08:42 Сейчас в теме
(9) Проверил, все работает.

1. Регистрируем интерес к нескольким событиям

	Ответ = ОтправитьRESTЗапрос("event.unbind", "event=ONCRMDEALUPDATE&event_type=offline");
	
	Ответ = ОтправитьRESTЗапрос("event.unbind", "event=ONCRMDEALADD&event_type=offline");
	
	Ответ = ОтправитьRESTЗапрос("event.unbind", "event=ONCRMLEADADD&event_type=offline");


2. А забирать буду только события по сделкам

	Ответ = ОтправитьRESTЗапрос("event.offline.get", "filter[EVENT_NAME]=ONCRMDEAL%");


Приходят события и на изменение сделок и на добавление

По лидам события можно прочитать например так

	Ответ = ОтправитьRESTЗапрос("event.offline.get", "filter[EVENT_NAME]=ONCRM%");
11. novatrade 23.05.18 13:11 Сейчас в теме
Я работаю со счетами.
но что интересно - на каждое изменение счета приходят два ответа: Статус и Действие. И только на изменение статуса счета - только Статус.

Ответ = ОтправитьRESTЗапрос("event.offline.get", "filter[EVENT_NAME]=ONCRM%");

получите список всех событий для CRM - которые включены и произошли.
12. user662672_explorer2000 217 23.05.18 14:45 Сейчас в теме
(11) получите список всех событий для CRM - которые включены и произошли. - про лиды в контексте подписки только на 3 события. Если же думаю подписаться на все события CRM то да, будет так.

Про счета интересно, но наверное есть какой-то смысл в этом?
13. novatrade 23.05.18 14:59 Сейчас в теме
подписки только на 3 события. Если же думаю подписаться на все события CRM то да, будет так.
Ну это, чтоб потом не забыть, на что подписался))
задача моя выросла из стандартного обмена. Там получали счета. Потом уткнулись - то нельзя, это нельзя, то не нравится... Пришлось в REST ползти)))
14. novatrade 24.05.18 10:01 Сейчас в теме
А кто может сказать - какое количество оффлайн событий хранится? чтобы не потерялись?500? 1000?
21. amd1986 06.06.18 19:18 Сейчас в теме
(14) Очень много. Но если есть process_id он повторно не выгрузится. Насколько я знаю, периодически эта табличка очищается. Т.е. записи старше месяца с непустым process_id удаляются
15. novatrade 28.05.18 12:14 Сейчас в теме
подскажите - как в запросе описать фильтр по нескольким условиям с условием "ИЛИ". захотели получать новые сделки и счета сразу. Делать отдельные запрос по каждому виду - два запроса. Хотелось бы объединить в один. Заранее спасибо
17. novatrade 02.06.18 22:18 Сейчас в теме
(15) сам и отвечу - в batch объединил в один запрос, а потом обработал
18. amd1986 06.06.18 19:02 Сейчас в теме
Смотрю во всю используют функционал изменений. Это радует.
Скоро появятся новые события: по пользовательским полям компаний/контактов/сделок/счетов/лидов.
Имейте в виду, что есть ограничение в 2 запроса в секунду(с буфером в 100 запросов), так что рекомендую использовать batch
20. amd1986 06.06.18 19:15 Сейчас в теме
И еще. Описана простая схема. Она не подходит, когда нужна повышенная отказоустойчивость. Например, если не удается обработать событие, то событие повторно не получите.

Если не удалось загрузить изменение(ошибка записи например), то можно пометить запись изменения как ошибочное. А потом повторно его получить по запросу event.offline.get с параметром &clear=0&error=1
22. user662672_explorer2000 217 07.06.18 13:52 Сейчас в теме
(20) Безусловно в статье искусственный пример, возможно можно читать события с clear=0 а затем после обработки каждого вычищать его через event.offline.clear
24. novatrade 08.06.18 14:30 Сейчас в теме
(22)сколько обращений будет к сайту?
25. user662672_explorer2000 217 08.06.18 15:02 Сейчас в теме
(24) Хм, давайте накопим все обработанные ИД сообщений, а затем разом их вычистим, event.offline.clear как раз принимает массив message_id. Я так не делал, просто рассуждения
26. novatrade 09.06.18 15:43 Сейчас в теме
23. novatrade 08.06.18 00:01 Сейчас в теме
(20)я пишу в док, потом обрабатываю. Иначе никак. если стопорится, то при повторном обращении остаются необработанные события - они обрабатываются в первую очередь
27. goel 07.08.18 10:18 Сейчас в теме
Хотелось бы передавать себестоимость и выручку по Сделке (Заказу покупателя).

Если создать пользовательское поле в Сделке для каждой строчки товара, я так понимаю что делать надо через метод crm.deal.userfield.update?

Как указать значение до каждой строчки товара?
Как я понимаю параметры id данного метода подойдет для пользовательских полей в шапке документа, т.е. для статичных полей. А нам нужно, чтобы это действовало для табличной части товара (размер списка динамический). Как к нему обращаться при помощи данного метода?

Заранее спасибо, разработчики молчат 4ые сутки, проект стоит(
28. user662672_explorer2000 217 09.08.18 08:13 Сейчас в теме
В CRM - Настройки есть раздел Свойства товаров, думаю можно там добавить свойство Себестоимость. Выручка по идее должна быть в строчке сделки, но я там на первый взгляд не вижу возможности добавить поле.

Через crm.deal.userfield.update меняем пользовательское поле на сделке: название, тип, отображение и т.д. Не для изменения значения поля. Да и на мой взгляд это проще настраивать через интерфейс

Товары в сделке меняем через crm.deal.productrows.set - передаем сразу все строки товаров в сделке.

методы взял отсюда
29. user1073447 23.10.18 13:07 Сейчас в теме
Очень нужна интеграция 1с и битрикс - создание обычного счета и счета/оферты в битрикс, синхронизация с 1с, отладка автоматической интеграции номенклатуры и товаров между битрикс/1с интересуют сроки и стоимость, нахождение программиста в спб обязательно!
Оставьте свое сообщение

См. также

#KafkaЭтоПросто: Kafka Adapter 1С (Confluent) - отправляем сообщения

Инструментарий разработчика Внешние источники данных WEB-интеграция Платформа 1С v8.3 Абонемент ($m)

Сегодня поднимем в docker kafka с confluent'om, а в 1С, в EDT загрузим проект из репозитория, создадим обработку, в которой несколькими строчками отправим сообщение в kafka через rest proxy и в confluent control center посмотрим на него. Если коротко, то: как отправить сообщение в Kafka несколькими строчками кода без компонент, регистраций и смс.

5 стартмани

24.07.2022    3691    6    huxuxuya    24    

Консоль запросов SQL (управляемые формы)

Инструменты администратора БД Инструментарий разработчика Внешние источники данных Запросы Платформа 1С v8.3 Конфигурации 1cv8 Абонемент ($m)

Иногда требуется подключиться к другим базам данных для обменов, например: MySQL (сайты, интернет магазины), MS SQL, PostgreSQL (базы данных такие как 1С, WMS, других приложений) и т.д. Данная консоль поможет настроить и проверить подключение, выполнить любые запросы на языке SQL, а также если подключить обработку в конфигуратор использовать для обменов между базами данных с помощью языка SQL.

2 стартмани

04.05.2022    3500    25    nikolasx    7    

Консоль обмена по протоколу TCP

Внешние источники данных Обмен между базами 1C Платформа 1С v8.3 Управляемые формы Конфигурации 1cv8 Абонемент ($m)

Внешняя консоль-обработка, позволяющая осуществить обмен пакетами данных между любыми приложениями или устройствами по сетевому протоколу TCP. Консоль работает как в режиме TCP-клиента, так и в режиме TCP-сервера. Реализована с использованием стандартной библиотеки Windows "MS Winsock".

3 стартмани

10.04.2022    4301    17    Bassgood    9    

Загрузка данных из М-Аптеки+ в 1С:Бухгалтерия 8 (ред. 3.0) Промо

Внешние источники данных Файловые протоколы обмена (TXT, XML, DBF), FTP Платформа 1С v8.3 Бухгалтерский учет 1С:Бухгалтерия 3.0 Фармацевтика, аптеки Бухгалтерский учет Абонемент ($m)

Обработка для загрузки файлов выгрузки из программы для автоматизации аптек и аптечных сетей М-Аптека+ в 1С:Бухгалтерия 8, редакция 3.0.

11.07.2014    46923    75    1C_MApteka    44    

Практика OData. Пишем проводник по данным

Внешние источники данных Платформа 1С v8.3 Платформа 1C v8.2 Конфигурации 1cv8 Абонемент ($m)

Специалисты, начиная работать с OData, сталкиваются с трудностями с первых шагов - не очевидно какие именно данные может дать источник и какие механики доступны для формирования выборок данных. Так возникла идея написать обработку, которая позволяет проанализировать структуру и содержимое источника OData, а так же станет примером кода для всех тех, кто делает свою интеграцию на платформе 1С:Предприятие 8.

3 стартмани

11.10.2021    5339    18    Dementor    7    

Конструктор подключения к внешним источникам

Внешние источники данных Платформа 1С v8.3 Конфигурации 1cv8 Абонемент ($m)

Какую строку подключения использовать к новому источнику? Эта обработка позволяет создать и проверить множество строк подключения сразу.

2 стартмани

20.09.2021    4415    4    kraynev-navi    2    

Пример обмена данными через XDTO

Внешние источники данных Платформа 1С v8.3 1С:Управление нашей фирмой 1С:Бухгалтерия 3.0 1С:Управление торговлей 11 1С:Комплексная автоматизация 2.х Абонемент ($m)

Пример обмена данными между 1С и сторонним приложением посредством механизма XDTO.

1 стартмани

01.03.2021    11258    17    user925427    2    

Менеджер загрузки данных из весов с печатью этикеток Промо

Внешние источники данных Весы Склад и ТМЦ Платформа 1С v8.3 1С:Управление торговлей 10 1С:Управление производственным предприятием Абонемент ($m)

Программное обеспечение "Менеджер загрузки данных из весов с печатью этикеток" предназначено для автоматического получения данных по сети Ethernet из весов МАССА-К моделей ВПМ и ТВ_Р3 (модификация MF) в режиме On-Line.

1 стартмани

20.12.2011    33125    81    hrip    10    

Улучшенная обработка универсального обмена данными в формате XML (УФ)

Универсальные обработки Внешние источники данных Файловые протоколы обмена (TXT, XML, DBF), FTP Платформа 1С v8.3 Управляемые формы Конфигурации 1cv8 Абонемент ($m)

Улучшенная обработка "Универсальный обмен данными" с полноценными возможностями СКД для выборки данных (не только для отборов).

1 стартмани

23.06.2020    18324    186    Lem0n    1    

Загрузка товаров из внешних файлов в произвольный документ (УТ11, КА2, ERP; Розница 2)

Обработка документов Внешние источники данных Платформа 1С v8.3 1С:ERP Управление предприятием 2 1С:Управление торговлей 11 1С:Комплексная автоматизация 2.х Россия Бухгалтерский учет Управленческий учет Абонемент ($m)

Речь пойдет о том, как типовой механизм "Загрузки из внешнего файла" прикрутить к, по сути, любому документу, где есть табличная часть Товары. Пример приведен на Перемещении товаров, и с каждым документом может быть своя специфика, но общий механизм совпадет. В приложенном готовом варианте расширения механизм подключен еще к двум документам - Списаниям и Оприходованиям.

1 стартмани

15.04.2020    9418    60    erutan    30    

Пример загрузки сообщений из шины Apache Kafka

Внешние источники данных Платформа 1С v8.3 Конфигурации 1cv8 Россия Абонемент ($m)

Пример загрузки сообщений из Apache Kafka средствами REST API, который реализуется в рамках Confluent Platform.

1 стартмани

10.04.2020    5442    44    thueirby    0    

Что нам стоит Push построить Промо

Внешние источники данных Платформа 1С v8.3 Мобильная платформа Абонемент ($m)

Попробовал некоторое время назад, push сообщения, реализованные в платформе. Понравилось, но есть несколько минусов, на примере одной программы сообщений (не буду показывать пальцем), спустя некоторое время, сообщения переставали приходить онлайн, а на компьютере приходили моментально, при этом сами смартфоны звались флагманами. Читал позднее статью, где описывалось, что проблема на стороне смартфонов, что-то вроде технологий энергосбережения, но точно не помню. Также немалый минус доступно только для смартфонов.

1 стартмани

08.09.2016    35677    18    PloAl    8    

Google drive - менеджер файлов

WEB-интеграция Внешние источники данных Платформа 1С v8.3 Конфигурации 1cv8 Россия Абонемент ($m)

Синхронизация с гугл диском легко и просто!

10 стартмани

05.12.2019    30358    47    zykov_vitaliy    28    

Обновление расширений с Google Drive

Внешние источники данных Платформа 1С v8.3 Управляемые формы Конфигурации 1cv8 Абонемент ($m)

Предлагаемое расширение содержит обработку, которая считывает информацию с диска Google и при наличии новой версии производит обновление текущих расширений конфигурации.

1 стартмани

03.10.2019    9837    4    Sedaiko    4    

Получение изображения с IP-камеры

Внешние источники данных Платформа 1С v8.3 Конфигурации 1cv8 Абонемент ($m)

Получение изображения JPG с IP-камеры в виде двоичных данных. В 1С может применяться для фотографирования объектов.

1 стартмани

10.09.2019    19990    53    sivin-alexey    11    

Чтение файлов PDF из 1С

Внешние источники данных Универсальные обработки Платформа 1С v8.3 Конфигурации 1cv8 Абонемент ($m)

Насколько мне известно, у платформы 1С нет встроенных средств чтения на лету файлов PDF для их последующего анализа, и приходится использовать внешние инструменты. Об одном из таких вариантов и пойдет речь.

1 стартмани

09.09.2019    28353    76    da_1c    8    

Согласование задач из Outlook

Внешние источники данных Платформа 1С v8.3 Конфигурации 1cv8 Абонемент ($m)

Согласование задач непосредственно из почтовой программы, в моем случае Outlook 2013 без каких-либо дополнительных настроек. Из почты отправляется GET запрос к HTTP-сервису 1С, который в свою очередь выполняет задачу.

1 стартмани

06.09.2019    16320    19    duhh    17    

 Интеграция 1С и C#. Обращение к 1С через COM. Создание номенклатуры и выполнение запроса к 1С из C# на примере интеграции с Союз-PLM (система информационной поддержки жизненного цикла изделий). Обработка «Загрузка заказа на сборку». (ERP) Промо

Загрузка и выгрузка в Excel Внешние источники данных Платформа 1С v8.3 1С:ERP Управление предприятием 2 Абонемент ($m)

Союз-PLM представляет собой полнофункциональный программный комплекс для решения  широкого спектра задач управления инженерной технической информацией наукоемких изделий и сложных инженерных объектов в области машиностроения, приборостроения, архитектуры, строительства. На практике, это управление конструкторской документацией, интегрированное с САПР, бизнес-процессы, файловый архив. Все это работает в SQL и шевелится с помощью скриптов на C#. Скрипты свободно  отлаживаются в MS Visual Studio. Подробнее смотрите на их сайте: http://www.programsoyuz.ru/products/system-soyuz-plm.html  Редактирование, конструирование и использование бизнес-процессов на порядок лучше систем на базе 1С из тех, что я изучил.

1 стартмани

25.07.2016    60196    8    milkers    2    

Расширение Бром для интеграции с 1С

Внешние источники данных WEB-интеграция Платформа 1С v8.3 Абонемент ($m)

Из этой статьи вы узнаете, как можно быстро и просто синтегрироваться с любой конфигурацией 1С при помощи расширения Бром.

1 стартмани

06.08.2019    13478    5    itworks    24    

Конфигурация для обмена данными (интеграционная шина)

Внешние источники данных WEB-интеграция Платформа 1С v8.3 Конфигурации 1cv8 Абонемент ($m)

Система позволяет организовать обмен данными, как с базами 1С, так и любыми другими приложениями. Система представляет собой отдельную конфигурацию. Система позволяет организовать гибкие возможности по настройке обмена. В качестве брокера сообщений, для передачи данных, используется отдельная самостоятельная конфигурация на 1С. Комплект поставки содержит файл расширения для "клиентской" части шины, данное расширение позволяет без снятия "ключа" организовать гибкий механизм обмена данными.

4 стартмани

08.07.2019    26794    43    miha-28    17    

Пример работы с viber из 1С, отправка сообщений из 1С в viber

Внешние источники данных Платформа 1С v8.3 Конфигурации 1cv8 Абонемент ($m)

Обработка разработана для примера отправки сообщений в viber из 1С.

1 стартмани

16.05.2019    26815    117    Isa816    24    

Импорт из EXCEL и других источников (xls, xlsx, xlsb, ods, sxc, dbf, mxl, csv, clipboard, sql) в 1С Промо

Загрузка и выгрузка в Excel Внешние источники данных Обработка справочников Обработка документов Платформа 1С v8.3 1С:Комплексная автоматизация 1.х 1С:Бухгалтерия 2.0 1С:Управление торговлей 10 1С:Розница Беларусь Украина Россия Бухгалтерский учет Абонемент ($m)

-Наглядная, контролируемая загрузка иерархической номенклатуры с различными атрибутами и картинками из прайсов, файлов табличного вида xls,xlsx,xlsb,ods,sxc,dbf,mxl,csv произвольной структуры по указанному диапазону строк, а также из буфера обмена и внешнего SQL-источника данных в основные, дополнительные и пользовательские реквизиты. -Вариантный поиск номенклатуры. -Создание сопутствующей справочной информации. -Создание документов в национальной/иностранной валюте. -Обычное и управляемое приложение. Файл и Клиент-Сервер.

1 стартмани

16.03.2012    459948    7720    StepByStep    736    

Шаблон http-сервиса для вашего проекта

Внешние источники данных WEB-интеграция Мобильная разработка Платформа 1С v8.3 Мобильная платформа Конфигурации 1cv8 Абонемент ($m)

Http-сервис для обмена данными в формате JSON. Обработчики этого сервиса находятся во внешней обработке, что позволяет дорабатывать его без изменения конфигурации. Также прилагаю пример мобильного приложения для работы с данным сервисом (получает номенклатуру и остатки на складе). Сервис очень быстро разворачивается и масштабируется под ваши задачи.

3 стартмани

04.05.2019    31795    106    MarkoSokolov    48    

Доработка функционала отправки дополнительных реквизитов 1С: ЭДО для Татнефть

Внешние источники данных Документооборот и делопроизводство Платформа 1С v8.3 1С:ERP Управление предприятием 2 Бухгалтерский учет Абонемент ($m)

Подключаемое расширение к конфигурации ERP с функционалом отправки дополнительных реквизитов 1С ЭДО для Татнефть (№ и дата договора, подразделение, автор, примечание) в электронных документах Счет-фактуры и ТОРГ-12 Проверялось на 1С:ERP Управление предприятием 2.4.6.160.

5 стартмани

07.04.2019    17691    21    sapervodichka    12    

1С и Битрикс24, загрузка и прослушивание звонков в 1С. Интерактивно и через регламентное задание. Инициирование звонка битрикс из 1с (секретные команды).

Внешние источники данных СRM Платформа 1С v8.3 Управляемые формы Конфигурации 1cv8 Управленческий учет Абонемент ($m)

1С и Битрикс24, загрузка звонков, прослушивание в 1С. Распознавание партнеров, сотрудников, Контактных лиц. Отображается звонок во взаимодействиях карточки партнера. Добавлены коды битрикс из командной строки. Если запущено приложение для звонков битрикс, может инициировать звонок из 1с, хотя в API такой функции нет

1 стартмани

04.04.2019    12377    18    p.ugrumov    4    

Самый простой клиент ЕГАИС УТМ для розницы. $m Промо

Внешние источники данных Рабочее место Розничная торговля Платформа 1С v8.3 Конфигурации 1cv8 Россия Управленческий учет Абонемент ($m)

Данная обработка позволяет обеспечить приходную часть магазина розничной торговли алкоголем(ЕГАИС розница), или прочего предприятия. Эти действия становятся обязательными для розничного звена в городских поселениях с 01.01.2016 и будут достаточными до 01.07.2016. Предлагаю Вашему вниманию простое и доступное решение, которое позволяет отсрочить проблему интеграции ЕГАИС в розничное звено до указанной даты. (открытый код). Реализовано на открытой модели http://infostart.ru/public/402052/.

2 стартмани

14.12.2015    45648    8    Terrain25    47    

Работа с Active Directory из 1С (загрузка / выгрузка данных)

Внешние источники данных Платформа 1С v8.3 Конфигурации 1cv8 Россия Абонемент ($m)

Загрузка данных из Active Directory / Изменение информации пользователя в AD из 1С.

1 стартмани

26.02.2019    21738    150    Смешной 1С    9    

HTTP API Диадок. Загружаем в Диадок любой документ. Посредством POST и GET запросов

Внешние источники данных Платформа 1С v8.3 Конфигурации 1cv8 Абонемент ($m)

Поставили задачу через HTTP API Диадок (diadoc-api.kontur.ru) отправить любой файл в Диадок и подписать его (например, служебную записку в формате пдф). Посредством POST и GET запросов.

2 стартмани

14.01.2019    23261    79    John_d    17    

Исправление ошибки универсального обмена Бухгалтерия предприятия, редакция 3.0 (3.0.65.х, расширение конфигурации)

Внешние источники данных Адаптация типовых решений Платформа 1С v8.3 1С:Бухгалтерия 3.0 Абонемент ($m)

Уже у третьего клиента вижу ошибку Ошибка проверки данных XDTO: Структура объекта не соответствует типу: {http://www.1c.ru/SSL/Exchange/Message}Header Значит, как говаривал Винни-Пух - это неспроста. Ну и точно неспроста, 1С что-то подшаманили в обмене через универсальный формат.

1 стартмани

19.10.2018    32977    56    capitan    15    

7 причин, почему интеграция стала приятной. Не упускайте ряд потрясающих возможностей Промо

Внешние источники данных Мобильная разработка Платформа 1С v8.3 Конфигурации 1cv8 Абонемент ($m)

В статье показаны примеры получения данных без программирования на стороне «1С:Предприятие 8». Вам нужно проверить гипотезу и проанализировать данные, почему бы не интегрироваться с Excel? Используете технологии .NET и «1С:Предприятие 8», процесс связывания систем движется катастрофически медленно? Хотите native Android приложение с вашими данными всегда под рукой?

1 стартмани

01.10.2015    67077    52    pbazeliuk    23    

Внешние обработки-полуфабрикаты

Универсальные обработки Внешние источники данных WEB-интеграция Платформа 1С v8.3 Система компоновки данных Конфигурации 1cv8 Абонемент ($m)

На данный момент в публикацию включены внешние обработки-"болванки": для интеграции со сторонними системами на основе типового плана обмена; для вывода отчета по какой-либо проверке с последующей обработкой-корректировкой; механизм для создания универсальной настройки на основе отбора СКД (отбор на СКД, запиханный в табличную часть).

1 стартмани

16.10.2018    10694    47    Kutuzov    0    

Загрузка чека онлайн-касс (загрузка товаров из чека)

Внешние источники данных WEB-интеграция Кассовые операции Розничная торговля Платформа 1С v8.3 Конфигурации 1cv8 Абонемент ($m)

Обработка-пример, позволяет любому и из любой конфигурации загрузить информацию о товарах из чека(и не только) из почтового сообщения, отправленного из приложения ФНС проверка чеков.

2 стартмани

08.10.2018    34633    44    echo77    76    

Обмен 1С:Управление Торговлей 11 и Frontol 5

Внешние источники данных Розничная торговля Платформа 1С v8.3 1С:Управление торговлей 11 1С:Комплексная автоматизация 2.х Розничная и сетевая торговля (FMCG) Абонемент ($m)

Обработка обмена для 1С Управление Торговлей 11 и фронт-кассовой системы Frontol. Отличия от типовой: выгрузка дисконтных карт с накоплениями. Выгрузка категорий товаров.

3 стартмани

14.07.2018    34724    140    Kutuzov    169    

Загрузка документов из системы Emex через веб-сервисы (Коммерция-Автологистика) Промо

Внешние источники данных WEB-интеграция Платформа 1С v8.3 Оперативный учет 1С:Управление торговлей 10 Управленческий учет Абонемент ($m)

Обработка предназначенная для дилеров системы Emex, для загрузки документов из программы Коммерция(Автологистика) в 1С 8.2 Управление торговлей 10. Для загрузки используются веб-сервисы программы Автологистика.

10 стартмани

11.08.2014    26996    1    desarz    1    

ЕГАИС: Розница 2.3.* Удаление данных из УТМ

Внешние источники данных Розничная торговля Платформа 1С v8.3 1С:Розница Розничная и сетевая торговля (FMCG) Россия Акцизы Абонемент ($m)

В процессе работы с ЕГАИС периодически возникают ошибки на тот или иной Tiket. Чтобы удалить ошибочный тикет, можно воспользоваться утилитой Curl, но не все умеют ей пользоваться. Для удобства удаления "зависших" тикетов была написана небольшая обработка, которая периодически выручает.

1 стартмани

02.07.2018    10688    80    gigabyte-leha    7    

RabbitMQ + 1С. Быстрый старт

Внешние источники данных Платформа 1С v8.3 Конфигурации 1cv8 Абонемент ($m)

Внешняя компонента для отправки сообщения из 1С в кролика. Сервис прослушивания и перенаправления сообщений из кролика в http или web-сервис.

1 стартмани

10.06.2018    52989    142    Goleff74    46    

Экономим время на ввод операций в 1С: Деньги

Внешние источники данных Обработка документов Банковские операции Платформа 1С v8.3 Конфигурации 1cv8 Домашние учет и финансы Абонемент ($m)

Рабочее решение автоматического создания операций в 1С: Деньги. Основано на анализе СМС.

1 стартмани

14.05.2018    21654    18    vsbronnikov    29    

Оформление ветеринарных документов на продукты питания и грядущие глобальные изменения в 1С (часть 1) Промо

Внешние источники данных Оптовая торговля Розничная торговля Платформа 1С v8.3 Сельское хозяйство и рыболовство Оптовая торговля, дистрибуция, логистика Пищевая промышленность Управленческий учет Абонемент ($m)

С 01 января 2016 года возможно оформление ветеринарно-сопроводительных документов в электронном виде. Что это означает для предприятий, производящих и торгующих подконтрольной продукцией?

3 стартмани

27.12.2015    68878    7    axxell    28    

Интеграция с Redmine (Rest-API)

Внешние источники данных Платформа 1С v8.3 Управляемые формы Конфигурации 1cv8 Россия Абонемент ($m)

Интеграция с Redmine (Rest API). Тестировалось на 1С:Предприятие 8.3.12.1412 1. Получение списков Проектов, Трекеров, Статусов, Версий, Пользователей 2. Отбор задач по дополнительным полям (произвольные поля добавляемые пользователями в Redmine) 3. Получение Учета времени с отбором по пользователю и диапазону дат 4. Получение задач с различными отборами (гибкая настройка)

1 стартмани

28.04.2018    21536    66    lastpioneer    7    

Интеграция между Atlassian Jira и 1С:Предприятие 8.3 используя Jira REST API (выборка, создание и изменение запросов, чтение, создание и удаление записей о работах, чтение комментариев и другие возможности)

Внешние источники данных WEB-интеграция Платформа 1С v8.3 Управляемые формы Конфигурации 1cv8 Абонемент ($m)

Внешняя обработка на управляемой форме для 1С:Предприятие 8.3 по интеграции с Atlassian Jira используя Jira REST API. Ключевые функции: выборка запросов с использованием JQL; добавление и изменение запросов; добавление, изменение и удаление записей о работах; чтение комментариев к запросам; сохранение всех ключевых параметров между сеансами работы. Тестирование проводилось на платформе 1С (8.3.11.2954) совместно с JIRA Server platform (7.3.7)

1 стартмани

24.04.2018    51817    326    Ko1t    97    

Чтение и запись из таблиц гугл (google sheets) в табличный документ 1С (8.3, управляемые формы)

Внешние источники данных WEB-интеграция Платформа 1С v8.3 Управляемые формы Конфигурации 1cv8 Абонемент ($m)

Внешняя обработка на управляемой форме для 1С версии 8.3 для доступа к сервисам Google Sheets c использованием протокола авторизации OAuth 2.0. Выполняет получение списка листов таблицы гугл, чтение таблицы гугл в табличный документ 1С и запись из табличного документа 1С в таблицу гугл. Тестирование проводилось на платформе 1С:Предприятие 8.3 (8.3.11.2954).

1 стартмани

09.04.2018    63589    453    Ko1t    93    

Обмен данными с А&А Club. Ежедневный отчет Промо

Внешние источники данных Платформа 1С v8.3 1С:Бухгалтерия 2.0 Развлечения, искусство, спорт Россия Бухгалтерский учет Абонемент ($m)

Отраслевое решение для обмена данными с системой А&А Club и формирования ежедневного отчета о движении денежных средств.

1 стартмани

05.03.2012    32990    2    i.c.h    1    

Подписка на события, преобразование объекта в JSONAPI, отправка в RabbitMQ

Внешние источники данных Универсальные функции Платформа 1С v8.3 Конфигурации 1cv8 Абонемент ($m)

Обработка содержит функции: - сериализация объекта 1с в JSONAPI - отправка в RabbitMQ по HTTP

1 стартмани

26.02.2018    18587    24    yaxinr    7    

HTTP API Диадок. Пример авторизации и обращения к методам посредством POST и GET запросов

Внешние источники данных Платформа 1С v8.3 Конфигурации 1cv8 Абонемент ($m)

Поставили задачу через HTTP API Диадок (diadoc-api.kontur.ru) получить статус документа. Посредством POST и GET запросов.

2 стартмани

19.02.2018    28865    116    John_d    5    

Управление изменениями в планах обмена (Управляемое приложение) v 1.0 Промо

Внешние источники данных Обмен между базами 1C Платформа 1С v8.3 Конфигурации 1cv8 Абонемент ($m)

Простая в использовании и наглядная обработка для регистрации изменений или отмены регистрации в планах обмена используя гибкие возможности отбора СКД.

2 стартмани

15.08.2015    36628    56    kser87    3    

К вопросу об интеграции 1С и Битрикс24

Внешние источники данных Платформа 1С v8.3 Конфигурации 1cv8 Абонемент ($m)

Обработка реализует 4 метода из Rest API Битрикс24 - получение списка бизнес-процессов, получение списка задач, создание задачи и получение свойств задачи по ее идентификатору.

1 стартмани

19.02.2018    22509    123    bulpi    19    

[Расширение] Контекстная подсказка и автозаполнение данных используя DaData.ru без снятия с поддержки БП + УТ + CRM

Обработка справочников Внешние источники данных WEB-интеграция Платформа 1С v8.3 1С:Управление нашей фирмой 1С:Бухгалтерия 3.0 1С:Управление торговлей 11 1С:CRM ПРОФ, КОРП Абонемент ($m)

Удобно искать, выбирать варианты и заполнять справочники Контрагенты\партнеры\адреса по частям строк, адресов, ИНН, чему угодно, благодаря сервису DaData.ru. Подключается в режиме Предприятие, конфигурация полностью остаётся на поддержке. Не требует наличия подписки ИТС и загрузки КЛАДРа (ФИАС) в базу, при этом не отключает штатный функционал по автозаполнению.

2 стартмани

07.01.2018    24411    175    ipetrochenko    112    

Загрузка ОФД (ofd.ru, ofd-ya.ru, taxcom.ru, platformaofd.ru, ofd.kontur.ru, online.sbis.ru, life-pay.ru, modulpos.ru, 1-ofd.ru, Экспресс касса, subtotal.ru, sberbank.ru/ofd, chekonline.ru, initpro.ru)

Внешние источники данных Кассовые операции Платформа 1С v8.3 Бухгалтерский учет 1С:Бухгалтерия 3.0 Россия Бухгалтерский учет Абонемент ($m)

Обработка по загрузке файлов из основных ОФД. Возвраты вычитаются из внесенных денег. Тестирование проводилось на Бухгалтерия предприятия, редакция 3.0 (3.0.54.15)

1 стартмани

28.12.2017    25518    129    ikbokov    9